Help configure Xiaomi MJDPL01YL Smart RGB Bulb


I am new with Home assistant. I have managed to install it and configure it with some magic home leds without problems reading the tutorials and help here.

Now I am trying to integrate a xiaomi smart bulb model MJDPL01YL. I have read this bulb is a Yeelight Color Bulb V2. I have configured it without problem with Xiaomi Home and it works great.

I have also read that other models need to be configured with the yeelight app and must be enabled LAN Control.

I didn’t managed to get it working with the yeelight app. I have resetted the bulb several times without success. So, no show in Home Assistant. I have also tried configuration in configuration.yaml as shown in the tutorials without succeed.

Help will be fully appreciated.


@galgamo did you get anything?

No success.
I even unable to add the lamp to Yeelight app to enable LAN control. Android version doesn’t detect one, iPhone version detects but then fails to rename the lamp with ‘Name is too long’ error.
Is there any known way to enable LAN control for this lamp?

@MiguelAngelLV No. I was not able to control It.

I know there is a way opening It and flashing the eso but I’d rather not do it

Please let me know if you manage to control it in HA

@galgamo what’s the way to flash it is? Do you have any links to instructions?

Tried to connect it like Xiaomi Philips light by getting lamp’s token and configuring through xiaomi_miio integration. No success. Lamp is not autodetected, after specifying the exact IP address it stays unavailable. I think there should be a way to use it through xiaimi_miio, but requires further development.
Yeelight is not an option. There are no plans to support these lamps in Yeelight app as for now.

I was able to connect my MJDPL01YL by using a modded version of Yeelight app. It is modded for Russian language support, and maybe the thing is in its version(3.2.34) , it is older than the current version on GooglePlay. Try to find an older version, or you can try this. The LAN control option is there, but i didn’t tested. Here is a direct link.

UPD: Just got the bulbs working in HA, but had to add them manually.

1 Like

thanks for answering.
When i try to install the light, the app finds the light but can not install it. the app comes to 50% and then lost the actual connection and tested it 5 times. but I’m very curious how you made these work.

In my case, the original app was not seeing this bulbs at all. When I installed the older version all the lamps were already there. I think this is because I already added them in MiHome, and logined in Yeelight with the same Mi account and region.

Thanks! It works!

Things to do:

  1. Add a bulb to Mi Home app. I used German server for account creation.
  2. Download Yeelight custom apk mentioned above and install.
  3. Log in to Yeelight custom app using the same server and account. You should see there the bulb added to Mi Home.
  4. Enable LAN control as usual for Yeelight apps.
  5. Configure HA with yeelight integration. Example is listed below.
  6. Enjoy!

Finally the problem is solved. Thanks!

      name: ceiling_bulb_4
      model: color2

Hello @dmisavenko
I tried your steps.
Indeed I can see the lamp in the application.
I do fail to do #4, maybe because the language is in Russian and I can’t understand it.
Any idea what I should check?

Also, now yeelight bulbs are found automatically. Do you think this might have problem with the current integration?

Hi, try to use google translate app with another phone. after you have active LAN Control you will found them automatic.


No, google translate didn’t help, because the links weren’t on the “textual” parts.

So what I did was a bit different path, I describe the steps here:

  • Add the bulb in Mu Home app, using a european server. I selected Greece since this is where I live.
  • Download the Yeelight app version 3.2.34. I used this link from
  • Log in to yeelight app, select German account, not US. With US the bulb didn’t appear. With German it appeared properly. So country is important. You should see the lamp.
  • On the lamp page, click the button at bottom right the one that looks like an “eject” button. Then on the next screen, the last button “LAN Control” (the one with the lightnling).
  • Enable LAN control
  • Find the IP of your lamp.
  • From “Integrations”, select Yeelight integration. On the pop-up enter the IP.
  • Enjoy your lamp!

I see the light bulbs, but the LAN control menu is not available.

Did you go to the page with the controls? You can send a screenshot and help you there.

I found it. :slight_smile: I was looking to the left, it is there in the new app. Thank you!

Thanks! I’ve wanted to get this going for a while now, works perfectly after using your link Yeelight app :slight_smile:

I might grab a couple more of these next time they are on sale

Could be this tutorial used for Mi Smart LED Bulb (Model: XBMGDP01YLK)?
Tried it exactly but the bulb was still not visible.
Thanks for help.

Am I missing something?

I’ve done eveything but when I click to add the bulb it shows me this options

In my case, the bulb was already added