Migrate from Synology core package to HAOS?

Hi, I started with the HASS synology package (core) with already some configs (*.yaml modified “by hand” for phone presence detection, ikea tradfri etc).
But I really felt I was missing the supervisor and store features, so I installed a HAOS VM in the synology VMM; nice, now I have supervisor and add-on store.
But, how do transpose the configurations of the initial HA core install to the HAOS install? It seems the HAOS VM is a black box?
Or, should I do the geek install through the command line to have this access?

Just do the full backup on the old instance and restore from backup on the new one. If you have some USB devices (like zigbee or zwave sticks) it might require to manually update configuration with proper path to these, but everythign else should work. Testing cost nothing as you can still retain untact source docker instance.

1 Like

thanks for the fast answer!

Well… after thinking about this for a while, the trick might be to move the backup between instances… Normally best solution is to use SMB add-on… but not sure if you can install it on source? So some tinkering with SSH might be required…

I would be interested to know what exactly you seem to be missing from a container/syno installed HA. I am running HA for 1+yrs on docker, first on syno then nuc (wanted a dedicated machine) and never ever had the need for supervisor

Naively I was thinking there would be a non-command-line way to do a Core HA (non supervised) backup. I tried to use This method under "automated backup but no automation can be created: things flash by and disappear.
So is there is another way?
If not, what is the command to be used to get a backup?

And, following HA backup and adding a “backup:” entry in configuration.yaml file
gets me this message:
“Setup failed for backup: Integration not found.” in the configuration page ==> logs tab

Edit: Err, just saw that backup is only available in HA 2022.4. The synology core install package I have from synocommunity is 2021.7.
So, not possible.

Well, missing the supervisor. Not super at ease with the linux command line here.

I understand but I have never needed supervisor… cli will remain if you want something special and HA itself is not all that straight simple as well, just look at all the template type of programming topics in this forum.
So, I am not at all lobbying for docker because everyone has their own ideas/views but docker allowed me to get complete control over each of the modules, easier for testing, etc. …and go beyond with docker stuff HA does not have (e.g. deepstack)… it is a choice to ones liking and the good stuff is, you can try one way and then go another path (with a bit of effort)

@vingerha and @mirekmal so how do you backup the config on core HA? It has to do with tar certainly, but do you simply untar at the new config folder and crush everything that’s there? and how to access the config folder of HAOS running in the VMM?

I am using another docker-based solution Duplicati, quite simple to setup, with a good gui, allows picking of folders, writes to gdrive (and many more). btw. all the admin-alike containers I added to the HA gui as well, portainer, duplicati, influxdb
linuxserver/duplicati - Docker Image | Docker Hub

1 Like

Well, I do have my HA instance installed as standard VM in VMware ESXi free 6.0. I use standard, build in backup option, but since this is supervised installation this functionality is build in… so very easy to use. In th epast I had my installation on RPi, but it was also supervised, so no problme with backup and restore… I used this to migrate from RPi to VM.
From integration description it seems it should be very easy to be enabled, so I’m not sure how it comes you have these errors in the log.

Where did you found this information? I’m using backups since the beginning and I started ~3 years ago with v0.8x… it was always there!

in the link about backup above, an official HA doc page. It clearly mentions backup is available from 2022.4. So it seems backup is difficult to add to the HA core, version 2021.9.7 which is the only one available on synocommunity packages.
What’s all the more irritating, the new HA OS instance running on VMM asks for a backup. The issue is, I do not know what is the format of this backup, I bet it is useless to try tinkering with tar…

Oh, have seen this now in the side notes… Also checked release notes for 2022.4 and indeed it states that backup was previously available only for supervised installas…
Then then the question is why don’t you upgrade to 2022.4? Is there any other limitation to perform such upgrade for non supervised installs? Of course update from 2021.7 means skipping qiuite few versions and there might be several braking changes introduces in meantime, so while technicly possible might be troublesome to perform…

hi @mirekmal you just answered your question, I do not want to risk breaking HA core by updating it so much, as I have already some work done in this.
Having an unsupervised install is just a pain in the a… So many limitations!

Finally, I want to summarize what was successful:
0. I stopped the HA core instance through Synology package manager

  1. I could copy the config files of the HA core with the tar command through an ssh:

sudo tar -cf /volume1/mydir/config.tar .

( the dot is important as it means “current dir”, and yes this takes the hidden files in)

  1. expose the directories of the HAOS instance via samba so that they are accessible on the newtork (samba integration)
  2. copy/untar the content of the tar into the new config dir (I used 7zip on windows)
  3. restart the new instance
  4. tadaa, my HA core settings are now on the new HAOS instance

Step 3 may seem savage but it worked for me. It is necessary as if you stop the VM it is no more accessible on the network…
Thanks for all who helped, @tinkerer on discord and @mirekmal

1 Like

Glad to see you sorted this out! Seems it was quite a journey, though! One suggestion; would you mind to mark your last post as the solution? This really might help others, struggling with similar problems in the fututre, especially that way you handled initial backup is pretty generic for non-supervised installations!

quite a journey, yes! I lost quite a few figurative hairs on this, and went to bed a 3 last night.
It is now marked as a solution, thanks for the suggestion.
Have a nice day :grinning_face_with_smiling_eyes:

Good morning,
I’m almost in the same situation as you.
the only difference is that my synology nas is too old to accept the virtual machine.
what would be the solution to backup HA core and put it on another media that accepts HAOS?

Thanks in advance