Locked out /cannot sign in with correct username and password (after unsuccessful update?) HAOS on VMM synology

This will be a long post.
I installed HAOS into a VM on the official synology VM manager package on my synology DS218+ using the haos v6.0 OVA file (which may be part of the mistake if there was one, blindly following a tutorial). I could import my config from an older install and happily play with HA several days ago, starting telegram integrations and some.

I had kept my HA web interface open in firefox and this morning I tried to update (via the web interface in configuration menu) HA core (2022.04.6 to 04.7) and HAOS (6.0 to 7.6), apparently unsuccessfully. The HA restarted and now I am locked out of it, " Incorrect username or password".
It happens whether I access it through {VM_ip_adress}:8123 or homeassistant:8123 or homeassistant.local:8123 on firefox, my usual browser. My HAOS samba share is also impossible to sign in.
Here is what I tried:

  1. when firing up the HA console I first saw briefly a message such as “VFS failure” or something like that flashing by
  2. With this I tried to reset the password for all possible user names I could remember in the HA console (which I access through “connect” on the Synology VM Manager): I get an “unknown error, see supervisor” message on the console on the ha > prompt. .
  3. I tried auth cache in ha console and command executed successfully, no effect.
  4. I tried to clear cache+cookies on firefox
  5. I tried to access through Brave, my secondary browser (which I had not used before to access HA if I’m not mistaken)
  6. I tried to access the samba share files of HAOS (I work on win10), but the signing in is refused too
  7. I tried to ssh into {VM_IP_address} via an ubuntu console on my WindowsSystemLinux: connection refused. I haven’t tried all possible users name there through because I think it does not make sense.

I am totally lost, starting to loose my patience with HA, and would appreciate help!

I had seen the page you indicate, thanks, and tried to follow the indications from the linked page, as I indicated above.
Now, how do I shut down HAOS when it is running in a VM? If I shut down the VM, how can I access the auth files to delete them? Synology seems sketchy on that subject. Accessing the VM files does not give me access to the HAOS file system.
So, the only access I have to HA is the "ha > " console (CLI) prompt I get when connecting to the HAOS VM. and the ha auth command gets an error, as indicated above.

Try at the ha > prompt


  ha authentication reset --username "JohnDoe" --password "123SuperSecret!"