Mirabella Genio Smart Home

Thanks @afalzon for all the tips.

I tired the other flashing tools and I got the same result albeit with less verbose error messages.

I came to the realisation that my 5v FTDI is probably supplying 5v logic levels as well as power rails, so fingers crossed I’ve not fried that part of the ESP8266. I have ordered a 3.3v FTDI and I will try again when it arrives.

I haven’t had a chance to get to this yet… all my stuff is still in boxes after moving interstate but I just came across this as another OTA flashing option:


Interesting points:

  • I used an external power supply (2 AA batterries) while flashing, as the FTDI/USB/TTL board that I have outputs 5v rails even when the logic level is switched to 3.3v.
  • Follow the wiki article by @afalzon here: https://github.com/arendst/Sonoff-Tasmota/wiki/Mirabella-Genio-Bulb
  • I have a fine soldering iron and didn’t have to remove the board from the housing to get the wires attached.
  • When I had flashed the board the light flashed intermittently until I configured it to be a Arilux LC11 and then it all worked fine.
  • Its not up and running in HA yet, as I don’t currently have MQTT setup and need to do some config work there (all other bulbs are LIFX which I whole heatedly recommend as it much less messing around than this! :slight_smile: )
  • UPDATE: Turned on Wemo emulation and the bulb showed up in HA on its own. :smiley:

Thanks again to @afalzon for the support.

1 Like

@mikegchambers that is fantastic! with your FTDI did you have a jumper you can set to 3.3v?

as for the wemo idea, I haven’t played with that yet I will have to give it a go and see if its better than MQTT as i am having trouble getting the dimmer etc to behave.

Glad I could help :slight_smile:

There’s a tiny switch to change between 5 and 3.3volts on the signal wires.

I had GPIO0 on the ground rail of the breadboard and just unplugged that after 3 seconds or so.

From what I’ve seen so far the Wemo emulation acts as a switch, so it’s either on or off.

I got the cheapest Genio bulb, the 15 single colour unit, it can fade via the firmware page, but that’s as far as I have got.

I have attempted OTA with Tuya-Convert which I got to the stage of downloading the firmware but bricked one device because the first release used tasmota-minimal. The second bulb didn’t work with tasmota-classic - see this for the log

just saw this post - already tried and logged an issue

looks good @drushbrook, If you don’t get anywhere with the OTA you could try the FTDI to unbrick (if you have one / comfortable with that)

@mikegchambers what FTDI are you using?

yes I’m aware… The effort might not be worth it - the time taken vs. $15 from Kmart for a replacement

1 Like

This is true but I don’t like to let these things win! :smile:

@afalzon I used this serial adapter to flash the bulb: https://www.jaycar.com.au/arduino-compatible-usb-to-serial-adaptor-module/p/XC4464 (again, powering the bulbs chip via 2 AA’s)

@drushbrook it’s all almost certainly not worth it, and if you end up buying replacement bulbs you should just go with LIFX, they work with HA out of the box, and you don’t have that ‘should I leave them powered on or will they burn down my house’ kinda feeling after you broke them open.

My take on these Genio bulbs is that while they are around 1/2 the price of LIFX, they are around 1/2 as good. So they have the same value but less utility. Also with LIFX you can control them via the mobile app Alexa, Google Home and HA all at the same time, and there is an API for your own stuff, so super flexible out-of-the-box.

1 Like

Was able to recover my flash and now it is working. Will attempt another bulb OTA using tuya-convert soon!!!

Do you mind if I update the wiki page with OTA instructions?

1 Like

Go for it,
That’s what the wiki is for, every can contribute to share their knowledge!

@mikegchambers I agree, I just hacked it coz I wanted to!

I have found the tplink bulb good too, no cloud services to deal with!

1 Like

Thanks for the suggestion - I have a number of LIFX bulbs already and agree the quality and out of box capability is better. It is true you get what you pay for :slight_smile: .

I purchased the mirabella bulbs because they were slightly smaller then the LIFX bulbs thus fitted better into my eldest daughter’s light fitting. She had been pushing me to make it possible for her to say to her Google Home to turn of the lights.

The tuya platform does have support for both Alexa and Google Home in a similar way to LIFX however I’m trying to move it away from too many cloud services especially ones which track a whole stack of data on your location etc. It also has an undocumented api which a number of people have figured out.

The ultimate goal which I have now been able to do was to flash tasmota to them over the air and thus have full control of the bulbs without opening them. The bricked bulbs/plugs I have were well worth the money.

This all started early December when I got a few of the ALDI SmartPlugs and watched as people were flashing tasmota to them via serial. Fortunately (unfortunately for Tuya) there was a bug in the original firmware making the plug turn off randomly and hence required a firmware update. After searching around to see if anyone had worked out the OTA process I decided to capture the network traffic of the upgrade process - see https://github.com/codetheweb/tuyapi/issues/49#issuecomment-444831417 . From that someone worked out the flash header format and successfully built an OTA upgrade process. A couple of days someone sent me a message telling me about the tuya-convert which appears to be more advanced than the guys who had written Tuyota and MockTuyaCloud had got to. By the way I had updated all the ALDI SmartPlugs to tasmota also.

My next challenge is to get the Sengled Bulb I purchased from Bunnings to work with zigbee2mqtt


Thanks for the OTA instructions, they look great!
I might have to give it a go now! :smiley:

make sure you download the sonoff-tasmota-basic firmware because the current repository doesn’t include it.

Looking good. :slight_smile: I will take a look at the OTA stuff.

@drushbrook Just a quick note on size, did you take a look at the LIFX mini? 60 x 60 x 105 mm which is basically the same size as the Genio.

Happy Aussie Day to Everyone