MISCELLANEOUS NetAtmo Smart Thermostat

Tags: #<Tag:0x00007f77fd5d5328>

Hi,

I’m writing this topic to discuss about general questions around pairing a netatmo smart thermostat with HA.

The goal of this topic is to collect infos around HA users/netatmo themostat owners by discussing about our experiences while configuring a whole setup.

I want to start with three main interrogations I have around this :

1/ Pairing Mode :
My HA runs on a wm using the wmdk provided here https://www.home-assistant.io/hassio/installation/

As soon as I had my wm and HA running for the first time, my NetAtmo thermostat (already paired with the relay) displayed the HomeKit pairing code.
Since then, it has never stopped displaying this code! Even if I put off the batteries (the datas displayed on screen disappear slowly), put them back, the thermostat displays the control and current temperature as usual for some minutes and then changes its display to the pairing code over and over.

Is this an expected behavior when paired with HA?

2/ Discovery Mode :
The netatmo relay appeared since the very first time my vm started running, as a new discovered integration.
But, when I want to configure it, and enter the pairing code I can see on the thermostat display, HA tells me “Device refused to add pairing as it is already pairing with another controller.”

This issue is probably related to my first question?

3/ config.yaml :
I added “discovery: false” into it.
Is this normal that when I go to to Configuration/Integrations/ I still can see my relay in the “Discovered” section?
(and from there, if I try to configure it, I go through the same issue described in 2/)

Many thanks for your help, fell free to close this topic if it is duplicate and the answers are already given in other existing topics

Graou

1 Like

@graounest Have you been able to solve this? I am facing the exact same situation: since I fired up my hassio server, my Netatmo thermostat is displaying nothing but a pairing code (which is driving me nuts!) and if I try to configure the Netatmo in hassio, it’s telling me that “Device refused to add pairing as it is already pairing with another controller.”.

Need to mention that I’m very new to hassio, I’ve just installed it yesterday on a brand new RPI 4 because I heard so many good things about hassio. Well, it has been giving me nothing but grief ever since and this Netatmo problem is just one of them. Do you know how I can make the pairing code go away from the display of my Netatmo thermostat and possibly even make Netatmo work with hassio?

Thanks!

Also, if you try to add the Netatmo API key to the hass.io integration, the main thermostat freezes and does not register changes in the room temperature until you remove its batteries.

I was eventually able to set up Netatmo climate in hass.io with an alternative approach (not with the automatic detection), following the instructions from here:
Home Assistant Netatmo instructions
This required setting up a custom application in my Netatmo account and getting the ClientID/ClientSecret from it.
It also required adding the following section to my configuration.yaml in hass.io:

# Netatmo
netatmo:
  api_key: MyNetatmoAppClientID
  secret_key: MyNetatmoAppClientSecret
  username: MyNetatmoUserName (email address in my case)
  password: MyNetatmoPassword

However, the auto-discovered Netatmo integration through WebKit is still nagging me, it did not realize that Netatmo is already set up, so every few hours it happily tells me that it has discovered the new “HomeKit Accessory: Netatmo Relay”.

And the biggest problem of all, my Netatmo thermostat is still in pairing mode after more than a day and the only thing that it shows on its screen is the pairing code. I wrote to Netatmo support to see how to get rid of that, but they did not reply after 24 hours.

Netatmo devices are supported via HomeKit as well as the ‘native’ integration. I would not suggest to use both at the same time.

Thank you! I do not want to use both, I want to get rid of the HomeKit integration, I just don’t now how…

Just navigate to Configuration -> Integrations, select the device you want to get rid of, and click the trash can icon in the top right corner.

Thanks, but that does not work because the HomeKit stuff is not yet configured, just discovered. I cannot configure it because it’s giving me the “Device refused to add pairing as it is already pairing with another controller.” message.

The solution to make the Netatmo main thermostat go back to normal operation and stop displaying the pairing code is to reset the relay (the device which is connected to the boiler by cable). You do this by holding the thin long button at the bottom of the relay for approximately 20 seconds (until the LED stops blinking). After this you go into the Netatmo app, you’ll see that it cannot connect to the boiler anymore. Click “Setup Wifi” and follow the instructions to re-initialize your relay. Your settings and historic data will NOT be lost.

So my only remaining problem related to Netatmo is that Home Assistant keeps discovering it as a HomeKit device even though it’s already set up natively.

So… does anybody know how to prevent Home Assistant from discovering the Netatmo thermostat as a HomeKit device on every boot? (because it was already configured “manually”)

Sure.

# Example configuration.yaml entry
discovery:
  ignore:
    - homekit

Won’t that ignore all HomeKit devices (not just Netatmo)?

That is true, but this issue is going away with the next release in January.

You mean the issue of nagging discovery message is going away or the issue of not being able to specify exactly what to ignore within HomeKit is going away?

Netatmo will become discoverable. You can join the pre-beta test group if you have a separate test instance. In case you’re curious, just drop me a PM or contact me in Discord.

Thank you for this great news! I don’t have an instance which I’d like to jeopardize, so I’ll wait for the release with great interest and anticipation :slight_smile:

1 Like

I’ve upgraded today from Ha v0.103.6 to v0.107.7 and surprise, surprise, Netatmo integration became broken. I’ve figured out that I had to remove the user name and password from the configuration.yaml and rename the client_id and client_secret, so my config now looks like this:

netatmo:
  client_id: ****
  client_secret: ****

however, no thermostat or radiator valve is showing up on the UI as before. Seems that they are not auto-discovered. How can that be achieved?

Please check the integrations page for your devices.

Thank you!

I’ve solved it in the end by deleting the Netatmo configuration from the config.yaml and enabling it through the HomeKit auto-detected integration. Otherwise it was still nagging me after each boot that it found a new device, now that message is finally gone.

Is there any advantage of any of these two integration alternatives of Netatmo? Through HomeKit or through config.yaml?

Those are different things. I can’t comment on the home kit integration. What devices do you have? Once Netatmo integration is in place should actually stop homekit advertising this device.