Missing Hass.io Tab

Hi all

I decided to start afresh with a new installation of the Hass.io release.

It installed uneventfully, however when comparing to the version in Ben’s video, my version is missing the HASS.IO tab in the home assistant home page.

I downloaded the version “resinos-hassio-1.0-raspberrypi3” and followed the instructions.

Is there something I need to activate to get the tab to appear?


Add hassio: to you configuration.yaml file and it will return


Hi @ward0112, search the forum for ‘hass.io menu’ and you will see. :slight_smile:


To access my configuration file, I need samba installed which I was planning on doing after enabling it via the HASS.IO tab.

With the new version, is it okay to install samba the old way via putty? Or is there another way to access my config file?

You mean there’s no Hass.io menu after a fresh install? Sorry, thought you have already edited the configuration file.
Maybe @pvizeli missed something in the image.
Don’t know if you can access the OS via putty.
I would look on the SD Card (where you wrote the image) for the configuration.yaml and edit it.

On the original image with no changes made is a strange one, as you’d imagine it would be the same image for everybody. Unless something has changed with the image very recently.

If you connect your SD card to a PC and it lets you access the configuration.yaml (never tried it personally) that may be the way to go

Yeah it is definitely a fresh install downloaded from the installation shortcut. I assume the configuration file is the default one.

I will try accessing my SD card directly on my PC. Although last time I plugged in my microSD card, windows was whining that the card needed to be formatted, and the files on the disk were not in the structure I recognised from my previous home assistant file structure.

I have plugged in my microSD directly into my computer, but there are bunch of files such as bcm2708-rpi-b.dtb, and only one folder labelled overlays.

There is one file labelled config, but it has the following in it which doesn’t appear to be the config for home assistant

For more options and information see


Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default “safe” mode


uncomment this if your display has a black border of unused pixels visible

and your display can output without overscan


uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border


uncomment to force a console size. By default it will be display’s size minus



uncomment if hdmi display is not detected and composite is being output


uncomment to force a specific HDMI mode (this will force VGA)


uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes


uncomment to increase signal to HDMI, if you have interference, blanking, or

no display


uncomment for composite PAL


#uncomment to overclock the arm. 700 MHz is the default.

Uncomment some or all of these to enable the optional hardware interfaces


Uncomment this to enable the lirc-rpi module


Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)


I vaguely recall Ben having a video where he describes how to edit your config with out a samba share via WinSCP, will see if I can track it down

Right - managed to get access to my home assistant config file via WinSCP.

I tried adding


to the config file, but I am unable to get permission to edit this file
I have tried some suggestions in WinSCP (in advanced options under environment>shell changing it to sudo su-), but I stil can’t get permission


After some advice from discord, I redownloaded the image and installed it again (for the third time).

Once I had done this it worked as advertised

Hi! I have Hassbian but I don´t see the “HASSIO” tab in my home assistant, I´ve alredy add the hassio: to the configuration.yaml but still don´t work. How can I fixed it? Hassio is alredy installed with Hassbian or do I need to install it over hassbian?

Hass.io is a totally different thing to Hassbian. You cannot mix and match.

So is not possible to add hassio tab to home assistant having Hassbian installed?

No, is the simple answer.

The hass.io tab is for hass.io configuration, you don’t have hass.io, so you don’t get (nor need) those configuration options.

Same problem, no hass.io tab, after a new fresh install, installede 2-3 times same result.

What to do

If you are installing home assistant via ANY other methods than flashing HASSIO to an sd card, then you WILL NOT have a hassio tab. It is that simple. If you installed home assistant manually, or if you installed hassbian, you WILL 100% NOT have a hassio tab, because you are not running hassio.


Thanks for reply

I only flash to sd card.

Downloaded latest Pi 3 image, and followed the guide, and after some hours -> 0.61.1 but no Hass.io Tab

What guide?

What image?

With HASSIO you literally just flash an sd card and boot it up…if you performed ANY other steps that involved SSH/command line, python, or anything of the sort, you didn’t install HASSIO.

now SSH/command line or python


Download Hass.io image for Raspberry Pi 3
Download Etcher to write the image to an SD card