Mobile app 2022.11.0-full slow lately. Solved after reset but now slow again

About a week or so ago I had a very slow app. Rebooted HA, rebooted nginx manager but nothing helped. I then reinstalled the companion app and it was lighting fast again.
The downturn was that all my widgets were gone, had to redo them.

But no I am facing a bizarre latency upon opening the app again.

What happens (internal or external):

  1. I open the app (from a fully closed state)
  2. Whit blank screen for about 3 secs
  3. Blue logo for about 5 secs
  4. Loading data appears for 5 secs
  5. Blue topline for about 2 secs.
  6. Square message “unable to connect” with 3 options for about 1 sec
  7. Normal operation

I also referenced it here:

I never had these issues, and I believe it started with the version of 2022.11.0.

What’s wrong?

1 Like

I have exactly the same problem, i’m not sure if its related to 2022.11. I also got an update to android 13 a few weeks ago.
The app takes very long to start and is also slow after starting. Loading the ui on the same device in the browser is fast.

In the logs of the app during the start there are two times 3 seconds where nothing happens:

01-09 10:51:20.301 14812 14864 I WM-WorkerWrapper: Worker result SUCCESS for Work [ id=2a872883-affc-4192-b5bf-d55eec8b8c35, tags={ } ]
01-09 10:51:20.301 14812 14812 D ConnectivityManager: StackLog: [] [] [] [] [] [] [] [$]
01-09 10:51:23.117 14812 14812 D [email protected]: updateSurface: has no frame
01-09 10:51:26.247 14812 14812 D [email protected]: updateSurface: has no frame
01-09 10:51:29.143 14812 31333 D WebviewActivity: External bus {"type":"config/get","id":1}

Seems to be solved now after the update of the app to 2022.12

Anyone else still having this issue?

Web UI is ultra-fast nearly instant in a mobile browser, but Android app 2012.12 is ungodly slow. Sometimes a force-stop + clear cache will briefly fix but it comes back.

Mine seems to take minutes to load and once it comes up it takes 10s of seconds to navigate menus and such. No idea why.

Yes, actually I still have the problem. After an app update it’s fast again, but then it gets slower day by day.

Here too. But when I reboot the entire phone its gone for a while.

It never was this way before.

Same Problem here. App gets slower every day.

I have the same Problem.

My workaround is:

  1. Open Home Assistant in Google Chrome
  2. Klick on the three Dots in the upper right corner
  3. Select “Add to Homescreen” (kind of, for me it’s German)
  4. Google Chrome will install a WebApp on your Homescreen. For me it is very responsive and I don’t miss any features. The WebApp locks like the real App, without the chrome Browser Stuff. The only problem is, you don’t have your android device sensors

Just adding that I too have the same issue. For me it started relatively recently (2-3 weeks). App is nearly unusable it’s so slow yet the webapp works fine. This is on android with companion app version 2023.1.1-full on Android v13.

I tried clearing cache but that had no effect.

Same here for me.

I would like to join the ranks. Unfortunately, I have the same problem and have not found a solution yet. Home Assistant works perfectly in the browser.

Same problem for me. The companion app has worked brilliant until recently it takes a lot of time to load the connection and build the displays.

Was having a similar problem, I’ve updated to 2023.2.4 and it seems better.

Same here… Maybe it’s after the update to Android 13, but not sure. When I reinstall the app, it works for a day or so really fast, but then it slows down again. Changing the connection url to external or internal doesn’t fix it.

Could Android Sytem Webviewer be the culprit?

I have been experiencing this as well for a few months

I am experiencing this as well. Started some time ago. The app will randomly run extremely slow and often time out when loading. Any automations that depend on the companion app will also run super slow. Like one I have based on if I am in my home zone. When the app is running slow, I can pull into my garage and walk inside the house before it triggers. Normally it triggers before I even pull into the driveway. Notifications to the app are similarly delayed, taking more than a minute to popup sometimes.

Clearing app cache seems to fix it once or twice, then it goes back to being slow. But it also isn’t slow all the time. It happens seemingly randomly.

Loading HA via a browser locally or via Nabu Casa remote always works fine, it is only the app.

I am using Amazon Fire HD 8" and recent weeks if not months now, it is getting SO SLOW!
as per the topic I just installed Android System Webviewer -lets see if that changes anything because it is now simply UNUSABLE!

errors from HA:
2023-03-05 08:28:21.266 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection] [547784020016] firehd from (Mozilla/5.0 (Linux; Android 9; KFONWI Build/PS7327.3326N; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/108.0.5359.160 Safari/537.36 Home Assistant/2023.1.1-3124 (Android 9; KFONWI)): Client unable to keep up with pending messages. Stayed over 1024 for 5 seconds. The system's load is too high or an integration is misbehaving

I bought the exact same device a few months ago and did not face any performance issue till the last few days. Similar to the other complaints the app runs butter shortly after reinstall, but slows down a lot after that.
I switched from the HA app to WallPanel (like Fully Kiosk Browser, Open Source and similar sonsor features like the HA app)