Home Assistant Community

Mobile App Notifications

#1

I know there was a change to something relating to mobile app / iOS notifications but I haven’t seen anywhere to say what the correct service trigger is to send a notification to the new mobile app.

Using

notify.mobile_app_my_name
{“message”: “hello”}

I get the following error Requested entity was not found.

I have pushed the notification token from the device and restarted home assistant but still no notification

Old iOS app works fine still.

#2

The new build just dropped (build 50) and has fixed notifications. However the same build might break everything else (like device tracking and/or sensors related to that device). This is the case for me (fresh HA install).

#3

Build 50 is broken. 51 eta is 3 hours.

1 Like
#4

My app (51) keeps crashing when trying to open. I have tried to uninstall and reinstall but same
I am on iOS 12.2 on iPhone 6

#5

Build 51 has issues too (I have 51 too). Notifications seem to work again which broke for me after build 40. However now device tracking and all other sensors that should get updated by the app are no longer working :smile:

So the one thing gets fixed while the other breaks haha. Well that is why it is called a beta though. I’d suggest waiting, most of these problems are already issued on github as far as I saw.

If you heavily rely on the app though, you might want to revert to build 40 (or the stable 1.5 app).

Me I’m having too much fun playing around with the new features like haptic feedback. Fortunately I have other device trackers so for me it is just a minor issue, notifications are working again.

#6

Is it crashing while your phone is not on WiFi? I believe there is an issue with the (work in progress) onboarding currently. My understanding is that you need to launch the app on Wi-Fi and then head to Settings -> Connection in the app and manually add an external URL.

Or if you’re away from home you can do the opposite, reset the app to go through onboarding again, do manual setup, and only enter your external URL.

Hopefully one of those things works for you.

#7

I havent got the chance to check out notifications after the update because of the crashes.
I have 1.5.1 running as backup, so no problem at all :slight_smile:
I havent tried out haptic feedback yet but guess it is pretty cool.

#8

It crashes on both away and on wifi.
The app crashes before I can get to seetings or reset it. But I tried to uninstall and reinstall without success.

#9

Build 52 was released like one hour ago. This has fixed all integrations for me, notifications, device_tracking, other sensors. The whole bunch.

This app is becoming really great now. Out of curiosity I just wonder what the benefits of firebase are?

Anyways great work @robbiet480

Edit: typo

#10

I guess you mean 52 :slight_smile: but after the update mine now says “URL unavailable” during startup and I can only choose “quit app”.

1 Like
#11

You are correct, I meant 52 (I edited my post). Anyways, did you read the change log? It says something about this URL.

ALERT: If you don’t use Nabu Casa cloud an external URL won’t be set during onboarding. You must set the URL in Connection Settings After onboarding.

I don’t use Nabu Casa and I was at home when setting this up, so I can’t say for sure. From within my wifi network it got discovered. It is working on 4G as well. I use my own domain name (no letsencrypt or dyndns).

#12

Yes I read the change log but I can´t enter the app at all and change the settings.
I have tried both on wifi and on cellular.

#13

Reinstall app

#14

Allright, the steps I took to make it work, you might have done it already. But never hurts to try again :stuck_out_tongue:

  • Remove integration from HA (at the frontend)
  • Restart Home Assistant (this is required to remove the previous integration)
  • If it is possible to open the app, then go to “app settings” (found in hamburger menu) and then reset the app.
  • If it wasn’t possible to open the app, remove the app from your device. (to be really sure nothing stays you could restart your device, but I don’t think that it would be necessary)
  • Reinstall the app from Testflight
  • Start the onboarding process again.

If by any chance it won’t work again, try to make sure your Home Assistant instance is available and that the frontend is reachable (you could use safari to try this or any other browser for that matter, preferably one that isn’t connected to your wifi network).
If it is reachable then try to look in the logs (you can do this from another browser, or if you have access to the files, you could just see the log files or if you do it by SSH you could copy the logs from there as well)
If there is an error, post it here (or create an issue on GitHub).

#15

I tried uninstall, restarted the device and reinstalled the app. Same result.
It shows the blue screen then draws a Little bit of the house and then the error message shows.

#16

-I tried to remove the integration and restarted HA.
-It is not possible to open the app.
-I uninstalled the app, restarted the device and reinstalled the app.
-Still only quitting is an option.

Should the app not start regardsless if there is a connection to HA or not?

I can fine reach HA through app 1.5.1 also on 4G and. Chrome on my pc also Works.

What logs are you thinking of? Just the normal one from the “about” page?

#17

That could be a start, but I think you might need the log files. The easiest way to get them is to go to your configuration folder (the folder where all your configuration files are stored like configuration.yaml and ui-lovelace.yaml).
There is a file there that is named home-assistant.log all errors will be logged here. I think it gets reset after each restart to keep it clean, but I never had to use the logs before as most of the time I have the console open anyways.

But the way you say it, there might be no logs on this if the app isn’t able to do anything at all. Could you maybe send screenshots of every screen you see from scratch? It might also be good to know which device you are using and what version of iOS you are running.

I am not really good with iOS apps, so I can’t tell you much about it, but all these little details might help give me (and anybody that reads this) a clearer image of what is going on.

One thing I do know is that iOS has it’s weird stuff as well and sometimes things won’t work for no obvious reason. Crazy thing is that some of these things can be fixed by restoring the iPhone with a fresh version of the latest iOS, it sounds silly, but it really helped my out many times in the past. If you store your photos on iCloud or another external source I’d suggest setting the iPhone up as new (without the backup) and pull the contacts (and other important data) from iCloud.

I know it is a big pain in the backside to do something like this, especially if you hold a lot of data on your device. But even so, if you have used the same backup for years, it would be a good idea to do this. I know people that still use the same setup as they had on their iphone 4, so they copied their old stuff to the new over and over again.

Oh, btw do you have any other iDevice like an ipad (that can run iOS 12) or another iphone maybe?

#18

Still not working for me on the latest. Same error as main topic. I do seem to have two mobile device integrations despite only one phone. The intervention with suffix 2 says unknown.

I will delete all and try again. I understand it’s beta so this happens but it’s frustrating the onboarding doesn’t look for existing devices and instead just creates new.

#19

@jeppper a new version has dropped, it might have fixed your problem. (Build 53)

@eximo84 you will have to remove the integration via the Home Assistant UI, remove both the integrations, restart HA. Reset the app (or simply reinstall it) and start the onboarding process again. Note that device trackers will not be removed upon removing the integrations. (You will have to do this manually by going to your known_devices.yaml file)

#20

Same for me. Everything, except for notifications, was working great. I always got the same error message: Requested entity was not found

I removed all integrations, restarted HA, and tried to redo the onboarding. Hangs now on “Configuring sensors” :disappointed_relieved: