Modbus scan_interval configuration

I had this modbus configuration:

      platform: modbus
      scan_interval: 2
         # LIGHTS
        - name: my_light_1
          slave: 1

This was working fine. Response times were quick, the app was very responsive.
When changes were done, HA noticed them straight away.

Now recently made an upgrade to the latest versions of Home Assistant (2021.4.3 now 2021.4.4), and the responsiveness is lousy. Seems this scan_interval is not taken into account anymore. I see more response times around 10 seconds instead of 2 seconds.

I have been looking in release notes but nothing caught my eye on this topic.
Any clues?

Thank you for your help.

2021.4 brought some changes to the modbus integration, check the changelog again.
Try updating your modbus to the new definition. They said, that for now the old style is still supported, but maybe that is causing the issues you observe.

Thank you for the hint. They do not mention a “scan_interval” change in there but indeed, some things have changed. And it looks like they moved scan_interval from the global to the sensor level.

I have the same issue with the new modbusintegration. After the upgrade, I changed my modbus sensor config to the new format, which broke my HA setup complettely.
After a restart, HA runs fine for a few minutes until the mainthread gets blocked, integrations start to timeout,… I was forced to remove the modbus sensors completely.
Today I’ll check if it helps to rollback to the old configuration style.
I’ll file an issue on github later when I find the time.

Interesting. In my case I only observe a very slow scan_interval. Functionally things are still working.

where can i now change the scan interval… it’s very slow actually… takes about 15sec until my Automation get started after the Signal was set to my Modbus PLC

Same happens here. If i read 2-3 registers it works ok. But if i add 10-20 registers it works for you some minutes then home assistant starts to timeout and then crash… If i remove modbus it works fast and fine… Did you do any request?

Hi, I commented on Github, see Modbus component freezing lovelace · Issue #46994 · home-assistant/core · GitHub. and the follow-up answers.
In the end, I rolled back to the old style and it worked for me. Last weekend, I tried again on the latest docker image and its working for me now.

Hmm it worked well fort me until i updated i March and something failed. My Raspberry is in another house 40km away and until yesterday i haven’t got time to fix it. I pre-installed latest hass on a new sd and when i had started it up it worked fine. But the more modbus registers i added in the list the slower the Raspberry got. So now i do only read around 5 registers and it works ok. I guess i have do preinstall an older version to make it work properly for a while…

April update was freezing for me after a few minutes. Yet to try bringing it back with May but does anyone know if it is fixed before I try? Not really interval related I guess but will report back here when I do.

EDIT: Still no good for me.

[pymodbus.client.sync] Connection to (, 502) failed: timed out

Lots of that - which is my modbus device.

Best would be to file an issue on github to increase awareness and rise pressure to fix it.

Yes. I will perhaps try to make sure I have migrated all sensors to the new style first and then see what I can log.

Sorry for delay - hospital and recovery for last month - after latest updates all working again for me.