MotionEye 0.9.0 update failure

Tags: #<Tag:0x00007f7399880338> #<Tag:0x00007f7399880108>

Just updated from v0.8.1 (working fine) to the new v0.9.0

(HA version 0.114.2 Rpi 2)

Fails to now start after update per below - any thoughts?

08:15:08] INFO: Starting motionEye...
    INFO: hello! this is motionEye server 0.42.1
Error relocating /usr/bin/motion: __nanosleep_time64: symbol not found
Error relocating /usr/bin/motion: __select_time64: symbol not found
Error relocating /usr/bin/motion: __gettimeofday_time64: symbol not found
Error relocating /usr/bin/motion: __pthread_cond_timedwait_time64: symbol not found
Error relocating /usr/bin/motion: __localtime64_r: symbol not found
Error relocating /usr/bin/motion: __stat_time64: symbol not found
Error relocating /usr/bin/motion: __localtime64: symbol not found
Error relocating /usr/bin/motion: __time64: symbol not found
   ERROR: motion failed to start
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/motioneye/server.py", line 334, in start_motion
    motionctl.start()
  File "/usr/lib/python2.7/site-packages/motioneye/motionctl.py", line 129, in start
    raise Exception('motion failed to start')
Exception: motion failed to start
    INFO: cleanup started
    INFO: wsswitch started
    INFO: tasks started
    INFO: mjpg client garbage collector started
    INFO: smb mounts started
    INFO: server started

@frenck - tagging in case you can assist with this recent update.

same here.
Motion failed to start
I had to revert back to previous version from a snapshot.

Same failure!
I just opened a issue on github…
Hassio mantainers, include rollback feature!!!

Just in case …
To fix the problem temporarily I have:

  • copied the old motionEye configuration

  • removed the “original” add-on

  • created a copy of the Hassio addons repository and modified the motionEye version … You can find it at https://github.com/mikyjazz/repository add the link as a custom repository in Hassio Supervisor

  • changed motionEye version to 8.1.0 (in this way it downloads the docker image of that version)

  • installed in this way version 8.1.0

  • restored the old configuration
    Everything works … As soon as the add-on has been repaired you can remove this repository from the supervisor configuration and reinstall the updated version of the add-on

3 Likes

I would say that this could be considered a general procedure to use in case you want to rollback / downgrade an add-on!

MotionEye dead :cry:

Strange, mine runs fine on 0.9.0

which operating system?

I run hassos, on vm

It may be that the update was done with hassos in mind; it is known that installing Hassio on other operating systems is no longer supported …
If so it would be a big problem; obviously I don’t dream of installing Hassos or even using it inside a VM since I use a Raspberry PI4 and I need the resources to run other processes on the same machine; If so (but I really hope not) I will be forced to stop updating the add-ons through the Supervisor …

Well, I have a esxi server, best system ever, enough resources to run what I want :wink:

But true, it should run on a pi also, probably an bug

Esxi server at home? Really impressive, you have a lot of resources … not exclusively computer-related :wink: At first I ran Home Assistant on a VM running on a QNAP NAS, but in this way the NAS never went to sleep so the consumption of current as well as disk wear was considerably higher … For this I decided to use the Raspberry4; is really very powerful and even running Home Assistant, a database, Homegear, MQTT broker and various other things there are still more than half of the free RAM resources and 70% of the free computing resources … all with a few watts and a few euros of expense … Just for completeness, I work in a large university computing center where we manage, among other things, hundreds of VMs in both VMWare and OpenStack environments so VMs … don’t scare me :smiley:
In the end, I hope it’s just a bug; I guess they used some references to libraries that weren’t included in the dependencies and maybe they are available by default in Hassios … If so maybe they’ll fix;) See you soon!

sounds logical but unfortunately for me not to follow now
I don’t run Hassos myself, but Raspian OS with docker
Can you possibly explain it in steps

hi Werner, I also use Raspbian! The instructions I have indicated are for using a custom repository to load the previous version 0.8.1 through Hassio supervisor …

I am a starting Home Assistant but after some searching and reading I understand what you mean, thanks! I’ll try it this evening.

I couldn’t wait and I did and it works! Thx …
Now wait and see if the next update has solved the error, in any case not set to automatic update.

1 Like

Same here, just stopped working…

Sorry, but I do not understand all of the steps you mention: how exactly do you change MotionEye in the Addon to download previous version?

1 Like

restored based on the procedure from @arkimedes, thank you very much
the 0.9.0 addon works fine if you have raspberry pi cameras, but not on other 3rd party cameras.
@gdschut - temporary solutin till the community addon is fixed:

  1. open the current faulty addon and do Backup of existing configuration of motion eye (save the file on you pc).

  2. remove the current community addon for motioneye - uninstall

  3. add respository - the link provided by @arkimedes

  4. install that particular addon of motioneye (e.g. at the bottom, from the repository of mikyjazz)

  5. finally, login to ME (admin, no password) and Restore the config from the file you saved on the PC at step 1

Note: My tar backup file was quite big, and had a huge core file inside. Check if such core file is present, and remove it from the archive. The restore on step 5 will fail unless you remove the core file from the tar.

3 Likes