Mount hard external disk drive


I wanted to put on my HAOS :

Home Assistant 2023.9.2
Supervisor 2023.09.2
Operating System 10.5
Interface utilisateur : 20230911.0 - latest

mount a hard drive disk via usb to combine it with Samba and PLEX or KODY to access 4k films, so with my pc send films via samba to the hard disk mounted on the HA pi, and watch it on my tv.

The problem is that whatever i’m root user, if I follow this tutorial, when I put

sudo mount /dev/sda1 /media/data

it says : mount: permission denied (are you root?)

I tried :


and it return “root”…

Anyone to know ?

The hard drive is detected on sda1 when I go in HA’s settings and the drive is set in NTFS

I am not sure if mount.ntfs exists on haos. Can you test if it exists?

By the way if you are root, sudo should not be used.

Even without Sudo it doesn’t work.

Didn’t find mount.NTFS in addon store

I asked if the command exists on haos. Type the command, press enter. Also, no upper case.



apk add ntfs-3g

He now knows the fonction, but not permitted :

Well your disk is reported to be in a screwy state “the ntfs partition is in an unsafe state”. I am not sure if that prevents mounting, try readonly (ro) as suggested.

By the way the correct invocation is mount -t ntfs /dev/sda1 /media/data

add -o ro to see if that mounts it.

Further thoughts, are you sure /dev/sda1 is the right device? Is it confirmed in dmesg?

Also do a df -h (not sure if this command works on HAOS).

That sda1 suspiciously looks like the primary drive and partition.

Df -h doesn’t see the hard disk

Well it won’t unless it is mounted. Anyway, you didn’t reply about dmesg.

Sorry, I didn’t see. Here a screen of the material :

I’m sure it’s the right disk

1 Like

Did you try -o ro?

Just thought too, are you using the advanced ssh & web terminal addon with protection mode turned off? You should!

I am interested in doing the same. Did you get it?