Move ConBee II to another host and reconfigure Home Assistant deCONZ integration

I currently have my ConBee II installed on a Windows computer, and I have Home Assistant with deCONZ integration installed on a Pi4. I want to move the ConBee II to the Pi4, use the deCONZ add-on, and then reconfigure the deCONZ integration to use that deCONZ instance rather than the one on the Windows computer.

I know how to back up and import the ConBee II configuration in Phoscon. But what I really want to avoid is, when importing the configuration in Phoscon on the Pi4 and hopefully getting every device up and running again, and then configuring the new instance in the deCONZ integration, that all the devices will be re-added in Home Assistant with new entity names.

So how can I move the ConBee II to a new host, and reconfigure the deCONZ integration so that all the entities remain the same?

You can move the ConBee II stick between computers without issues if you export and import the deconz configuration.

The ConBee II keeps all the device pairings on the hardware, and the deconz export keeps track of all your groups, names, etc. As long as you have both, you are okay to migrate.

I moved my deconz installation from a Synology NAS (x86) to Home Assistant Blue (arm64) without issue by exporting and importing my deconz configuration. I think I had to restart deconz after importing, but outside of that, all my devices moved over without issue. I changed the IP address of the deconz integration in my Home Assistant configuration and I was good to go.


Here are the exact steps I took:

  1. Exported deconz config
  2. Shut down deconz on my old host and made sure it was configured to not start up again
  3. Moved the ConBee II to my new host
  4. Started up deconz on my new host
  5. Imported my deconz config
  6. Restarted deconz
  7. Changed the IP address of my deconz server in Home Assistant and restated Home Assistant (you may or may not need to do this step. I had deconz setup on a DNS entry, so I changed my DNS entry to point to the new host. If your deconz is setup as localhost or your IP isn’t changing, you won’t have to worry about this step)

Thank you, @ronaldheft.

It’s the 7th step that’s the issue. I can’t find anywhere I can change the deCONZ server IP address in the Home Assistant integration. The options menu has no such configuration, and I’m not sure where the integration stores its configuration in the file system.

Initialize a new integration setup and it will match the current integration based on its bridgeid and update the host address rather than create a new integration


Excellent, I’ll give it a try.

It didn’t go completely as smooth as @Robban said, but close. I closed down the deCONZ instance on the Windows server, moved the ConBee II to the Pi4, and installed the add-on. I then imported the configuration from the Windows server, and saw that all the devices came up as they should.

When I then added a new deCONZ integration with the new IP address, it came up as a second bridge with the same ID, with all the devices but without any entities. Note that I didn’t remove the old one first, as I thought this might delete all the entities. Since all the old entities now became unavailable, and I didn’t get anywhere with the new integration, I deleted the new integration and restarted the Pi4 host (from the Supervisor menu) to get a fresh start. After five minutes the system was back up, and now the old entities from the old deCONZ integration were available and worked with the ConBee II connected to the Pi4.

Don’t know what happened behind the scenes here. But it is at least up and running again. Could be that I should have removed the old deCONZ integration first, and if I had done then everything would have worked at the first try. Next step now is to install Proxmox on the Windows server, and to then virtualize a new HA installation there. The Pi4 was to evaluate HA for a while before migrating from HomeSeer to HA. So I will get another chance to move the ConBee II again soon. :slight_smile:

Thanks a bunch for the help to both of you, @ronaldheft and @Robban.


Glad to here you got yourself up and running.

For the future, you can edit the IP address by stopping Home Assistant and manually editing .storage/core.config_entries.

The file is a JSON file, and if you search for deconz, you’ll find the host and port settings in the file. After editing, when you start Home Assistant back up, your new host/port will be used on your existing config.


It seems that if you have the core-deconz addon installed, your changes in core.config_entries will be overwritten at each startup of HA due to auto discovery. I wanted to have a “test” deconz that I could build myself to test the latest version while keeping the default deconz plugin installed (so that I can start one or the other at will), unfortunately because of this it was not possible (and disabling discovery of deconz in HA is also not simple apparenlty as it involves changing default config).

Running HA on a docker @ Synology NAS, I had the impression my changes got overwritten each restart. In my case it appeared to be a problem with file access rights: changes would not be written to file without an error message. Adding r/w right to the Synology user changing the files, made the change persistent.

I successfully moved my deCONZ from a Windows 10 installation to a docker on Ubuntu 20.04, using the steps above. Copied the .db file and reloaded the exported settings from the Phoscon app (Gateway settings).

Thanks guys for the steps. It was very easy.

  1. Backup phoscon configuration
  2. Configure Conbee II on another computer
  3. Import backup
  4. Stop Deconz and delete the integration completely. This will delete all the entities and devices.
  5. Add new Deconz integration and put the host ip address.

When it loads, all the entities and devices with the previous ids will be back