Move from EZSP to EMBER

Following the upgrade to firmware of my Sonoff Zigbee Dongle E I always have this in the z2mqtt log :
zh:ezsp: Deprecated driver ‘ezsp’ currently in use, ‘ember’ will become the officially supported EmberZNet driver in next release. If using Zigbee2MQTT see Improved Ember (EZSP) driver (experimental) · Koenkk/zigbee2mqtt · Discussion #21462 · GitHub

I tried to change from ezsp to ember in the configuration.yaml I 've got this :slight_smile:

Then after restarting z2mqtt though the file is ok the view from the z2mqtt module is still in ezsp, and I still got the same message in z2mqtt log :

When I’m trying to change it from there to ember it reverts back to ezsp. What can I do ?

Thanks for your help

I’m getting the same message and a Google search brought me here :sweat_smile:

Same situation

Found out that I had to go in z2mqtt module information (where you can stop/ restart it from there there you can set the settings regarding the interface after writing ember and a restart I’m now with ember

where did you find this option?

If I go to the zigbee2mqtt web UI, click the gear icon, go to settings, and go to the serial tab, then there’s a dropdown menu for adapter type. If I change it to ember and hit submit, it immediately changes back to ezsp. That’s the only place I’ve found this setting other than the zigbee2mqtt configuration.yaml.

It is in the Addons page - click on Zigbee2MQTT tile. Then click the configuration tab at the top.

There are 3 places to edit this - and this is the only one that seems to work.

  1. The Cog on the Zigbee2MQTT webUI - as you say resets immediately
  2. Edit it in the config file - updates (sometimes) but has no effect in practice
  3. In the Addons menu - that is where it works (after restart)
1 Like

Thanks. I finally found this out after tinkering a bit. I’ve been running ember for a couple days now and it seems to be working just as well as EZSP.

What are the benefits of switching to ember and not staying on EZSP?

No more development on the EZSP driver

Thanks. Uploaded version and works as expected.
EmberZNet coordinator type is displayed in Z2M.

? Not sure what I am to do here?
Isn’t this somewhat cryptic?

And exactly how please?
I can change from “ezsp” to “ember” as much as I like, it always goes automatically back to “ezsp”?

1 Like

OK, If I change it here, the Zigbee2MQTT doesn’t start at all anymore :-/

Did you flash 7.4.1 or 7.4.3 firmware ?

I am flashing this one:

Blindly …



The above FW seems to do the job. I was able to switch to “ember”.
Got a lot of new error messages tough… Does anyone know what they mean?

1 Like

could it be possible there are still some reminants of the “ezsp” in my network?
Very few (2 out of 62) nodes are not responsive anymore. In the error message there is a mention of “EZSP”, where I am currently on “ember”.
Or maybe just a coincidence?

Maybe try to re-pair those.

Anyone try and move to ‘ember’ for a HUSBZB-1 coordinator? It otherwise has been working great using the ‘ezsp’ adapter type, but it’s not listed as a supported adapter for Z2M and not sure what the consequences are.

I don’t think it is possible. The HUSBZB uses an ancient chipset that does not support recent Silabs SDK’s.