Move from Raspberry Pi to Synology Docker

yesterday I got my new Synology NAS and I would like to move my HA Pi Setup to Docker. First of all I have noticed the differnce between Pi and Docker, but it wasn´t be a issue to setup. I have some open questions:

How can I implement my data (backup) from Pi to Docker without Supervisior?
Do I need to setup DeConz separately on Docker?
How does it work with HA updates on Docker?
Is there anything else I need to note?

Thank you in advance for helpful hints :slight_smile:

1 Like

Copy everything in /config (incl. hidden .storage directory) to a new location on the Pi and bind-mount it as volume /config into the HA container.

Depends on the integration you are going to use:

  • deCONZ - yes
  • ZHA or MQTT / Zigbee2MQTT - no

Stop and remove the running HA container and run it again from :latest image. Or - fire up a 2nd container from watchtower image. I recommend use of a docker-compose stack in general.

Don’t delete the old instance of your NAS until migration has been done :slight_smile:

Thank you for the detailed answer :slight_smile:

I will keep the PI as back-up option.

How is your experience with HA on Docker?

Excellent, for years now.

Dropped the Python vEnv installation (know known as Home Assistant Core) as soon as possible, never felt the need for an Home Assistant appliance (known as Home Assistant OS) or some magic-skript (also known as Home Assistant Supervised).

Currently I run two Home Assistant instances for different properties, both using docker-compose for stacking:

  1. HA, Nginx, Homegear, MariaDB, Watchtower on a x86_64 machine on Ubuntu Linux
  2. HA, Zigbee2MQTT, Eclipse Mosquitto, MariaDB, Watchtower on a RPI4B 4GB on Raspbian Linux

It’s worth to note, that I am well familiar to Linux and Docker.

:face_with_raised_eyebrow: Good to know. I´m not very familiar with Linux, but I guess I can realize it with your hints. My setup is not that difficult, everthing external, just the DeConz implementation. I will start this weekend, keep you posted :nerd_face: Thank you so far

Check this out

I have installed the package yesterday for a try. First issue I have encountered was a not working supervisor. I will try the official way.

Thank you anyway :slight_smile:

There are no official way for Synology. If your synology support VM then you can build a Debian + Supervised which official support version. Be sure to turn off UFW or make sure all your container will have access to the outside world to make it work.

The other options is to go with Docker + HA Core but then you will lose snapshot. For me going back to RPI 4 + ArgonOne M2 and split some containers from Synology. This way give some load off from limited RPI4. Quite happy with the setup. RPI 4 Supervised version running Debian 10 allowing me a full control + have some load off to Synology at the same times. Combine control from single portainer to see both dockers. :star_struck:

Okay, HA and DeConz are installed and running. The Conbee 2 stick is recognized by the Synology NAS. I have set the path to the stick in Docker. But the stick is not recordnized by the DeConz plug-in. Any idea?

Hi Tamiami,
Like you I too tried to run Home Assistant on my Synology NAS via Docker and noticed the limitations. These seem to be due to the version of Docker supported / installed by Synology.
My previous posts (see link below) include more detail:

However I am finding that running HA under a Synology VMM (assuming your NAS supports them) seems absolutely fine. In fact my HA just updated with the two new releases issued in the last couple of days via a simple click on the ‘update’ button. Additionally I’m successfully running many other programs such as InfluxDB & Grafana alongside the HA core & supervisor programs.

Hey John, the missing Supervisor panel is not the problem for me. HA and DeConz are running absolutely fine. The connection between as well. Just the problem with the not recordnized Conbee stick is the issue:

Do you have any hint?

Hi Tamiami,
Sorry but I don’t have any experience with the Conbee stick. I hear what you are saying about it being recognised by your Synology NAS. Unless you find an answer to allow you to continue running using Docker I would suggest that it might be worth testing an HA instance running under a Synology VMM to see if that recognises the hardware.

Got it :slight_smile: The path to the Conbee2 is in my case /dev/ttyUSB1 and not /dev/ttyACM0 like described in much communities.

1 Like

I have a Synology DS920 and installed Home Assistant using the VMDK image found here: Installing Home Assistant OS - Home Assistant ( I think this is the only officially supported method if you want Home Assistant Supervisor and the add-ons.

Home Assistant Supervisor is included, so all HA x64 add-ons also work. I use a GoControl Z-Wave + Zigbee HUSBZB-1 USB stick connected to the front USB port of my Synology and it works with Home Assistant. Just make sure to expose the USB device in your VM.

There are a few negatives to using a VM for Home Assistant, which is running HA add-ons on top of your Synlology Docker install. Home Assistant startup times are incredibly long, I’m talking about 20+ minutes long. I only reboot HA at night because of all the disruptions it causes while offline during the day.

Home Assistant runs a little slower than my laptop w/ core i5 3rd gen CPU. Pages are not as responsive, but the dashboard responds to button presses fast enough. The slowdown is noticeable, but not annoying enough for me to do something about it. I’ve also noticed my motion light automations tend to run 0.5-1 second slower than before, even though I’m using a USB Z-Wave stick and all automations are processed locally on the Synology.

The VM also eats up a good amount of RAM too. I have a total of 8gb RAM installed on my Synology and I dedicated 3gb to the VM.

In the end, I’m seriously considering moving HA to a dedicated Rpi4 to offset the workload on my Synology. I run Plex and a number of Plex-related Docker containers on the Synology and may want to keep my Synology focused on that.

Good luck with your setup!

My Synology is slightly older (DS918+), again with 8Gb RAM but my start up / re-boot times are only in the order of around 1-2 minutes in total - certainly not 20+ minutes which I would find unacceptable.
I, too, have Plex installed along with (running under Docker) my Unifi controller and I’m also using Synology’s Surveillance Station recording a CCTV feed 24/7.

My Synology boots up quickly (1-2 minutes), but the VM running Home Assistant takes a very long time, like 20 minutes. Everything else on the Synology (Plex, Docker containers) boots within a few minutes.

I don’t know if it’s just my instance of HA running on the VM that takes a long time to boot. Would love to hear if others have the same issue.

Just to confirm that the 1-2 minute boot-up times I mentioned were for the HA running in VMM not the Synology DSM load time. In fact after running the usual config checks when I make a change I have no hesitation in re-booting the core HA program as it’s so quick.
Like you I’m curious why we are seeing such a massive difference in the time taken to boot up HA.

Moving to RPI4 is a good idea which I’m also taken out my HA back to RPI4 + Adding ArgonOne M2 to make it a blazing fast system. It’s running Debian Supervised method which gives me more flexibility in controlling all the systems. One warning! DO NOT INSTALL WATCHTOWER… somehow it will bring supervisor to unhealthy states.

Hey guys, my conclusion after some days on docker (Synology). From my point of view the system is more stable than on Pi4. I have observed that the Pi always geeting hot after some hours of run, last time the complete system crashed and needed to reboot. The missing Supervisor is no problem for me on Docker. Connection between Deconz and HA is working stable. I´m just missing my UPS Server on Synology. Its really strange, my Greencell UPS was recognized by my old NAS (DS119j), the new one (DS220+) doesn´t recognize it (not offcially supported). Does anybody has installed a external UPS server on Docker?

Does Synology recognize the UPS? If yes be sure you allow the Synology IP to get some information coming out from the UPS