Moved from supervised to haos 🤯

Just did that today… long shot :gun: Restore (~6GB full backup) took virtually ages (many hours) but it finally came back :up:

So what did I gain?

And what did I loose?

  • My cpu temperature…
    which was previously achieved with this 5 lines:
  - platform: command_line
    name: CPU Temperature
    command: "cat /sys/class/thermal/thermal_zone6/temp"
    unit_of_measurement: "°C"
    value_template: "{{ value | multiply(0.001) | round(1) }}"
  • My bluetooth which I actually just were recently gifted with
    together with it all it’s devices
    (the hardware stayed the same!)

and last but not least the most crucial thing:

  • The possibility for a “unattended” boot - in my case without a display (hdmi) and keyboard connected to the ha server (x86-64 machine).

The last point makes it show stopper for me because my setup typically never has a display connected and therefor it can’t “recover” itself after a power outage or what not.

I don’t expect that this behavior can even be changed from a user (me) because of the architecture of the managed OS with this install type.

Guess tomorrow I have to role back :tired_face:

I also did this migration and the CPU temp is working with the same command on HAOS, I just had to try different thermal zones (mine changed to thermal_zone2).

As for the boot without display connected, that one I’m also curious about. I have a NUC system and it fails to recover after a power loss (it worked normally with supervised) and when I plug in to check it always work. I had this problem and didn’t even know it, will check the BIOS.

1 Like

You can buy one of these. You didn’t say what hardware you were using but I don’t have any issues with RPIs without a display connected recovering.


You could check the bios for an option to boot without display. My NUC starts without attached display so it’s definitely not a HAOS limitation.

For the temperatures you could try other thermal zones than 6.

1 Like

I’m aware of this but as this is not a hardware limitation (I didn’t changed my server and with debian it worked without display) I rather don’t invest in such hardware when it can be solved in software only.

My device is like the raspberries powered by 5V but it’s smaller :pinching_hand: and a full blown x84-64 machine actually

Totally get what you’re saying. But…

I don’t believe this is a HAOS thing as real RPIs don’t have this issue nor do NUCs (depends on the bios I believe). It sure seems like a bios/hardware issue to me at least.

Out of curiosity though, what kind of device is it?

I can really rule out that issues because till today (before I replaced the debian supervised install with haos) it was capable of doing an unattended boot. I didn’t change the hardware and no bios setting.

I think this type of computers were called something like Intel Compute Stick. Mine is years old got 2gb of ram a weak Intel 3735F CPU and is fanless - everything I need :wink:

In my limited searching, yeah it was likely a grub/boot parameter debian was passing that HAOS isn’t.


I expect that also - maybe not only the missing display but and/or also the missing keyboard.

Real bummer - would expect a server OS is able to boot without attached display/keyboard :confused:

You could try to edit /mnt/boot/config.txt and see if you can get it to work correctly. I am not sure if that persists reboots but I believe it does. It wouldn’t persist a OS update though.

But what should be change? lol idk. Maybe something in the cmdline.txt.

Looks like you are running on an Intel compute stick or similar. I have a couple that I used several years ago to make dumb TV’s smarter and to run VPN so that I could stream Netflix outside the US. Mine would reboot after a power outage - believe it is a BIOS setting.

Like others have mentioned, I am also running HAOS on a NUC and it reboots after a power outage. Running without a monitor and keyboard connected. I manage it completely via the HA web interface or SSH.

In the past (till today) it always restarted/started fine without display or keyboard attached (that was with a debian installed which was topped with a supervised install). I was running this setup for years now.

Today I switched to HAOS and now the setup is not able to start (cold boot) without a display attached (it works when only a display is present but no keyboard actually).

I did not touch any bios settings and there is any way no setting regarding that in my (quite limited) bios available.

This is what I did in the past and what I thought I could continue with haos on my hardware :confused:

What’s wrong with the system monitor integration? It’s got a processor temperature option, works without issue for me. No command line sensoring required.

Aside - you’re aware that the sensor you’re currently using for that only updates once a minute right? If that’s what you want no worries I just ask because tools for that kind of stuff usually default to about every 15 seconds or so.

It was quite some time ago I rolled out my supervised install but I think I changed something in etc/default/grub back than:

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

maybe I added the quiet? :thinking:

I use that integration but for cpu temperatre that didn’t work in the past for me - it showed a different temperature sensor and not the one from the cpu (the docs mention that this can not be changed)

Yes, no worries - was sufficient as long as it worked (pre HaOS) :grimacing:


Just tried and it doesn’t work:


Mine will boot without a display. Gotta be a setting in the bios…

Interesting. Submit a bug? Perhaps there’s some hardware requirement I’m not aware of but as a core integration on HAOS I’d expect that to work.

Sadly it’s not. That would be to easy… btw. mentioned already two times in this thread today.

So today I’m in the process of setting up a fresh debian system for moving back to a supervised install.

This time I installed the minimal debian 11 and right away checked if the system boots without display/keyboard and here are my findings:

  • no keyboard doesn’t look a problem at all
  • no monitor causes grub indeed to don’t let the system boot by default

If the etc/default/grub file is changed from it’s original state

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

to this one:

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

(changes quiet to nomodeset and timeout form 5 to 0)

the system boots without a display :rocket:

I wonder if such a change could me also added (or included?) to HaOS :thinking:

I recently instaled HAOS (HA Operating System)on a Lenovo ThinkCentre M710Q Mini PC Intel Core i3-6100T and can boot without keyboard, mouse or monitor by default.