Multiple Zigbee errors - no hardware/ software change

I stated, there was no problem before.
I don’t want to discuss my WiFi settings on this topic because it is a good setup for my house in combination with all the smart WiFi devices connected to it.

Sorry, I conflated his post. with yours.

1 Like

ok, i also never said that the errors was directly caused by your wifi-settings ( seems like you use all wifi channels )
so you have alot WiFi-zignals, on the 2.4ghz frequency , beside your zigbbe-devices, and all other household devices who runs/disturb the 2.4 frequency

So what happens when an i.e zigbee-router on your stable zigbee-network glitches or get turned of/unplugged ?, zigbee-devices(signals have to find another Route) first attempt failed because it choose a (bad) route, try again, another route, and so it keeps on ( depending upon how many routers you have ) and how many (hotspots) 2.4ghz choked/disturbed areas in your house

Oké thanks.
Do you think I can restart all Zigbee devices in a specific order to restore the ideal route?

Not really, they tend to live their own life, maybe you can “bind” some devices to a certain “router” , but as it’s airborne signals, they will “flow” around, and hopefully not “choke” 1 specific router-device (they should regulate this them self, depending upon how many devices/connection they can handle)
Best would be to not have routers involved who get turned on and of, so when the zigbee network has stabilized it stays that way

PS: If i had major issues, i would try to wipe all, and then turn on the zigbee-routers first in order-distance from the controller, then enable the “children” and let them/integration choose the route … can take days/usage until this has stabilized

Fortunately i’ve have still not ended in this scenario, and im actually not feeling comfortable with the “topology” as i prefer to know which route each device have at any specific time/scenario :slightly_smiling_face: ( yes you can call me control freak ) , so i’ve only have 2 who function as router, to reach/help 1st floor and basement devices, and im about to swap the basement with 868Mhz devices (Tapo) for the same reason

EDIT: What is Sub-GHz? | Tapo

1 Like

Hi @woempiej

I have this exact same problem too. I think it started around the 2023.12 release but I’m not sure. It’s definitely within the last couple of months. I’ve also added some new devices so maybe it’s this.

Everything is working but I don’t like having hundreds of warnings.

Yes! I will try this in the weekend.

Yes it surely started @ some HA core update, but do not know which one.

No-one of you guys have reported which integration you are using( among other things ), i see “traces” of coordinators.( beside OP’s tag ( ZHA ) which you sometimes can read about in release notes.
So i believe you would get better “result” searching Topics related to your specific Integration
MQTT/ZHA whatever , but ofcause still have the basic understanding of Zigbee( weak signal in common ) in a crowded 2.4ghz environment
Some people tend to trow in more and more on this frequency, with no “common” sense … Bluetooth, Wifi, usb3 , Huge NAS, with 2-4 spinning disk , next to their Pi, with Bluetooth, and a USB dongle( 1 meter above ) for Zigbee … Yes i works fine ( running/occupying WIFI on ALL channels ) , until it doesn’t
Ethernet-connected Zigbee coordinators, is not much more expensive than others 10-15 euro/dollars, but imagine the convenience with the ability to place the zigbee-coordinator, basically where ever you want, and, is it cool with your TV connected to WIFI ? …nooo, not only is it a huge source of “disturbance”, it’s constant on, if you don’t turn of the power or plug, your tv will also use about 10-20W( wired tv, about 1-2W ), just for this purpose ! listening/waiting for “commands” requesting update-news, Apps updates etc … everything that can be wired, should be wired

I have opened an issue on Github. We’ll just have to wait.

Each day i get thousands of these warnings.


Regardless of issue I highly recommend reading try following all the best practice tips here to rule those issues so not waste developer’s time troublesooting → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage

It might as well good idea to also try changing Zigbee channel as well as verify that you are using static WiFi channel(s) that do not overlap →

Also, if you have already done so already suggest upgrading to the latest available deconz firmware to the ConBee adapter →

Thanks for the effort.
Since the latest HA core updates I don’t see the errors anymore. I didn’t changed anything yet.

1 Like

Yes good advice. I check conbee firmware updates regularly but there was no new update in 2 years now.

On the other hand, changing my ZigBee channel is a option but not logical because it worked before and is working right now as supposed since the latest HA core updates.

Yes whoops,

I’m on ZHA.
I know about the WiFi and ZigBee conflicts including all the other stuff you mentioned.

I had the same hundreds of Zigbee warning messages in my HA log throughout December. I just updated to HA core 2024.1.2 and the messages haven’t appeared since. :crossed_fingers:


This seems to have been fixed by 2024.1.1

I see most of my error are gone now with the last update in 2024.1.2.

Even with 2024.1.1, I was having random reboots of ZHA.

I got exactly same errors since 2023.11 upgrade, with ZHA & Conbee2.
I just upgraded to 2024.1.2 and I confirm theses warning are left. Hope the network will also stay stable without lags.

You also need to understand that the radio chip used inside the ConBee II adapter is quite outdated and the firmware is relatively old as have not been getting any major updates for years, so you might want to consider replacing it with a newer more modern Zigbee Coordinator adapter. Suggest you check out this community guide → Zigbee buyer's guide


  • If using ZHA integration buy/use a new Texas Instruments or Silicon Labs based USB adapter.
  • If use the Zigbee2MQTT software buy/use a new Texas Instruments based USB adapter.
  • If use deCONZ/Phoscon software buy/use the new ConBee III (ConBee 3) USB adapter.
1 Like

Love your post, thank you!