My Grid Connect lights are working even though they are in Tuya

Hi very new to Home Assistant and don’t mind finding and spending the time fixing this but have no idea where to start or what to look at.

I am using bulbs that are supported In Tuya and Smartlife, the first time of bulbs is just an every day round glob, these work fine, I can turn then on/off brightness up/down and also change their colour “spot on”
The second set of light are from arlec strop lights and they are running under the type “Grid Connect” these too can either be controlled with the Android Grid Connect or Tuya application, I’ve added them to Tuya.
Alex and Google can control them via via the Tuya application but when I try to control them in Hpome Assistant I get an error in the logs

Short error is
Error doing job: Task exception was never retrieved
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/helpers/entity_platform.py”, line 408, in _async_add_entity
await entity.async_update_ha_state()
File “/usr/src/homeassistant/homeassistant/helpers/entity.py”, line 275, in async_update_ha_state
self._async_write_ha_state()
File “/usr/src/homeassistant/homeassistant/helpers/entity.py”, line 316, in _async_write_ha_state
attr.update(self.state_attributes or {})
File “/usr/src/homeassistant/homeassistant/components/light/init.py”, line 477, in state_attributes
data[ATTR_BRIGHTNESS] = self.brightness
File “/usr/src/homeassistant/homeassistant/components/tuya/light.py”, line 43, in brightness
if self.tuya.brightness() is None:
File “/usr/local/lib/python3.7/site-packages/tuyaha/devices/light.py”, line 16, in brightness
brightness = int(self.data.get(‘color’).get(‘brightness’) * 255 / 100)
AttributeError: ‘NoneType’ object has no attribute ‘get’

Any idea of what I should be looking at?

confirming that all the devices are in the same phone app (tuya smart for example) and the tuya integration in HA works for at least one device?

if the integration works for the globe bulbs, but not the strip light, it is quite likely the strip light isnt’ supported unfortunately.

Hi @johnw230873,

I just bought the strip from Bunnings and have the same issue. I thought I may be able to connect the strip as a normal bulb and it may work with colour but no joy. Shame, they are a decent product at a good price. With no colour control through HA I’ll have to take it back though :frowning:

In case anyone ends up here with the same issue, I found that you can control the lights through HA using the “color_name” attribute. You can only use this so you can’t tweak it to a more specific colour other than base colours but it does at least allow you to automate and change between colours if that’s your thing.

Hopefully as these gain popularity someone may pick them up and add full support for the features in the app (and ideally we get LAN support but I think I may be dreaming there :slight_smile:)

Cheers

Hi @greybags in the end I flashed them to Tasmota over the air, if you haven’t seen this, here is a good video https://www.youtube.com/watch?v=O5GYh470m5k&t=277s

I’m now using other Grid connect devices as well, all with Tasmota.

Thought I would add a bit more to this.
The Grid Connect appears that it can be loaded in to the Tuya software on your phone, so you can add it to all the other tuya devices you have and control it like that.

As you can load and control it in Tuya that is why I tried the over the air update and it did work.

Template for the led strip is {“NAME”:“AL 810LM”,“GPIO”:[0,0,0,0,37,40,0,0,38,0,39,0,0],“FLAG”:0,“BASE”:18}

Once Tasmota is installed there are a few settings I set via the console
poweronstate 1
setoption15 1
setoption19 1
RGBWWTable 255,255,255,255,0 <==helps when you only selecting white from the color wheel

Thanks @johnw230873 that’s great to know! I have a few devices already on Tasmota so that works well for me. That will also provide the much desired local control and remove the delays that you have when using Tuya.

Can you still select the full colour range once it’s flashed to Tasmota? Do you need to forget from the Tuya app before you flash? Actually, why don’t I stop asking you questions and watch the video you kindly provided! :slight_smile:

Thanks again and for the strip template, I’ll revert back with my progress. Perhaps Bunnings will get some more purchases from me if it’s that easy!
Cheers

Did you have any issues flashing the strip initially? I’ve been trying for a couple of hours now and I can’t get it to connect and upload. vtrust-flash is showing, wifi is on and configured for AU and device connected to AP. When I put it in pair mode it stops flashing almost as soon as I run the “start flash” command but it never then goes past this and uploads the code. Just keeps coming up SmartConfig complete. Resending SmartConfig Packets

Almost there but something is wrong in that final stage??