My Lovelace Plugins

Oh. I see what the problem is.
This version should work with earlier versions (but not look as good with the beta).

Glad to see someone is using the section row :smile:

Thank you. This version work fine on 0.81.6, but the UI…


Yeah, I know. I’l see if I can fix it later today… but I don’t know if it’s worth the effort for just a couple of days…

I think you do not need to fix it. HA will have a new version in a few days. And it will run fine with your latest version


Tired of that boring old more-info dialog?

Replace it with something you made yourself, using popup-card.



The way lovelace places cards into views may seem a bit weird if you don’t fully understand the rules.
But who wants to read the source to find out about card heights, and the limits of five and stuff? Shouldn’t things be simpler?

Yes, they should. Let me present layout-card.

Say you want to put the cards into the stacks one at a time:

Or fill each stack until you say stop and then move on to the next:

Or maybe just decide yourself how many stacks there should be:

This is your card.

This deprecates column-card.


Great card! Much better than the column-card.
I have two suggestions.

  1. Is it possible to add a top margin above the cards (below tabs)? Maybe as an option.
  2. Can the card correct the number of columns after opening/closing the side panel of the HA?

I fixed your second point.
There should be a margin… I’ll look at that tomorrow.

1 Like

Thanks for fix. I have top margin if I change in line 18 margin-top to 4. With 0 there is no top margin.

1 Like

Great cards! Thanks for share

Margins should be fixed now.


And now it also works with the thermostat card - a long standing bug of column-card.

@thomasloven I have in log error after opening/closing HA side panel:

https://_redacted_/local/lovelace/layout-card.js?ver=c8847a:55:28 Uncaught TypeError: Cannot read property 'id' of null

I am getting this error when trying to use the “- break:” function in the layout-card -> Uncaught TypeError: Cannot read property ‘startsWith’ of undefined.

Edit: Turns out I was using a colon after “- break” which shouldn’t have been there however now when trying this with the modder-card i am hitting this error -> Uncaught TypeError: this.card.setConfig is not a function

Edit#2 After struggling trying to get this to work with the modder-card for a couple of hours it seems all I needed to do was go to another tab within lovelace and immediately go back and just like that it worked. I’ve had this trouble with other cards but usually I get the red-info card but in this case all I got was the error message in the lower left corner and I assumed it wasn’t working. Another lesson learned, hopefully this helps someone else.

Should be fixed now.


I have a lot of errors in system log when resizing the browser’s window:
/local/custom-lovelace/layout-card/layout-card.js:69:1 TypeError: this.$ is undefined
Now i workaround it by adding
if (typeof(this.$) != "undefined")
is it OK?

Thank you, it work’s great. About toggle lock entity row - it works only with “switch” type. What about the “input_number”? For now it convert’s the “input_number” to “switch”…

@thomasloven After upgrade HA to 0.82 when I go ftom dev-info page to overview page I have in log this error for layout-card (browser cache cleaned):

https://_redacted_/local/lovelace/layout-card.js?ver=dfdfe8:69:27 Uncaught TypeError: Cannot read property 'columns' of undefined

My config:

  - id: home
    icon: mdi:home
    title: 'Pomieszczenia'
    panel: true
      - type: custom:layout-card
1 Like

Great new card, thanks!!

One suggestion if it’s possible please - could there be an option for “up to column count” or “maximum column count”?

For example, I like to use the horizontal layout, and on my 24" monitor it automatically results in 5 columns. I would like to reduce this to 4 columns but don’t want to force this to be the case when viewing from a smaller display such as a mobile phone. The result would be auto column count by screen size, up to and no more than 4 columns on larger screens.

Happy to put this request in GitHub if you prefer?

@Bieniu The TypeError should be fixed now.

@jarrah Try the newest version and config option max_columns: (undocumented).