My Lovelace Plugins


#184

I don’t get the red problem because i don’t use stack, i’ve got a white card :slight_smile:
the line 98 is a line where we try to get a "state’ from a template but we need to use entities now , lets see what developper says …


#185

So that’s a seperate issue then.

I did change my template to get rid of an error I was seeing - here is an example of one of my templates:

  - platform: template
    sensors:
      forecast_0:
        entity_id:
          - sensor.dark_sky_daytime_high_temperature
          - sensor.dark_sky_overnight_low_temperature
          - sensor.dark_sky_precip_probability
        friendly_name: "Today"
        value_template: >
          {{states.sensor.dark_sky_daytime_high_temperature.state|round(0)}}°/{{states.sensor.dark_sky_overnight_low_temperature.state|round(0)}}°/{{states.sensor.dark_sky_precip_probability.state|round(0)}}%
        entity_picture_template: >-
          {{ '/local/icons/dark_sky/' ~ states.sensor.dark_sky_icon.state ~ '.png'}}

#187

Thanks @thomasloven for the fast fix of the fold-entity-row!


#188

The problem with cards in stacks should be fixed with 0.81.1.

If you have problems with cards in conditionals, there’ll be a fix in 0.81.2.

Fold-entity-row will need to be updated for use with 0.81 (latest version on github is not backwards compatible with home-assistant 0.80 or earlier).


#189

I’m having issues with the slider-entity-row. I get the following error message in UI:

image

My code is below:

      - id: 8506890d98aa4cf993b27df5a82dfbeb  # Automatically created id
        type: entities
        show_header_toggle: false
        title: Living Room
        entities:
        - entity: light.color_living_room_lamp
          name: Colour Light
        - entity: light.living_room_lamp_2
          name: Left Light
          type: custom:slider-entity-row
        - entity: light.tv_light
          name: TV Light

That entity does actually exist - it will appear if I remove the custom type. Any ideas?


#190

I just updated card-modder with the ability to specify a card size.

That can give you a bit more control over which card goes where on screen

More info on github.


#191

Hey Thomas, yesterday I had a bunch of gradients working with your card-modder, however today only a few of them is working. The ones that are still working have this:

style:
          "background": "linear-gradient(45deg,rgba(39,44,53,0.5),rgba(144,176,176,0.2))"

the ones not working have exactly the same.
I also tried:

style:
          background-image: linear-gradient(45deg,#2ad8b5,#2cdea7,#7fecb0)

with no success, any ideas why some is working and some is not?


#192

Could depend on the type of card you are modding. What cards are they?


#193

Its a couple of different ones, the ones that worked yesterday was entities cards. The ones working today is the weather card (default, not custom) and a custom tiles card that is also working.


#194

Hang on, let me update to 0.81.2 and see if I can reproduce this.


#195

It works with an entities card for me with 0.81.2…
Is it only "background" that’s not working? How about, say "--paper-card-background-color": "red" or "font-size": "200%"?


#196

Aaah, I forgot I updated to to 0.81.2 must be why they suddenly stopped working…

“–paper-card-background-color” works fine
also I have your? slider card on some of the entities in the card if that makes a difference


#197

nope doesn’t work if I remove the ones with sliders either.


#199
background-size: 100% 100%
height: 180px

Are you setting the card size and asking me why it turns out that size?


#201

You can’t add stuff to the card with card modder, just change (some of) the things that are already there.

I think you’d have better luck with picture elements, but it won’t be easy.


#202

Could you right click your non-working card and choose “Inspect” and show me what this part looks like:
card-modder-debugging


#203

Like this?


#204

Aaah, I forgot I updated to to 0.81.2 must be why they suddenly stopped working…

I should have caught this.
You need to upgrade card-modder. Get the latest version off of github.


#205

Cool, I´ll do that, just a question should it still be referenced as a module?


#206

Either works, js or module.