Home Assistant Community

My steps to success for Hass.io on Intel NUC


I’m sure it will be the way you have the NUC set up to boot? If you connect a keyboard and hit F10 on boot, that will bring up the boot menu. Try selecting the MicroSD card without the USB in and see if that works.

P.S Why are you using a SD Card and not a SSD? I’ve had HA die so many times from burnt out SD cards I’ll never go there again.


@JesseWebDotCom has documented the process to install the new NUC here Intel-Nuc help needed :)


is ble working using this method?


I just bought this: LENOVO M72E DUAL CORE G630T 4GB + 128 GB SSD

Do you think I can go with NUC image installation? Or do I need to go with virtualization? … I would prefer to get HassOS onto it …



Just install Linux (Ubuntu or Debian), Docker and then a generic linux install for Hass.io.

Personally I prefer Debian for stability over Ubuntu which is more bleeding edge but it isn’t important (unless you at some point do a dist-upgrade and it hoses everything)


For me under 2.8 and 0.87.1, Bluetooth is working but not BLE.


I can confirm that Hassio and the Z-stick works perfectly on Synology using Virtual Machine Manager. Super quick too!


Thanks David … but I went with NUC image as I wanted :wink:
One thing - I was not able to restore AddOns - different platform so I needed to download/install one by one from scratch





@xbmcnut thanks heaps for the help mate! I eventually got there with @JesseWebDotCom guide.

which worked a treat…and i’m a linux noob


There is always room for improvement; however, i’ve had no problems running it on Ubuntu NUC, even picks up the Aeotec Zwave stick.
I roughly followed the steps here. Hope it helps.


Hi Mate,

Tks and i have tried with usb but did not worked. Maybe something I’m missing? I figure out how to on Raspberry PI to make the wifi works but at the moment im stuck on y intel NUC Celeron…

Just sharing my experience from migrating from Raspberry to NUC. I have flashed the Hassio directly to the ssd car and worked straight way with AEOTEC Z-Wave and ComBee + Bluetotth all working perfect. (I use Bluetooth for my temperature xiaomi sensors :slight_smile:

Anyway if some have a step by step on how to make the wifi work on NUC please share!!! :slight_smile:


All good now!! I have my Hassio NUC runing on wifi… just read the instructions again and format the USB for FAT32 get UUID and done. :slight_smile:


Well done!

1 Like

Hi Everyone, just been reading this thread and thought I need to join.
I’ve been using a RPi3b+ for a while now and it’s worked very well, but the tinkering side of me was too strong and I opted for a NUC. I bought the NUC8I3BEH, i3-8109U with a WD Green 240GB M.2 2280 SATA and Corsair Vengeance 8GB SODIMM DDR4 2400MHz. I am using Ubuntu 18.04 and Docker CE with Portainer. Portainer gives a GUI to Docker.

I have been trying to get it working for 5 days and nights and the problem I was having was that I couldn’t get Duck DNS to work. I couldn’t access my system remotely and I tried everything as there is a lot of documentation about issues with DNS resolve issues. But as it turns out, there was nothing wrong with that (DNS), but more the user, i.e. me! I forgot to reassign the port forwarding to the NUC from the RPi. Now, it is working really well.

I wanted to load an OS on the NUC, so that I can play around with possibly other home automation software. There is a specific install for the Intel NUC on docker, which worked really well. My recommendation is to have a read of this thread, HASSIO on NUC - My Journey and also this Install Hass.io. Please be aware that there the specific install command for Intel NUC is curl -sL https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install | bash -s -- -m intel-nuc.

I didn’t want to just install Hassio on the NUC as I thought it would be a waste of a powerful computer and hence I used Ubuntu as my OS. I also tried installing on Virtualbox, following Dr Zzs method on YouTube and the install works well. My only issue is that I didn’t like the idea that I couldn’t copy the snapshot file from the VM to a backup disc. I haven’t found out how to do this. Some might say that I can take a snapshot of the VM and that is true, but if I wanted to install hassio somewhere else, I prefer to use the hassio snapshot. If anyone is moving from RPi to a NUC using a snapshot, I advise you to delete the home-assistant_v2.db file and let hassio rebuild a fresh database after restore/transfer. One advantage of using Ubuntu is that it is very easy to access the snapshot file and back it up elsewhere.

Other things of note was that I was using a Raspbee zigbee GPIO module, which was brilliant and I am now using the USB version, Conbee. It is very responsive and installed/worked very easily. One warning is, reboot or shutdown through hassio will literally reboot or shutdown the NUC. It is best to do this, as stopping hassio (i,.e. through Ubuntu shutdown may disable automations, but in these cases, I made an entity card to check that automations are enabled. The NUC I’m using is silent, I cannot here it! The bios states that the fan is running at 2000 rpm, but I can’t tell.

As a new user, apparently I can only post 2 links, so sorry if there is a lack of links.

I hope my experience above is of help to others. I am very happy with the NUC.

Intel NUC, Ubuntu and Docker - Gotta Love It!
Connection refused after restoring backup, no errors, samba working

Great share. Thank you!


Awesome, I was planning to do the exact same setup. Great to hear that it was a painless experience. I can use one right now…


What path did you use to connect to samba from a computer in your network?

I was able to follow your steps without any problems, though I’m having trouble getting Samba to work. It might be because my Hassio installation is on a VM (VirtualBox), to verify if that’s the problem I would like to be sure that the path I use is correct.

Thanks in advance!


Hi all

I am running Hassio on an Intel NUC with Proxmox from about two weeks. The VM OS is Ubuntu Server 18.10

What I’ve noticed, is that the Xiaomi Aqara Gateway is not working properly (it works only for the light), not working on the sound part.

I’ve read that when in Docker Hassio (but also other container) should be run with the option --network host --user 0

Same things happens to my other VM with Nodered, if I try to connect to the gateway thru the proper node, it does not connect.

I’ve Portainer to manage Docker, but I haven’t found a way to add this --network host --user 0 option to the actual node without loosing anything.

Is there a way?



If you’re running Hass.io, the install would have taken care of this.


I’ve installed Hassio following this guide

In Portainer in the Container homeassistant/qemux86-64-homeassistant the network is host and in the hassio_supervisor Container I have bridge and hassio networks.

But, as I said, the Xiaomi Aqara works only as light, but not as sound

My config is

  discovery_retry: 5
    - key: !secret xiaomi_aqara_key
      host: !secret xiaomi_host

I’ve set also log

  default: error
    xiaomi_aqara: debug

But I don’t anything in the log

I have only the entity light.gateway_light_xxxxxxxx and nothing more.

But maybe I’m wrong and there is something else in the xiaomi aqara configuration

PS: I found this thread and it seems he has same issue, not resolved