My steps to success for Hass.io on Intel NUC


#163

Well i’m not sure how, but i now have it working.

I have a 256gb SD card, and also a 64gb usb plugged in…if either of those are not there is does not boot, and requires both of them to boot. does that make sense?


#164

mate, you can use Etcher to burn directly to your ssd and done… :slight_smile: may be you need to buy a USB adapter to connect your ssd.


#165

hi, anyone know or tried to setup wifi on NUC? cheers


#166

Optional - set up the WiFi or static IP: On a USB stick, create the network/my-network file and follow the HassOS howto.


#167

Hi, I bought the new NUC8I3BEH with i3 8109U cpu + 8 GB DDR4 + 250GB SSD
I installed Windows 10 Pro 64bit
I installed VirtualBox 6.04 for Windows
I created a vm based on Ubuntu 64bit
I mounted the hassio 2.8 vid image
I restored my last snapshot I had on RPi3
Almost all works… but it seem do not find internal bluetooth device… then bluetooth_tracker do not works… and then my presence detection system do not works.
Can anyone help me?


#168

Are you even able to pass that through to Virtualbox? The only hardware that will work is what you give it.


#169

@ flamingm0e
Yes, Virtualbox see it as a usb Intel wireless device [0002]
I tried to use a Trust usb bluetooth stick… Virtualbox see it as a Broadcomm Bluetooth wireless device but… Hassio do not see it.


#170

I’ve been struggling today to get HassOS to run, but I’m not getting anywhere.

I’ve been using the latest (2.8) image for nuc. Now I got thinking, which version have you that have succeeded with this used? 2.5 or 2.8?

I’m going to give 2.5 a try tomorrow.


#171

I started on 2.5 then upgraded to 2.8. All working fine.


#172

I have been trying for the past day without any success.
I’ve got a NUC6i3 which I previously had CentOS+Docker, but I wasn’t happy with it, and I’m generally not a Linux person anyway. So I thought I’d try HassOS as it has everything available which my previous setup had anyway, but I want a simplified UI and easier maintenance.

I have tried all sorts of combinations now, starting with v2.8.

  • Installing from a 32GB USB drive, but doesn’t finish. Even left it overnight.
  • When using the network config USB to connect to Wifi that also doesn’t work.
  • Using live Ubuntu to DD an img to the SSD. This completes successfully (AFAIK), but it then doesn’t boot.
  • And just now I tried v2.5 and with the same results.

I think I’m now to the point that I have to accept that this is still early days for NUC development, and that there is still room for improvement. Unless anyone has any other suggestions?

I’ve been wanting a dedicated HA device for a while now, and HassOS is so far the closest I’ve come. The ability to go from an off state to HA operation in the shortest time and in the simplest manner is the goal. I know the NUC is overkill for this, but it is exactly what I purchased it for.


#173

Have you updated the NUC firmware to latest and defaulted the BIOS settings? Also, have you tried removing the HDD/SSD and burning image direct to that?


#174

Yes to both firmware and bios, no to a direct burn of the image to SSD. I need to get an appropriate cable first, which I guess might be next on my list of things to try.


#175

I’m running HA in a dedicated NUC, on a clean Windows installation. Just install Python and then install HA in a Python virtual environment. Mine is at a different location, and this way I can access the OS via TeamViewer and use the NUC for some other servers, like Plex. I think Z-Wave would be the only issue, but I don’t have any. So far to me it’s been rock solid, and the difference in speed and response vs RPi is outstanding.


#176

I finally managed to get it to work.

I’ve been using Ubuntu live distro for putting the image on the SSD. After some googling on where it got stuck it seemed to be some issue with Ubuntu so I tried Parted Magic live instead since others used that. Doing the exact same thing from there solved it for me.


#177

Thanks for the suggestion. I just purchased a copy of PM to try but with a similar result. Image attached.
To clarify, I only have an M2 drive installed, and in GParted it is listed as NVME, not as a SATA SD# drive.
So I’m unsure if this message is regarding it trying to find a drive which doesn’t exist?


#178

I was getting an error when it started to detect USB devices connected through a hub it would just hang there


#179

I’m still not really having any luck.

I’m trying to boot off an 256gb SD card…I flash the image and I get the boot menu with Auto Boot/ system 0/system 1/ shell. And what ever I choose nothing much happens.

I have flashed a USB drive with the image…and I get a similar issue.

But if I have them both plugged in I can boot of one of them…I’m not sure which. Is there a way to tell?

And then if I remove either of them it will not boot again


#180

What are you flashing? I ‘burnt’ the DVD disk 1 to my USB drive and booted from that and it was straightforward setting up debian from that point…


#181

I’m running Hass.io mate.

So…I have found that i’m booting off the USB and not the MicroSD…i flashed the micro SD with a clean image, and my old data is coming up…so i know i’m running of the USB…but if the MircoSD is not installed, it does not work…


#182

Well so am I but via Debian and then a generic Linux install of hass.io all on an SSD.