My steps to success for Hass.io on Intel NUC


#103

0.84.6 (Beta) HassOS image is now available for download for the Intel NUC platform. Testing today.


Choosing an installation method for NUC
#104

Any luck? I tried with no success. Freezes at the autoloader menu on first boot. Maybe I’m missing something


#105

The Hass.io gods do exist.

Have a nuc with dead HDMI so this will work perfect.


#106

Sadly, me too.


#107

Anyone know of these steps are still required?

Installation
Currently there is no shiny installation method. Checklist:

Boot PC to live-environment using PXE or USB
Copy or download the hassos image into your live environment
zcat the image to local harddisk
Reboot


#108

Here I was hoping I could just use etcher with the mssd and install back into the device and boot.


#109

That is not hass.io right?


#110

Apologies for the late reply. Did you manage to install Hass in Docker?

What I did in the step you are in now (guessing) is I didn’t install hass.io through Portainer, but I installed it by ssh’ing into the host and running the following command:
docker run -d --name=“home-assistant” -v /PATH_TO_YOUR_CONFIG:/config -v /etc/localtime:/etc/localtime:ro --net=host homeassistant/home-assistant

After a while you will see homeassistant popping up in Portainer after which you can configure things like config directory and mounts easily through the Portainer interface (through editing the container and redeploying it)

The challenge starts if you want to leverage USB devices as after every reboot the name of the USB devices changes. You can overcome this by creating udev rules which essentially bind an usb device to a specific port based on serial number and/or manufacturer


#111

No worries because you can’t install hassio through Portainer.

Why do so many people have problems with this? My zwave stick never changes dev names on reboot.


#112

Do you have 1 usb device attached or multiple ones? The issue only pops up if you have more than 1 usb device installed.


#113

I only have one zwave USB stick.

Everything else is over the network


#114

That then explains why you don’t have the issue :slight_smile:
The naming of USB devices (or specifically their mount points) determines on the order through which they are discovered after boot. So if you do not use UDEV it is a bit of a gamble whether your usb devices gets mounted to /dev/ttyUSB0 or to /devices/ttyUSB1


#115

Just to let


#116

Hi Frank, thanks for continuing to help! I now have access to Portainer on the NUC now and I can use your terminal command to install hass.io. However, what do I put in as /PATH_TO_YOUR_CONFIG?

I am on the NUC itself, so not SSH’ing from another computer.


#117

That’s the nice part: you decide :slight_smile: it can be any path in the container or a path inside the host (don’t forget to make it available inside Portainer!)

My suggestion is to go for the simple “/config” option and to install the hass.io samba plugin later. If you do that you can always approach your config directory through a samba client.


#118

Pick a place on the host OS that you want to store your configurations.

But, you guys aren’t installing HASSIO if you are running docker run. You are installing HOME ASSISTANT

hassio isn’t installed with the normal docker run commands. there are no addons with the normal home assistant docker image, which you have supplied the instructions for.


#119

Are you sure? I am pretty sure I completed those steps (though it has been a while ago) and my installation looks like below…


#120

100% without a doubt, the homeassistant/home-assistant image, is whole heartedly HOME ASSISTANT only, it is NOT hassio.

This command is for regular home assistant only.

Just look at the image it was pulled from in portainer.


#121

Aha! Then I must have used: https://github.com/home-assistant/hassio-build/tree/master/install


#122

Given my confused attempts with Docker and the fact that I only need the NUC for Hass.io anyway, I thought it might be somewhat easier to just use the new NUC Hass.io image and do exactly what I did on the Raspberry Pi.

So I downloaded the NUC image, flashed it onto a USB stick, put the stick into a NUC with no preexisting partition. However, I get stuck at the very beginning when this menu shows up and none of the options seem to do anything.
image

Can anybody guide me towards the next steps?

On the Raspberry Pi, this worked without a problem, but the NUC seems to be a different animal.