MyQ - Acting Up Again!

I was checking HA logs this morning. While doing so I ran across a significant number of errors on MyQ. I’m running HA 2021.1.1 which, according to upgrade notes, contains a fix for the integration issue identified in Dec 2020. I don’t understand what’s happening and could use your help in correcting the problem.


Logger: homeassistant.components.myq
Source: helpers/
Integration: MyQ (documentation, issues)
First occurred: January 9, 2021, 8:10:48 PM (443 occurrences)
Last logged: 7:53:01 AM

Unexpected error fetching myq devices data: Error requesting data from 500 - Server Error

Traceback (most recent call last): File “/usr/src/homeassistant/homeassistant/helpers/”, line 144, in async_refresh = await self._async_update_data() File “/usr/src/homeassistant/homeassistant/helpers/”, line 132, in _async_update_data return await self.update_method() File “/usr/local/lib/python3.8/site-packages/pymyq/”, line 226, in update_device_info devices_resp = await self.request( File “/usr/local/lib/python3.8/site-packages/pymyq/”, line 157, in request return await self._send_request( File “/usr/local/lib/python3.8/site-packages/pymyq/”, line 122, in _send_request raise RequestError(message) pymyq.errors.RequestError: Error requesting data from 500 - Server Error

Check out these threads.

The information is there. (No need for yet another thread on this.)

1 Like

I managed to get the MyQ integration working again. Reinstallation did the trick. Seems the original install lost authentication. I had the same problem with the ecobee integration. Reinstallation and authenticated corrected that so I tried the same process on the MyQ integration - voila, working once again!

However… reading between the lines - it appears the MyQ integration is unstable and I should look at other options.

Thank you for those links. Through them not only did I find some interesting garage door solutions, I also found a nifty sprinkler control by OpenThings.

Yes. That Open Sprinkler looks interesting. Right now I have a valve that I can turn on and off and automations that turns the valve off after 2 hours unless I have a “lock-on” switch set.
Aside: My wife uses it to water the gardens. In fact one of the reasons she agreed to my tinkering with Home Automation was this capability. The other was making the kitchen lights collectively turn on or off regardless of the switch you use and the same in the bathroom. If you’re having issues with spousal consent, finding a few of these cases can help immensely. :wink:

For the past several days, I’ve had an issue where the integration breaks and reports “invalid username/password.” Deleting the MyQ integration and reinstalling it (with the same user name and pwd combo) fixes it, but it breaks again on restart of HA. Anyone else experiencing this?