Myq integration stuck on initialization

My home assistant Myq integration does not work and Myq fails setup. I’ve tried deleting the integration and adding it again but was not able to add it back. Currently running latest home assistant (2023.9.0) and tried loading backups (2023.8.3) with no luck. Curious to know if anyone else is having problems like this.


Welcome, I can recommend the search function in the forum:

Problem is happening to everyone. Not just HA.

There is a very long discussion thread about it on GitHub as well:

Can confirm, I’m having the same issue. I reported it as a reply to the blog post for the HA update, but now I see I’m not the only one, makes me feel a little better.

I’m in the same boat. Integration not working.

The workaround solution is in, I followed the steps and I can see MyQ from Home Assistant again.

Thanks, any idea if the workaround is safe? I’m always a bit hesitant on running a user’s script.

From my understanding of the thread on gitub this is not an official solution by the developer.

I think it’s regional / load balancer / smth related. Some folks in the US West region say things just started working yesterday. I’m in US east and my integration still has the same errors after multiple HA restarts.

I’m exactly the same way and it’s a good way to be IMO. If you’re using docker, I found this comment to be my solution and I understood everything that was happening:

As someone on Github pointed out, the Github issue reporting for MyQ regarding this issue has gotten hijacked with solutions and workarounds which should be here in this forum rather than in a bug report. But regardless, as many including me have discovered, the integration just started working again with no change whatever. The one NA exception as of this writing (Thursday 10:43 Central time) seems to be the eastern NA region. The working hypothesis is that the issue is on the MyQ end, possibly with load balancing, and not an actual problem with the MyQ integration.

Got’cha. Hope they sort out their crap. :smiley:

I hope this is okay to post, just trying to help with the troubleshooting process:

I’m in western Canada and the myQ integration has not fixed itself. I’ve rebooted my home assistant raspPi, removed and reinstalled the integration but with no luck. So this isn’t limited to eastern North America.

I have not tried the hacks suggested on this thread.

Thanks, I’m running HA on a raspberry pi.

But I think I’ll try this solution if it hasn’t fixed itself in the next day or two.

The myQ app works… but getting tired of having to open it up.

myQ just stopped working (again). I hope Chamberlain gets their $#@ sorted soon.

Mine is still not working. California.

Any news?

Same issue here. Mine seem to have broken in 2023.9.2. Any update?

Mine started working and stopped again.

Same here. Not working in North East USA. I am about to whip up a wemos d1 mini and use esphome to make my own opener. I’m done with 3rd party integrations

I picked up a MYQ homebridge and connected through the homekit integration. Didnt want to spend so much, but the Garage door automations are important to my day to day living in my home.