MYQ not working again

Thank you! This worked for me.

Not working for me… but I’m probably doing something wrong.

I open the Terminal window and paste the following:

docker exec -it homeassistant sed -i ‘s/okhttp/3.10.0/pymyq/g’ /usr/local/lib/python3.8/site-packages/pymyq/

and it returns the following error:

sed: bad option in substitution expression

For reference, I’m running hassos 5.8 on a Pi 3B

There was an error when that command was first posted, the forward slash in the string okhttp/3.10.0 Needs to be escaped.

Edit: found the correct command in the GitHub pull request discussion:

docker exec -it homeassistant sed -i 's/okhttp\/3.10.0/pymyq/g' /usr/local/lib/python3.8/site-packages/pymyq/

1 Like

Is this going to be patched in the next HASS patch, or will everyone need to manually run that command?

Check GitHub for the merge status of the pull request.

Off topic but for those asking about 3rd party hardware options or running into the button sending unique codes, there are options. Never found MyQ reliable so I went with a GoControl and ran into the Security+ code issue. To get around this you can pop open the wall button and solder your relay directly to the button contacts (mine had 4 so i just used a wire to short out and identify which two resulted in close\open). The post I used from another forum appears to no longer be available but it was fairly simple to accomplish. I do remember others talking about buying a spare wall button and doing similar so they didnt risk damaging their primary wall button (I just went for it).

@bs87 like this???

Yep, that isn’t the guide I used and the button is different (I don’t have an LCD) but that’s exactly the same premise. Since my installer used ethernet cable I had 2 extra strands I was able to use to get from the opener to the button and mount the GoControl at the opener. Looks like that guide went with a button up by the opener which would work just fine. You could also mount the relay down at your button if you had power and were just using your original button.

I am just now installing this integration so I never had it working before. I am getting the ever-useful Unexpected Error. I went into the docker container and modified DEFAULT_USER_AGENT to some random string, but still getting it. Does this only work if you already had the integration working previously?

Still working for me… Here’s what I did:

Ran the following command after SSH’ing into HASS (you’ll have to disable protection mode):
docker exec -t -i homeassistant /bin/bash
Then I just manually edited the file using vi, changing the user agent to “pymyq”.

1 Like

@bs87 I have the non-LCD type as well. Anyway you could find the procedure you went off of? Id like to do it.

That worked, I had to set it explicitly to ‘pymyq’

The site no longer exists and I couldn’t find it archived either. That other blog should work just the same though. My button was basically identical where it connected to the circuit board. 4 contacts, just had to determine which 2 triggered the button push. I just used a short piece of wire to test them.

I finally ditched MyQ, for “meross Smart Garage Door Opener Remote” just installed it today and it works great! So easy to get going. Even links directly to HomeKit. Best thing is when it closes there is no beeping, it just closes the door.

Does anyone know how to access the file from home assistant os? I’m running it in a VM and I connect with SSH, but I don’t see the file /usr/local/lib/python3.8/site-packages/pymyq/ (there is no folder named python3.8 in /usr/local/lib)

you’ll need to login to the container. just look a few replies above and you’ll find the docker command.

Exactly what I was asking for! Thank you!

Does this integrate with HA or do you need Apple HomeKit?

Meross integrates through HACS

What is HACS? This? If so I do not see how that is used to setup a garage door opener.

I found the Apple HomeKit Controller integration. Will this work?