Nabu Casa "no response from instance"

This again.

HA is running normally. Configuration/Home Assistant Cloud/ Nabu Casa Account shows “Cloud connection status…Connected”. The mobile app is working, over the internet (wifi disabled).

But if I go to nabucasa.com, log in and click Connect, I get the now-familar “no response from instance”.

Tried logging out from NC on HA, logging in again. HA says “connected”, but same error from NC.

Then in HA I turn Remote Control off, and on again. Now NC can connect and give me the desktop.

I’ve been through this in the past, opened a ticket at NC but was only told to be sure HA was updated. That was months ago.

Could someone at least say “it’s not just you”?

4 Likes

You’ve been waiting months to hear this bro but “Its not just you” this has just happened to me this morning and I’m unable to even enable then disable Remote Control in HA.

Still trying to figure out how to fix this

Same here. Happened this morning. The nabu casa cannot connect.

Is the service down?

1 Like

Same here. Haven’t had a problem for a while but can’t connect today.

I fished up the last email from NC support, replied and attached my log file. But I’ve gone around with them 3 times now and they have no solution.

1 Like

There was no outage at that time or currently.

Your server needs to be able to connect out to the service to then initiate and maintain the connection. You don’t ever need to sign in at nabucasa.com to connect.

On your own server, you should first verify that you are signed in and the next billing date is correct within the Configuration > Cloud card. If the date is is the past, you’ll want to submit a ticket at nabucasa.com/support using the same email address used for the subscription.

If that looks good, you want to then confirm that the Remote Control is enabled on the Cloud page and that your URL appears in that card. You click on that URL as a test. If it works, then you are good. That URL never changes and it can be bookmarked or added to your favorites. It’s a good idea to do this, as you can use the to differentiate an issue with the connection by testing it in a mobile browser vs a potential issue with the mobile app.

If it doesn’t work, signing in at nabucasa.com and clicking on “connect” will not work either. Your instance (your HA server) and the service are not communicating with one another. Signing in at the site to connect simply instructs your server to toggle that remote on if it is off. If they can’t communicate in the first place, this won’t happen. I’ve been using the service for years and never sign in at the website to connect to my HA instance.

At that point, if it still is not working, you should start with a reboot of your host. This can be done from the Configuration > Supervisor > System > Host card in the UI on a standard HA install.

Restarting HA does not restart your system or networking, whereas restarting the host does. This might shake out some network issue you might be having.

You can also check the Configuration > Settings > Info page and look at the system health under the “Home Assistant Cloud” section. You want to see that everything there is “true” or “ok”.

My system health shows “connected” and everything else in HA seems to be working. Clicking on the URL for Remote Control does not work, it gives me “Unable to connect to Home Assistant”.

I then logged out of NC and logged in again. Immediately, that URL works, and so does the mobile app. There’s nothing relevant in the HA log, just a very long stream of this:
2022-03-30 08:35:13 ERROR (MainThread) [snitun.client.connector] Can’t connect to endpoint 127.0.0.1:40365

This problem recurs every now and then, and it’s always the same. Whatever is causing this, I have no way to debug it and NC support has not been able to help. I guess I’ll abandon NC for now and set up Duck DNS as my remote access. My guess is that this is a bug on the HA side which apparently affects few users; maybe it will get fixed someday.

I had a similar issue last week - my Home Assistant instance was clearly running and connected to the internet as it was successfully sending out email notifications (and other internet-facing services on the same host were also working), however I couldn’t connect to it via Nabu Casa (either using the Home Assistant companion app or directly via the URL).

Unfortunately I had to restart the host for another reason so I don’t have the logs to hand (I’ll try to look in more detail if it happens again), however I wanted to add another +1 to this. Restarting the host with Home Assistant has since fixed the issue for now, but clearly that is not a real solution as it defeats the purpose of being able to access it remotely.

2 things that stand out when this happens to me:

  1. HA still shows the NC status as “connected”.
  2. A working connection is restored by logging off/on NC from HA. It isn’t necessary to restart HA.

I don’t want to keep paying for NC if it isn’t totally reliable. Can I use the HA mobile app with Duck DNS?

2 Likes

Yes, the apps are independent of the cloud service. It is not required to use NC in order to configure them for remote access.

1 Like

I just stumbled over this thread, as I am trying to assist my brother, which has the exact same problem…

Status:
image

The HA is running as a VM on an ESXi server. Everything works fine locally, and we have tried to restart the VM as well (not just HA) - and we are still unable to connect via the Nabu Casa homepage…

Using the direct link (with the unique ID) works fine… ?

Any hints ?

What do you mean by direct link with unique ID? The Nabu Casa URL?

If that is working then there is no need to sign in at Nabu Casa to connect. That’s your address to reach your HA server. It will not change and you can bookmark/favorite it in any browser. Signing in at nabucasa.com is only used to activate your remote control so that the URL is active. If it is already active, this is not needed.

Solution:
Go to settings
Click on home assistant cloud [cloud connection status will be “Not Connected”]
Click on Sign out
Sign back in.

It should not be Connected

5 Likes

Exactly as you said Mari143 - thank you so much :pray: :pray:

This worked perfectly! Thank you so much!

This is the only answer. Don’t waste time with anything else.

I was having this issue and I signed in and out of Nabu Casa within Home Assistant and all appears to work again. Even months later, the solution @Mari143 called out worked! Thanks!

(+) 1. Tks @Mari143 !
I wish I could mark this as solution on the post.

1 Like