Nanoleaf Aurora Component

At long last, the Nanoleaf Aurora component is ready for testing!

Please give it a try and let me know what you think. If anything at all doesn’t work for you, please let me know.

2 Likes

Thank you for doing this. I have 2 Auroras and installed your software today, and am pleased to report it works great.

Only one bug to report - it seems the display of the colour temperature slider is backwards. It displays as cool on the left and warm on the right, but actually works in the opposite direction.

Having said that, I was still able to use it to match the colour temperature of my dining room Aurora to the Philips Hue lights I have over the dining table. That’s something I wasn’t able to do with Nanoleaf’s own app, so that’s a big improvement.

Next up is to deactivate the IFTTT automations I have setup to turn them on and off and bring those into HA.

Once again, brilliant work and thank you.

1 Like

Hi, thanks for your hard work! Can confirm what funhouse said, my color temperatures are reversed. Basic functionality looks good. My nanoleaf module didn’t get installed automatically; I used the node.js functions to pull a token off the device and then manually created your component and on a restart the dependency didn’t get pulled. I’m on 0.48.1.

Thanks for the feedback guys! I’ll look into both of those issues.

Thanks for your efforts on this - it works great for me.

I had the same installation issues as the other guys.

One other very small issue: - when I use an automation to set the brightness to a low value - like in:

  action:
    - service: light.turn_on
      data: 
        entity_id: light.myaurora
        brightness: 10 
        effect: Nemo

the brightness is set to a slightly different value - for the example above, it gets set to 7.65 instead of 10.

Hey,

sorry im new into all this stuff im im very happy that I can integrate my Auroa to HA but I also use the nanoleaf Ivy Smarter Series lights. Is there a way this component can also control this lights? Or is there maybe another solution?

Kind Regards
Mike Auer

There isn’t currently a component for it however it could be possible. The nanoleaf ivy bulbs look to use zigbee so if you have a hue or wink hub then when you connect the bulbs to either hub they should show up in home assistant.

Getting an error when trying to run pip install --upgrade nanoleaf so that I can get the API key.

Error here: http://i.imgur.com/lSybsYC.png

Any idea’s?

I don’t have an Ivy to play around with. Does anyone know what’s different about it?

Any plans to PR this into HASS?

2 Likes

Yes, but there are some more fixes I need to make first. Since I originally wrote this, Nanoleaf has released some firmware updates that fix a lot of bugs with what the device reports back.

The two big features I want to add first are: Not needing a static IP, and baking in a bunch of effects that can be accessed via hass without needing to store them on the device’s limited memory.

2 Likes

@Software2 If you need to do any testing on a build before submitting a PR I am happy to help out.

1 Like

Any update on this? Sometime this week I’m going to be testing this out, if there’s been any developments I’d love to try those out too.

Hi! I’m having some trouble installing this. I added aurora.py to the custom_component folder in /.homeassistant/, but when I run pip install nanoleaf --upgrade on my Pi I get this error:

Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-DYUTdG/nanoleaf/

Any help would be appreciated :slight_smile:

Okay, turns out using pip3 solved the problem. Still having trouble trying to generate the Auth key though :frowning:

Did someone successfully make it run with hass.io and could post some brief instructions?

Were you able to get the api key? I cant seem to get it…

Yes actually, from this thread here: Nanoleaf Aurora API Key

The instructions I followed are from this site here: https://www.technikkram.net/2017/05/nanoleaf-aurora-via-api-zugriff-per-homematic-steuern (I used Google Translate to follow along :slightly_smiling_face:)

Hi,

I’m still trying to set it up on hass.io and getting the following error:

2017-12-26 16:06:01 ERROR (MainThread) [homeassistant.loader] Error loading custom_components.light.aurora. Make sure all dependencies are installed
Traceback (most recent call last):
File “/usr/lib/python3.6/site-packages/homeassistant/loader.py”, line 142, in get_component
module = importlib.import_module(path)
File “/usr/lib/python3.6/importlib/init.py”, line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File “”, line 994, in _gcd_import
File “”, line 971, in _find_and_load
File “”, line 955, in _find_and_load_unlocked
File “”, line 665, in _load_unlocked
File “”, line 678, in exec_module
File “”, line 219, in _call_with_frames_removed
File “/config/custom_components/light/aurora.py”, line 1, in
from nanoleaf import Aurora
ModuleNotFoundError: No module named 'nanoleaf’
2017-12-26 16:06:01 ERROR (MainThread) [homeassistant.loader] Unable to find component light.aurora

Any idea on how to install the dependencies on hass.io?

Sorry I don’t know much about hassio. Hopefully someone else can help you out.