Need help Connecting my HA to the Internet

I have tried multiple tutorial, but I can’t seem to access my HA from the internet. I followed every instruction to the T, but no matter what I couldn’t access my HA from the internet. Because my ISP doesn’t provide Static IP, I used the DuckDNS. I forwarded the ports on my router. Although most online tutorials were using UniFi or pfsense routers, I had a TP-Link one. But I understand the concept of port forwarding & I port forwarded the necessary ports on my router. I was not able to access my HA from the internet. Can some please post a step by step guide on how you setup & accessed your HA from the internet. I am a noob at this, so it would be very helpful if you could post with as much explanation as possible.

When you go to the duckdns setup web page for your domain does it correctly obtain the public IP address of your router?

Did you edit the DuckDNS addon configuration ans set accept_terms to true?

Are there any errors in the addon log?

In my router’s web UI, the Internet IP address is different than from the one I see when I search whatsmyip. Wait my Internet IP address & my Public IP address are the same thing, right…?
Yes I edited the DuckDNS config.
No there are no errors in the addon log.
But when I followed the instruction of the online guide it says to check if the ports are open or not by going to There when I try the 8123 or 443 port, it says " **Error: I could not see your service on on port (8123)"

I was checking the port forwarding section of my router. The port forward entry I created for the 443 has disappeared. And when I try to create it, I get an error message saying “Conflicting with existing port: 443. To avoid conflict, please enter another value.” I am attaching a picture of the page where the 8123 port forwarding entry is there.

Tried to create the 443 port forwarding entry again & it was created successfully. Here is the screenshot of that page. But I still can’t access my HA from the internet. BTW I tried & it still shows that my 8123 & 443 ports are not open. Can someone please help me?

I even tried enabling the DMZ setting along with disabling my Internet Security Suite & I made sure that both my Windows & Internet Securitty Firewalls are disabled. But no luck; the ports still show as not open. I am attaching a screenshot of the page from

Sounds like your ISP is using CGNAT which is incompatible with dynamicDNS services like DuckDNS.

Are there any work around for this?

Contact your ISP and ask if CGNAT can be turned off for your account.

Otherwise services like nabu casa (Home Assistant Cloud) will work. You get to try it free for a month , then $5 a month. The profits go to supporting Home Assistant development.

I just confirmed with my ISP, they are not using CGNAT. I will consider using nabu casa, but not until I figure out what the issue is exactly. Wait, my port not being open has nothing to do with DuckDNS. Can someone please tell me why my port is not open, even though I port forwarded?

BTW I randomly tried to port forward port 1212 on my computer & I that port is still showing as closed in I am a total noob at this; but I think something might be wrong with my router. Or does anyone else has any way to check if port forwarding is working or not on my router?


Since HA is listening on port 8123, you need to forward port 443 to 8123…
So my.public.IP:443 forwards to

You can also use 8123:8123, but then you need to use https://my.public.IP:8123

PS:/ Your public IP you can find with

Still not working. Attaching a screenshot of the config. Going to the canyouseeme website still shows the same error message i.e. couldn’t see your service IP addr on port 443ed1

There a tick box to enable it at the bottom. Tick it.

Yes yes I have enabled that.

Are you using the IP found with ?

You should also check with comand line:
to see what ip’s you are traversing

If your ‘public’ IP starts with 192, 172 or 10 it means your ISP didn’t give you a public IP, but a private one (and they cannot be routed ober the internet)

There must be some program listening on port 1212…otherwise it is still not responding

Yes I searched findmyip in google & there it showed me my public IP addr.
Sorry I don’t understand what traversing is. I mean I ran that command in my cmd & it shows me a bunch of IP addrs.
No my public IP doesn’t start with 192 or 172 or 10.
BTW after enabling port forwarding on my router, I went to the website There it detects & grays out the IP Address box. There when I enter the port number 8123, it shows me an error message “Error: I could not see your service on on port (8123)
Reason: Connection timed out”.
BTW when I entered port number as 53, it says “Success: I can see your service on on port (53)
Your ISP is not blocking port 53”

So far everything appears to be configured properly in the router :thinking:

When you tried the tracert, did it show your ‘public’ IP directly behind your routers IP 192.168.0.?
Or where there still some IP’s in between?

I am asking because the other side of your router is (or should be) the public IP

Actually my public ip addr doesn’t show up at all there. The 1st IP adr was of my computer, 2nd was xx.xx.xx.x, 3rd was xxx.xx.xx.x & so on and so forth. But my public IP adr was not in there.