Need help Connecting my HA to the Internet

Does it completely freeze, or still respond to ping?
If pingable…does SSH still work?
If so, you can still check the logs…

I already had an old laptop running (plex and some other software) so added HyperV

It completely freezes. It doesn’t respond to ping.
No, ssh doesn’t work.
Can you please tell me where the logs are. I mean when it freezes I can’t use ssh to access it. But in which location is the log saved. I mean if I can see the log, I might be able to find something or at the very list if I don’t understand it then I can post it here.
Still nothing can beat the efficieny and low power of a Pi.

I think you should start another topic for that…
it also depends what kind of install you have…

Have you searched this forum?

1 Like

There are many topics regarding this. And there are many proposed solutions. But most solutions are pretty generic. But after this topic concludes, I will try to find out what the issue is. BTW I talked to my ISP regarding what we discussed yesterday; these are the things they told me:

  1. I told them about them about my public ip not matching with my tracert. They told me that my public ip is a “NATing IP” & it will not show because it is “DNATting” always. They told me that purchasing a static IP “might” solve this issue.
  2. I asked them about the modem having port forwarding option. But they told me that the modem is a simple ONU that connects the fiber to the internet. And its port forwarding option is only for trasnport link.
  3. They also confirmed that they are not using IPv6.
  4. BTW when they told me that the dynamic IP or “NATting IP” is not showing up in tracert. They told me that is routed to google peering. I couldn’t understand this. Can someone please explain?

I have a small question. Does anyone know how to check if my router; the first IP in tracert, has the port 8123 open or not. Because if I can confirm that my router’s port 8123 is open then I show them this as a proof that I have port forwarded from my router & now they need to help me port forward from their modem. As the port forwarding option on their modem is not configurable; they must need to allow port forwarding from their end. So does anyone know how to locally check if a router’s specific port is open or not without using internet?

Bottom-line: They might not use CGNAT per se but they are still NAT’ing on their side, which is the same as far as you are concerned.
You will not be able to reach HA (or anything else, really) from internet unless you “buy a static IP” or change provider.

Not sure if Nabu Casa will work in this configuration. @tom_l probably knows.
My guess is that it will because the initial connection would be from your HA to Nabu Casa, so bypassing the NAT issue.

Tricky, but theoretically:

  • Disconnect ISP cable
  • place a PC on the router’s WAN side
  • give it the static IP of ISP’s GateWay (3rd or 4th IP obtained from TraceRT)
    And try to access with a browser (where is the WAN address of your router)

google peering explained

Yes it does.

So will ZeroTeirOne (free).

1 Like

I mean other remote control softwares such as Chrome Remote Desktop, Anydesk, eWeLink web etc are working.
Actually Nabu Casa is working. I opted for the first month free subscription.
Yes I also think that buying a static ip is my only choice. But when I explained my issue to them, they told me that getting a static IP “might” solve this. I don’t want to buy a static IP on maybe. I will talk to them about confirming the issue being resolved using static IP before buying it.

Will try this & get back to you.
3. Wait by giving it a static ip, you mean giving my computer a static ip. Like changing the IP from the Network Connection > Ethernet > Properties > TCP/IPv4. Right…? There you want me to give a gateway ip that I obtained from running tracert when I used my ISP i.e. the 3rd or 4th IP. Right…?
4. If I reach my HA login page that would mean that the port was successfully forwarded…?

I have read about this this before. But I heard that it was calleed Google Global Cache (GGC).

Those work because they initiate a connection to an external server, which then acts as “reverse proxy”. You might think it is P2P, but it is not (you might keep that in mind security-wise).
Nabu Casa works the same way.

What will never work is, e.g., an external browser initiating a connection to your HA directly.

Oh. Thanks for explaining

No it didn’t work. I change my computer IP addr to the 3rd IP addr from tracert. Plugged my computer to the WAN port of my router. When I entered my router’s WAN IP addr it showed is unreachable.

Where are u? I mean what country are you in? are you sure those port is not being blocked by ISP? In my country, some ISPs just block the entire port below 1000. So you will not be able to use those ports. The only way to do it is to use another port.

They have stated repeatedly that:

So it is a NAT issue not a port blocking issue.

That may be more expensive than a subscription to Nabu Casa. Just something to keep in mind.

Because they don’t rely on a dynamicDNS service, they use webhook relays and such.

I am from India.
Don’t know. I asked my ISP regarding this & he couldn’t confirm if the ports are blocked from their side or not. They told me that they will update me soon.
I tried both port 8123 and 443. Both of them didn’t work.

Oh. I have asked my ISP for a static IP. If the cost of the static IP is more than Nabu Casa subscription, then I will take the NC sub.

Wait, the NAT issue is from whose end…?

My ISP informed me that the cost of static IP is around 47 USD per year which is much lower than the Nabu Casa subscription; which is 5 USD per month which translates to 60 USD per year.
My ISP told me to try another thing to check if problem was with my router or not. He told me to connect my laptop directly to my modem onu & changed my laptop’s IPv4 config to match the one in my router. I had working internet on my laptop & as per his instructions I installed a software called WWW File Share Pro. There I used the port number 8123 & then I started the server. I checked the server’s status log & it said there that port 8123 was listening. Then I used google to find my public IP & I entered in my address bar. I couldn’t access that server. I also tried using & it indicated that port 8123 was closed. I also ran tracert on this; my public IP was not matching with any of the IPs in that list.
I have passed on this info to my ISP. I am waiting for them to reply.

The solution that I found to be able to do it. activate the DMZ function on the operator’s router! and put the ip of the TP-Link router deactivate port redirection 443-8123 on the operator’s router and open redirect ports on the TP-Link router !!!

English only please. How to help us help you - or How to ask a good question