Need help with RFXtrx

Our recently-bought house has a few Somfy powered blinds that I’m trying to integrate into HA. I bought the RFXtrx433XL and am having some troubles. I’ve followed the instructions with the exception of flashing the firmware, which I seem to be unable to do either on a Linux or a Windows box - on my Windows box the RFXFlash program never finds the RFXtrx, and on Linux I can’t find the windows visual basic library. Anyway, I seem to have successfully added the RFXtrx as a remote - when I execute the “list remotes” command I get back the following:
------------------------------------------------
3/19/2019 07:05:55:498
Packettype = Interface Message
subtype = RFY remote:0 ID:01 01 01 unitnbr:1 rfu1:A5 rfu2:0 rfu3:5
------------------------------------------------
3/19/2019 07:05:55:822
Packettype = Interface Message
subtype = RFY remote:1 ID:0C 1C 1C unitnbr:3 rfu1:AE rfu2:0 rfu3:E

with remote=0 my original remote, and remote=1 is the RFXtrx.
My problem is that when I execute any of the up or down commands, I get an ACK back, but nothing happens as far as the blind itself is concerned:

================================================
3/19/2019 07:08:30:398= RFY command
================================================
Packettype    = RFY
subtype       = RFY
Sequence nbr  = 9
id1-3         = 0C1C1C decimal:793628
Unit          = 3
Command       = down
rfu1          = A5
rfu2          = 00
rfu3          = 05
Signal level  = +10 dBm
------------------------------------------------
3/19/2019 07:08:31:164
Packettype        = Receiver/Transmitter Message
subtype           = Transmitter Response
Sequence nbr      = 9
response          = ACK, data correct transmitted

Does anybody have any suggestions? As a side note, I noticed that doing all this seems to have changed the behavior of my original remote. Before, an up or a down button push would raise/lower the blind to its stop position and then stop. Now, I have to hold the buttons down to raise/lower and the motor will not shut off when it reaches the stop position. Odd.

Thanks in advance.

Stan

1 Like

Update: looks like I got over my skis a bit. The two remotes showing in the remote list were virtual remotes, not the actual remote itself. I don’t believe my RFXtrx is communicating at all with my Somfy device. Not sure why, unless it’s too old (circa 2002) and the frequencies don’t match. That said, the hardware remote that I have is labeled “TELIS 4 RTS US” so I was assuming that it would work with the RFXtrx.

Hoping someone can help. :slight_smile:
Stan

Stop all other programs on the Windows system that have a connection with the RFXtrx433XL before you start RFXflash!

You have to pair the Somfy RTS motot and use the Program command for this. Easies tway is to use RFXmngr for this.
See the RFXtrx User Guide chapter 9 how to pair a Somfy device.

Hi, thanks for responding. I followed the instructions in chapter 9 to the letter. I have multiple Somfy blinds so I turned off power to all but one. I pushed the up and down arrows on my remote simultaneously and the blind jogged up and down, then I sent the Program command. I then tried lowering or raising the blind with an Up or Down command and nothing happened.

Any ideas?

Thanks again

I guess, you should push the program button on the backside of the Telis remote instead of pushing the up+down buttons.

This is the instruction in the RFXtrx User Guide:
To pair the Somfy RTS device:

  • Select a unique ID and unitcode for the RFXCOM RFY device.
  • Disconnect power from all Somfy RTS devices except the device to pair.
  • Press the Program button > 2 seconds on the original Somfy remote until the Somfy device responds.
  • Transmit a Program command with the RFXtrx433E/RFXtrx433XL. The Somfy RTS device should respond indicating the pair command was successful.
1 Like

Hmm… my remote doesn’t have a Program button on the back of it. But pressing the up/down buttons simultaneously successfully “jogs” the blind.

I’m an idiot. There -is- a Program button on the back, but it’s recessed like a Reset button. Never really noticed it before. It works like a champ now.

Thanks for your help.

Have to ask. No when u got it, do u have any problems with hassio receiving info after ?

As soon as I use my blinds my Rfxtrx stops receiving info from my other 433 units.
(Or at least Hassio stops receiving from Rfxtrx )
My blind works fine but not the receiving to Hassio.

Wish I could help you, but I’m not having any problems at all. Sorry.

Do you see the same problem in RFXmngr after you have controlled a Somfy device?

Once I got my blinds working I never went back into RFXmgr.

Yes i did. But im pretty ashamed now, it was the easiest solution… firmware update

Glad you solved it!

@Sfmcfar: thanks for your topic, I’ve been able to do the same using the RFXmngr documentation in combination with the RFXtrx433XL unit and my Somfy screens. I can now control my screens (up/down/stop) using the RFXtrx433XL when connected to my Windows machine using the RXFmngr software.
But I still lack some knowledge on how to now make this work in Hassio - and hope you can be of assistance.
In my configuration.yaml I’ve added the following entry:

rfxtrx:
** device: /dev/serial/by-id/usb-RFXCOM_RFXtrx433XL_DO2VHZCW-if00-port0**

And when using SSH terminal and the “hassio hardware info” command the RFXtrx433XL device is mentioned.

However, how to I get switches now in my Home Assistant dashboard that allow me to control my screens using the RFXtrx433XL (after re-connecting it to my RPi of course).

What lines did you add to your configuration.yaml-file to get this working and control your blinds from HA?
Can you provide your configuration.yaml entries maybe?
Did you use (in your case and from your sample) the id1-3 = 0C1C1C decimal: 793628 in your configuration.yaml somewhere?

Any help appreciated!

Oh, and btw: I’m a HA and RPi newby :wink:

Thanks!

Fred.

Sure. Here’s what I got that’s currently working with no issues. Note that instructions to correctly identify your devices is at https://www.home-assistant.io/components/cover.rfxtrx/.

# Cover
rfxtrx:
  device: /dev/serial/by-id/usb-RFXCOM_RFXtrx433_XXXXXX-if00-port0

cover:
  - platform: rfxtrx
    automatic_add: true
    devices:
      071a000001020101:
        name: Left Blind
      071a000001020201:
        name: Center Blind
      071a000001020301:
        name: Right Blind
  - platform: group
    name: Great Room Upper Blinds
    entities:
      - cover.left_blind
      - cover.center_blind
      - cover.right_blind
1 Like

Great! This was exactly what I needed - it now all works!!

Is there a way to set the blind to the “My Position” which is supported by the RFXtrx but I can see how to apply this in HA.

Actually I found it in another thread I had to remove the following from the configuration.

signal_repetitions: 2

HI @Sfmcfar - thank you for posting your success with Somfy here. I have just ordered the RFXCOM device because Somfy’s Connexoon just sucks in Australia.

Can I please ask you, or anyone in this thread, are you using the RFXCOM locally to your HA host or remotely? If local, is it on a RaspberryPi? Any help you can share is much appreciated.

Kostas Williams

HHi, I’ve got my RFXCOM connected directly to my laptop on which I run HA but there shouldn’t be a problem connecting it to a remote Pi. I have my zwave stick connected to a Pi that’s centrally located in the house for performance and I use usbip to communicate between my laptop and the zwave stick.

Hope this helps.

Stan