Need host reboot for new z-wave devices to be recognized? (or old to be deleted)

using an Aeotec z-wave stick, I always need to reboot the host to add/delete devices after re-attaching the stock to the rPi. is this as designed? I would have hoped a mere refresh of the z-wave network would suffice, or a restart at most.

btw, I dont have zwave: in the configuration.yaml, only have installed the core integration

thanks for having a look

why are you removing it from your machine? You can include/exclude through the UI.

You shouldn’ add/remove Z-Wave devices with the stick, you should rather use the add/remove node services from the Z-Wave Panel. See the warning here in the docs.
FWIW with the OZW Beta I never need to restart the network when I add/remove a device.

1 Like

thanks! never realized that, after having read the manual of the stick and seeing several videos…

works fine indeed like that. Seems even the advised HA restart isnt necessary, I see the entities appear real time :wink:

and the zwave: entry in configuration.yaml? what is that for (I dont use it now)

1 Like

Isn’t zwave: needed in configuration.yaml in order to enable the zwave integration and get control panel etc.

No, apparently not :wink: I don’t use it. I simply added the integration in the UI

Ah nice, haven’t used the old Z-Wave integration since OZW Beta came out.

Where can I find that? Is it available for Home. Assistant OS too?

And yes, it’s available for Home Assistant OS as well. One of the best things is that the Z-Wave network doesn’t get restarted every time you restart HA.

thanks!
bit confused though, as this:

The ozwdaemon installed and running in your network. For Home Assistant Supervisor there’s an official add-on named OpenZWave available from the add-on store.

seems to point back (after clicking links in circles…) to the core z-wave integration I am already using? or is the ozwdaemon yet another add-on/integration I would need to install separately.

the functionality I would be most interested in is this: https://www.home-assistant.io/integrations/ozw/#service-ozwset_config_parameter, setting specific parameters, which I can not do right now.

With HA OS you need to install the OpenZWave add-on. It has nothing to do with the old z-wave integration at all.

o wait, so the add-on integrates this ozwdaemon already? I was confused by the listing/wording of the sentence there. thought it needed it as step 2, additional piece of software.

wonder if it (is it an integration or an add-on…) will install alongside the existing integration. will experiment some :wink:

first choice, more confusion:

There’s two parts to the equation, one is the add-on which runs the ozwdaemon software (I run this on a separate Pi as a standalone software) and the other is the integratiom for Home Assistant, which you need to setup through the UI, once you have the add-on installed.

hmm, do I need to uninstall the core z-wave integration first? I cant seem to find the correct data for the config flow, ending up in:

I’ve tried all 3 /dev/… options for the USB device path:


and didnt fill out the key (wouldn’t know what to enter there in the first place …

You need to stop the current Z-Wave network first, before installing OZW.
Check out these two guides, I can’t help here as I don’t run HA OS in production.

1 Like

The other thing you need to know is that you MUST be running the built-in mqtt broker for this to work with the add-on. Any external broker won’t work.

And if you do use an external broker you can install the stand alone docker ozw container. But also that mqtt broker must allow anonymous clients since ozw doesn’t support credentials for logging into mqtt. At least it didn’t the last time I checked.

it does support credentials.

I have the built-in broker running on another Home assistant Pi. would that do? Seems the above picture allows to enter the IP address of that Pi without issue?

Thats good to know. Thanks.

Like I said when I last looked into it the integration didn’t support it so i ended up creating another broker that allowed anonymous ckuents do i could test it out. So it’s good that there has been progress there.

I’ll look at the docs to see how it needs done in the non-add-on docker version.

I have no idea.

The usb occasionally swaps to /dev/ttyAMA1 when it is unplugged and plugged back in.