Nest Cam - No image

Just set up the new nest cam component but can’t see the image in the frontend. My configuration is as follows.

  client_id: secret
  client_secret: secret

  - platform: nest

This is the output that i’m getting in the frontend.

My 2 Nest cams are getting the same issue with the latest update 0.34.0

+1 Same error after 0.34. Glad this component has landed, hope we can get the bugs worked out. Happy to share more info to help.

This has been fixed in 0.34.1

Just upgraded and still no image.

Here’s an error I’m getting. Is this the same for others?

  File "/home/hass/.homeassistant/deps/nest/", line 1239, in snapshot_url
  if self._device['snapshot_url'] != SIMULATOR_SNAPSHOT_URL:
  KeyError: 'snapshot_url'

I’m running 0.34.2 (latest version as of this morning) and am still getting this error.

Fixed my issue by ensuring that all the correct permissions are checked in the nest developer portal.

Can you screenshot that so I can compare? I thought I had them set right?

Just make sure that you enable every checkbox and ensure that read/write is checked even if you don’t have that product.

I did that, the weird thing is that Camera has a “read v3” or a “read/write v2”. I assume v2 in this case? Also “Camera + Images” is disabled, and it says you must verify you company. Did you do that?

I’m in the same boat. I did tie the “read v3” and “read/write v2” neither worked. I’m getting the same error on snapshot_url. I’m running 0.34.2 via docker, tho.

16-12-05 20:42:50 ERROR (MainThread) [aiohttp.web] Error handling request
Traceback (most recent call last):
  File "/usr/local/lib/python3.5/site-packages/aiohttp/", line 265, in start
    yield from self.handle_request(message, payload)
  File "/usr/local/lib/python3.5/site-packages/aiohttp/", line 96, in handle_request
    resp = yield from handler(request)
  File "/usr/local/lib/python3.5/asyncio/", line 209, in coro
    res = yield from res
  File "/usr/local/lib/python3.5/asyncio/", line 209, in coro
    res = yield from res
  File "/usr/src/app/homeassistant/components/http/", line 403, in handle
    result = yield from result
  File "/usr/src/app/homeassistant/components/camera/", line 186, in get
    response = yield from self.handle(request, camera)
  File "/usr/src/app/homeassistant/components/camera/", line 204, in handle
    image = yield from camera.async_camera_image()
  File "/usr/src/app/homeassistant/components/camera/", line 91, in async_camera_image
    None, self.camera_image)
  File "uvloop/future.pyx", line 230, in __iter__ (uvloop/loop.c:103945)
  File "uvloop/future.pyx", line 432, in uvloop.loop.BaseTask._fast_wakeup (uvloop/loop.c:107104)
  File "uvloop/future.pyx", line 101, in uvloop.loop.BaseFuture._result_impl (uvloop/loop.c:102363)
  File "/usr/local/lib/python3.5/concurrent/futures/", line 55, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/app/homeassistant/components/camera/", line 98, in camera_image
    url = self.device.snapshot_url
  File "/usr/local/lib/python3.5/site-packages/nest/", line 1239, in snapshot_url
    if self._device['snapshot_url'] != SIMULATOR_SNAPSHOT_URL:
KeyError: 'snapshot_url'

Sorry I responded last night by replying to the email and apparently that didn’t work. Here’s what I said:

So I found out you do need to the “Camera + Images”. I did the “verify your company” but am unsure if I needed to. The biggest thing that you have to remove “Camera” before you can add “Camera + Images”. They’re mutually exclusive but don’t really make it known. Hope that helps.

ah ha! yes. that did it. dropped Camera and added the Camera + Images. I guess they approved my “application” the other day. Worked fine after a re-auth.

hi quick
do i have nest cam but net themo stat… do i need that

Followed this thread and did all the suggestion.

Been trying to add Nest Cam for a couple of days but keep getting [Error loading image].

Added the Camera + Images with read and write like more than 10 times, even recreated the product in the Nest Dev site a few times still [Error loading image].

There was no error on the logs, so everything looks ok.

Well turns out you still need to “TURN Camera ON” on the app or Nest website. Duh!. This should be added to the instruction.

Would be nice to have an option in HA to turn the Nest Cam ON and camera automatically turns on a restart.

Looks like it’s in the works.

I think I did it with my Nest Cam and can the same be done with Ring Stick Up Cam? Or Arlo Q?