Netatmo camera feed stops working after a few hours

Hello,

I changed my ISP and router recently and since then, I noticed that the camera feed of my Netatmo Presence stops working after a few hours. Everything else is fine : I still get notifications from the webhook, the snapshot of the camera is still updated. But the stream won’t load and I get this error in the logs :

2021-09-11 04:16:01 ERROR (stream_worker) [homeassistant.components.stream.worker] Error opening stream https://prodvpn-eu-1.netatmo.net/restricted/10.255.177.13/<id_1>/<id_2>,,/live/files/high/index.m3u8

When I try this URL in a browser, I get an error 403. The 2nd id is wrong. Maybe it’s supposed to change regularly and the integration doesn’t update it for some reason.

From the developer documentation ( Netatmo Connect | Security API Documentation ) I get a different URL.

vpn_url:"https://prodvpn-eu-1.netatmo.net/restricted/10.255.177.13/<same_id_1>/<different_id_2>,,"

Restarting HA or removing and adding the Netatmo integration again temporarily solves the problem.

Has anyone ever had this issue?

edit: I also feel like it shouldn’t use the vpn_url attribute in the first place but the local_url since my home assistant and my camera are on the same network but local_url is set to null for some reason. Maybe the real problem is here.

Found the solution. I was on the right path. The Netatmo API was sending a wrong local_url in 169.254. Rebooting the camera then HA fixed it.

1 Like