Netatmo Cameras gone since 23.10.22

Hi guys,

since yesterday all my Netatmo cameras (Security outdoor) are not transfering any video Stream anymore. The only camera working is the Netatmo Welcome Indoor. I have not changed anything except upgrading to Home Assistant 2022.10.5.

I several times removed the cameras, deleted the dashboard and cleaned the cloud access account in my User Profile of Netatmo, nothing helped.

When manually looking for a new integration, Netatmo shows up and all Cameras are identified. Then the Integration is asking for permission at Netatmo (which I accept) and I receive the message that the cameras are installed. However all Entities do show a red bubble with “!”

In Netatmo Profile the Home assistant show it is authorized.

The Cameras themself do work finde. In the own Netatmo app and also in Apple Home they do work an deliver data as usual.

It worked flawless for two months now (even they are also registered in Apple Home, which the Netatmo welcome is also and still show up in Home assistant.

I have no idea where to look at? I tried to downgrade to 10.4. using a backup but that did not work!

Any ideas?


From what previous version

Please provide debug logs and diagnostics to inspect. But in general I assume you either have to reauthenticate or reboot your cameras.

From 10.4.

Where can I find the specific log for these cameras? The “general” logbook, does not deliver anything regarding the cameras as the entities do not work anyway. So without an installed entity there cannot be any logfile?

The Cameras where several times re authenticated with Netatmo and the netatmo account shows that Home assistant has access.

I cannot reset the cameras or reboot as they are connected to a constant current supply I cannot switch of. Which makes pretty sense for security cameras :wink:

Thy do work fine with Apple Home and the Netatmo App. So i cannot imagine why to reboot them? I several times rebootet the Raspberry Pi HASS is running on

I suspect the API returns the wrong IP address for whatever reason. The debug logs will show. There are no specific camera logs, just the normal HA logs with debug level for Netatmo is sufficient.

Sounds valid. Where do I find the log. Is it the standard “Logbook” I am afraid there is no single “Netatmo” Entry. They are simply not connected …and so I cannot even add them to a Dashboard as the entity is not working

Is there any chance I can wipe all “Netatmo” entries in a config file or history?

Edit myself:

Logger: homeassistant.components.netatmo
Source: components/netatmo/
Integration: Netatmo (documentation, issues)
First occurred: 24. Oktober 2022 um 18:10:30 (1 occurrences)
Last logged: 24. Oktober 2022 um 18:10:30

Webhook not registered - https and port 443 is required to register the webhook

and additional:
File “/usr/src/homeassistant/homeassistant/components/netatmo/”, line 172, in async_update

await self.async_fetch_data(publisher)

File “/usr/src/homeassistant/homeassistant/components/netatmo/”, line 199, in async_fetch_data

Anyone?? I checked the board here and followed the ideas regarding webhooks etc. but nothing solved the issue. The Netatmo support sees that Home assistant basically has full access. I also opened ALL Internetports in my fritz box router so the cameras ar currently “fully exposed” to the internet. anyhow. There is still no Videostream!

If Home Assistant is such unreliable I will turn it off and stay with the manufacturer provided solutions and/or Apple home. Even the shellys in use I can “hack” and bring an Apple Homekit integration on them.

I would love to stay with Home assistant but when devices stop working which were flawlessly working for weeks, without any interaction from my side, and i am left alone without help then this App is useless.

I would understand it for Hardware which is a bit “exotic” from China, but Netatmo is not a backyard manufacturer.

I also have trouble with 2022.10 update… sometimes I have to reload the netatmo integration , and sometimes I have to power on off my cameras … I hope it will be better with 2022.11

Meanwhile it is clear that it is a fault in the way home assistant did the netatmo Integration. I can use the cameras in
Apple Homekit
Netatmo Cloud and App
EVE App.

all working flawless. Just HA is not working. Whatever happened Sunday this week, it caused the issue.

Please provide debug logs and diagnostics to inspect. If webhooks are not setup the problem is described in the error message above. About why your cameras don’t show images is a different story.

2022.11 will probably resolve a long standing issue when Netatmo API returns invalid IP addresses due to some caching issue. Rebooting the cameras usually resolves the issue.

I have the same issue.
All 3 outdoor cameras became unavailable in HA. The indoor Netatmo Welcome is working.
During this time I updated to the latest HA version. However I can’t tell if this was the cause of the issue.

Here is a small update.
I have another instance of Home Assistant with an old firmware - 2022.10.4.
I just added Netatmo integration there and all cameras work fine!

So this is definitely caused by the latest updates in HA.
That old version suggests 2 updates:

  • Home Assistant core to 2022.10.5
  • Home Assistant OS to 9.3

I hope someone can find this bug and post a new HA update (or at least revert all changes in Netatmo integration for now)

Hi Andrey, exactly the same for me. This was the only change done last weekend. Update of HA Core and HA OS.

So no need for any log as the issue is clearly caused by HA itself.
This is the answer of Netatmo regarding this issue:

If it correctly works via Home + Security application, that means that the issue comes from Home Assistant. As they are third-party services using our APIs, we are not involved in their developments and can’t see what is happening

In main cases, it’s a problem with authentication (password or configuration changed) or access_token/refresh_token not retrieved. My advice would be to restart your service and, if it still doesn’t work, check your configuration to see if everything is OK

So, My hope ist hat 1022.11 will solve the issue as it is obvious I cannot solve it with any mechanism before.

I’ve been troubleshooting the same issue as the folks here. I’ve tried resetting the cameras, restarting/re-installing HA, re-installing the integration, adding/removing cameras from Netatmo, HomeKit, tried different naming conventions, etc. I have multiple homes in the config, and all seem to work fine accept for the one home with multiple cameras. I originally thought the issue was related to duplicate entity ID’s. Since the troubleshooting, I’ve been able to isolate the issue, and have been able to get any single camera working, if the others are removed or powered off. I believe the issue is the integration itself, it does not enumerate well with multiple devices.

This work around works for my cameras to turn on
(make another script to turn the off)

alias: Tænd Kamera
  - service: homeassistant.reload_config_entry
    data: {}
        - camera.netatmo_udendors_kamera
        - camera.netatmo_udendors_kamera_2
  - delay:
      hours: 0
      minutes: 0
      seconds: 15
      milliseconds: 0
  - data: {}
    entity_id: camera.netatmo_udendors_kamera
    service: camera.turn_on
  - data: {}
    entity_id: camera.netatmo_udendors_kamera_2
    service: camera.turn_on

mode: single
icon: mdi:cctv

Am I the only one to still have this issue with multiple outdoor cameras (presence) ?

Light switch works fine on all camera, webhook works fine from each camera with correct ID and no error in log when in debug mode.

Reconfigured the whole integration and cycle power doesn’t help.

Still only the first camera is streaming and the other ones are shown as unavailable. (Used to work fine before oct 2022)

Please share possible solution

do you have unify router ?

No I don’t.

I have netgear xr500. Didn’t have issue before October 2022.

I tried removing and reinstalling integration while my router bypasses pi-hole (after HA and router reboot) this don’t change anything.

I’ll try tonight removing all the API config from Netatamo and redo the integration from scratch. What I’ve done so far on this end was just resetting the keys (client ID and secret) which worked to get webhook but doesn’t help to get all camera streaming.