Netatmo in HA 0.105

@cgtobi for me the new configuration isn’t a 100% clear, maybe for others as well.

So I changed my configuration as mentioned here:

but my sensors had no values. So I went to the Integrations page and configured netatmo there too. Now the sensors show up again and it works.

However this is not mentioned in the docs. I’m now asking my self if both (Integration setup and yaml) is needed or only one of both options?

1 Like

We decided against putting this in the docs as it is mentioned in the breaking changes section in the release notes of 0.105. It should only be a onetime issue for people coming from earlier versions.

Right now only configuration.yaml is supported. This will change soon (hopefully) and will also get rid of the requirement for a dev account for users.

I read that breaking change, but it’s still not a 100" clear for me.

So the right way to got to 0.105 is:

  1. change the configuration.yaml
  2. login with the Integration page


Unfortunately (because I tried to delete the Integration) all my entities got updated to the new name (sensor.netatmo_home_… instead of sensor.home_ ) so I have to go trough my complete configuration and changes those entity names.

That is unfortunate.

Would it be possible to change the entity name directly in the core.entity_registry?

Also I noticed that the sensors get the name sensor.netatmo_home_... but climate entities get the name climate.netatmo_... isn’t that inconsistent?

Edit: I will restore a backup and start again, because changing everything manually will cause other issues.

That might be an inconsistency. I’ll have to investigate.

I’ve problem with 0.105 and Netamo…

Since the update, my old configuration for the thermostat fail…

Then I try with integration/netamo and the acceptation page open, I accept but then nothing change a all?
No new popup in this webpage nor in the HA.

Anyone could help?

Please try Netatmo in HA 0.105

Other way than integration / netatmo?

My old configuration was:

api_key: !secret api_net
secret_key: !secret secret_net
username: !secret user_net
password: !secret pass_net

But that config give me:
Invalid config for [netatmo]: [api_key] is an invalid option for [netatmo]. Check: netatmo->netatmo->api_key. (See /config/configuration.yaml, line 22)

You have to update your config. Rename api_key and secret_key and remove user and password. After that you simply run the config flow with configuration.yaml option and everything should be fine.

I’ve change my config:

client_id: !secret user_net
client_secret: !secret pass_net

But now when I try to add integration the external website give that:

Missing code or state parameter in

You have to edit the base_url option in configuration.yaml to the external URL of your HA instance. In my case I set this:


You may also have to specify the port number (default 8123) if you’re not using a reverse proxy like in my case. The it would look similar to this:


I hope you get it up again!


1 Like

I’ve not yet ssl configurated on my HA…
I don’t know yet how to configure it with my OVH domain :thinking:

You don’t have any access from the outside world?

Of course but via VPN

I am no expert on this particular matter, but I suspect that external access is required to verify the authentication… :-/

External access is not required.
I just verified this on my dev instance, which has neither ssl nor external access. If after you accepted the account link at the netatmo page and get an empty page just go to your HA tab and it should be authenticated.


I don’t see anymore the netatmo page but only this code:

Missing code or state parameter in

In that case, the fix I proposed should get you across the finish line! :slight_smile:

Problem solved!

Value for

client_id: must be API from netatmo and not username
client_secret: must be code delivered by netatmo and not the password from the app

Thx for your help!!!