Netatmo Linking Not Working

Tags: #<Tag:0x00007f327112b9c0>

Hi All,

Im experiencing trouble with linking my Netatmo account with home assistant.
When I go to the integrations page and add Netatmo, im redirected to the site of Netatmo where I need to give permission to share device information.

When I click accept, Im taken back to a Nuba casa page where the system is waiting for a token, however it always times out and fails the linking procedure.
I have tried the same with Google assistant and it linked just fine.

Schermafbeelding 2020-10-12 om 16.45.01

But if I look in my Netatmo account page for third-party applications its shows the Home Assistant Cloud and Google Assistant.

Has anybody have an idea why it is not working, and how to get it to work.

Have you upgraded to 0.116.2?

Yes I have?

Hi @Jordy_Kleian
There is a problem with Netatmo after 0.116, which is supposed to be fixed in 0.116.2.
I haven’t gone to 0.116 yet, too many problems for me in the transition for now.
There are a few options you can pursue.

  • Post in the thread about 0.116
  • Open an issue on github.
  • Or, as you do it through Nabu Casa, it could a problem there (which is nabu casa support).

I know from previously that Netatmo has implemented some throttling, which nabu casa previously has been hit by, but I don’t know if that is still the case.

I have tried to downgrade to version 116.0 but no luck still the same.
I have posted the same thing in the thread about 0.116 as you suggested.
Hoping somebody can provide a fix for this, because I have some automations that depend on the Netatmo weather station and climate sensors

The Netatmo back end seems to have issue. We just gotta be patient.