Netatmo not working anymore

Since today, Netatmo sensors are not working any more. Integration works, sensors can be added but all sensors do not receive any data. Any ideas to resolve the issues or other people with the same problem?

Note: Netatmo says that their services are down at the moment. This happens quite often. Since Legrand has bought Netatmo, it seems that the services work as the French governement and state: very unreliable… It’s just impertinent for products of such a price.


Same problem. All my Netatmo-sensors are “unavailable”. Have tried to reinstall integration but still no data.

Same problem here, they are all unavailable.
Manually using their API seems to work fine.
Wonder what went wrong :thinking:

There is a “System status” explaining the situation.


Is there a way to not use the Netatmo servers and just have the equipment integrated with Home Assistant?
Strangely all my Netatmo data is still being displayed OK on The Netatmo website


No, Netatmo unfortunately does not provide a local API.

Is there any cheap and reliable option to netatmo maybe? Z-wave, zigbee, wifi or something else?

What a bummer! The latest data I got is now 8 hours old - netatmo really should provide a local API… :thinking:

Hi Tobi, is there anyway you can think of to maybe surface the Netatmo System Status from into HA that might help with these queries every time there is a Netatmo backend issue


Hi Gavin,

I like that idea. I’ll investigate if and how that could be implemented.



This is happening frecuently since Legrand buy Netatmo. Netatmo was great until then. Now is absolutly unreliable.

Have you been able to get your sensors working? Mine have been down since problems on the 18th. Netatmo status on their help page says everything is fine now. I can see my temperatures etc fine on the Netatmo app and on their web portal, but not in Home assistant. I’ve tried rebooting HA and Netatmo but haven’t reinstalled the integration yet.

Do you see anything in the logs?

Mine are back ok.

Apparently just the client_id and secret had changed. Updating those brought everything back online.

1 Like

That is very curious. But glad it’s working again.

Same was for me… down for some hours. My ventilation rely on Netatmo station. Maybe will avoid in future their products…

Same problem here, one year later… how was the problem fixed a year ago?

There is no “the problem”. So it is difficult to give advice. According to the Netatmo status page there is no known outage. Please give more details.

all six sensores “unavailable”. I updated HA during the last days regularly as soon as an update was available. I’m unable to say when it happened first.