Netatmo station weather

I have some problem with last update of HA and Netatmo station . The sensor not appear on states Of HA. Before this update working well.

Which version are you using now? There was a fix for missing sensors in 0.102.1, see the release notes.

yes this is the version… the sensor not work

how could i resolve on Hassio??

Maybe this will help:

There are a lot of people complaining about this I’d suggest you just wait for a new release and roll back in the mean time if it doesn’t work.

ok thank you

The solution suggested in the above link uses the netatmo integration from a previous release, if you do it like this everything will be up-to-date, except for netatmo. However as soon as you update to a new version, netatmo will be updated as well, so you would need to do this workaround again if it still not works in a new version.

In the 0.102.1 version which has just been released this morning, the issue of the missing Netatmo indoor sensors had been fixed. I suggest you upgrade to this version.

The problem still exists with 0.102.1.

not work also in new version

Very weird, for me it’s working!
It’s also in the changelog:

1 Like

What is the exact problem? There is another fix coming for 0.102.2 which is related to manual configuration. Have tried discovery: true and commented our your manual (netatmo related) config?

“not work” is not exactly a precise description of the actual error/problem. Could you please let me know what exactly isn’t working and how you’ve configured the netatmo component?

the sensors do not appear. only the main module of the weather station is present on the home assistant. also in version 0.102.1.

  - platform: netatmo
    station: 'matteo trieste'
      - matteo via udine
      - camera da letto
      - cameretta
      - lo scroscio dell'acqua
      - la forza del vento

As I’ve written above the manual config is borked right now but a fix is already merged and should ship with 0.102.2. But I would really suggest to use discovery mode.

how could i use discovery mode with my configuration?

You’re right! I removed the appropriate manual climate: and sensor: (weather) entries and it all comes back on-line. Thanks!

1 Like

Without seeing your config I can only repeat myself, remove every netatmo specific config and use discovery only.

1 Like
  api_key: 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx' 
  secret_key: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
  username: '[email protected]'
  password: 'xxxxxx'
  discovery: true
  - platform: netatmo
    station: 'matteo trieste'

Either remove the manual sensor config or wait for 0.102.2 and deactivate discovery.