[New Addon] Samba NAS. (Mount external disk and share it )

A local timemachine disk is different from a remote.
Your disk is a local, you connect to Mac by usb/th and needed to be afs or hfs+.
A remote disk is exposed by a NAS and the fs need to be rw for nas.

You need to reformat the partition with a Linux box and then after mount by Smbnas select as external tm target. You lose the current backup and need to begin from scratch.

L

I had this working fine until I broke my home assistant, no snapshots so couldnt restore so I have had to start a fresh.
Anyway as I say it worked fine but now it will not mount the drive at all.

[13:47:01] INFO: Starting the Plex Media Server...
[13:47:01] INFO: Network Disks mounting.. \192.168.1.23/share
[13:47:01] INFO: Mount \192.168.1.23/share
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
[13:47:12] WARNING: Protection mode is ON. Unable to mount external drivers!

Protection mode is OFF but it says its on ?

as far as I can tell everything is the same as it was before but now it wont mount the drive

claim_code: claim-***********************
webtools: false
networkdisks:
  - \\192.168.1.23/share
cifsusername: shaved-ape***************
cifspassword: ***************
cifsversion: '3.0'

ive tried \192.168.1.23\share and //192.168.1.23/share etc nothing seems to work very confusing as I say it definately worked previously

edit im an idiot I had my vpn connected

The addon may be stopping me from creating snapshots.
I was able to create a snapshot fine until I installed the addon and now I get errors like system is in start up state etc

This was the case in my previous HA too but I wasnt sure it was this addon this time however i tried snapshots when I had installed something new.

** EDIT
So this was working perfectly before my recent issues and I cant figure out whats wrong now.
If i have a vpn running my network share will not mount and access to it will be blocked if i turn on the vpn after mounting. Ive disabled firewalls and searched and searched for anything else that might work. I can be on the host machine where the share is which also contains my VM Hass and soon after enabling the vpn I can no longer access anything on the plex server.
If anyone has any idea how I can fix this I would be very very grateful.

i mounted a seagate external harddisk and connect from windows, i tried copy or delete file but failed, say its write protected, in the log shows this:
fruit_unlink_internal: Forced unlink of [System Volume Information/tracking.log:AFP_Resource] failed [Read-only file system]

can anyone teach me how to fix this?

Hello everybody!

i have mount with sucess :

[23:04:10] WARNING: MoreDisk option found!
[23:04:10] INFO: More Disks mounting.. cameras
[23:04:10] INFO: Mount cameras
[23:04:10] INFO: Success!

and have the folder visible and usable with windows pc,

but when i want to record my cameras streams (under Home Assistant with a script) in /cameras it doesnt work. It only works in /media

I have put in config.yaml

  media_dirs:
    local: /media
    cameras: /cameras

i get this error :

Not a directory for dictionary value @ data['media_dirs']['cameras']

i tried :

  media_dirs:
    cameras: '/dev/disk/by-label/cameras'

and

  media_dirs:
    cameras: '/dev/sdb1/cameras'

same error doesnt passed config check

any idea please?
i am under HassOs, latest core and supervisor.

please @Lucio_Tarantino can you help? is there a way to write to the “moredisk” option define in the settings of your addon please?

EDIT : find a better way : add a SSD dedicated to camera streams record : [SOLVED] Mount USB drive in Hassio to be used on the Media Folder with udev customization - #5 by paoloantinori

for those are interested…in combinaison with https://community.home-assistant.io/t/add-on-hassos-ssh-port-22222-configurator/264109 the mount works automaticaly…after install this add on…

First i install the samba add on and as i said in my previous post, it works on the first boot, but not after a reboot of HassOs.

Then i try to mount my sdb1 disk manually, what works but just mannually and i dont find any solution to make it mount automaticaly (like with the [email protected] Add on and his “init_command” option).

Then i found this post about the 22222 port ssh add on, try it, it works for ssh from putty on port 22222 with root privileges.

After a reboot i try to mount my sdb1 disk with no luck in terminal of the the ssh&terminal addon, and the mount command provide a “no such file or directory” and i realise that the disk sdb1 is already mount as expected, i have a the “usbstorage” folder (who is the label of my disk in ext4 format) in /media !!!

then i type “df” in terminal and see the sdb1 mount in /media/usbstorage.

Works after reboot host and restart HA.

so nice!!!

hope it can help other. For me its to store the recording stream of my ESP32-cam and RpiZeroW cam with motion eyeOs.

the folder is accessible with samba add on too with a Win10 PC on my LAN, and is visible with multimedia navigator in HA, so i can play and watch the video encoded in H264 with ffmpeg of all my ESP32-cam or motioneye cam based on Rpi0W.

:partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face:

It is with great pleasure that I announce the availability of version 9.5.1-nas1 of this add-on.

The most exciting new feature is :partying_face:THE POSSIBILITY TO MOUNT DISKS DIRECTLY FROM THE HOST:partying_face: so that they are visible also to other addons and to the Media Browser.

The price for the functionality is to have a HassOS installation (it doesn’t work with other installation types) and to have configured SSH access on port 22222 of the host.

WARNING: It’s an experimental feature, even if I’ve tested it for more than a month without having problems it could cause corruption in the data and in the installation.

WARNING: It is necessary to pass the private key ssh in the configuration of the add-on so eye to security.

:partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face:

2 Likes

lol ! excellent work!

its exactly what i was expected in my post above…lol… continue your good work, thanks!

It havent try yet because as i said it already works with the ssh 22222 addon and your addon…

I have ordered a NUC I5 so i will migrate soon and perhaps try your new release!

thanks

Hello,

i have try your addon but i get this error :

[01:31:28] INFO: Protection Mode is false
[01:31:29] INFO: MoreDisk option found!
[01:31:29] INFO: MediaLibrary option found!
Warning: Permanently added '[192.168.1.XX]:22222' (ECDSA) to the list of known hosts.

[email protected]: Permission denied (publickey).

[cont-init.d] automount.sh: exited 255.
[cont-finish.d] executing container finish scripts..

the host 192.168.1.XX:22222 is not add to know_hosts file and nothing is mount because of the permission denied.

any idea please?

If the ip is the right ip of your hassos installation this mean the private key is wrong.

You must use your id_rsa not the id_rsa.pub. Check if the key start with -----BEGIN RSA PRIVATE KEY-----

Second option you use the wrong id. If your pc is Linux or MacOS try the key:

$ ssh -v -i ~/.ssh/id_rsa \
[email protected]

1 Like

So I used a rpi3 to format a 3.7tb hard drive. Then removed the external har drive and plugged into my pi 4 running this add on. The add on runs fine, but I don’t see the external. I figure I need to add to the configuration but what exactly? Thank you

youre right, in the hassos addon 22222 i used the wrong key.

i try again from the begin and now your addon work great thanks!

@Lucio_Tarantino Thank you for your addon! I just started looking into the new medialibrary option and realized that you only support RSA keys (as the filename id_rsa is hardcoded in automount.sh. Would you consider making the filename/key type configurable (so as to allow id_ed25519 keys, for example)? Or would you be open to accepting a PR for that?

The ‘medialibrary’ option is in its first version and definitely needs improvement.
Feel free to propose a PR for it. I will be happy to accept it.

Hello,

I read through the previous messages but I am running into some issues. I installed the add-on on Debian 11 and it runs fins but I am seeing data in all shares.

config maps ok to /usr/share/hassio/homeassistant
backup maps ok to /usr/share/hassio/backup
media maps ok to /usr/share/hassio/media

but the addons folder is empty and I seem to be unable to add other folders.

I tried to add my /home path in the moredisk section but mapping does not seem to work. Any idea on how I could troubleshoot ?

thanks,

Charlie

The addon is for hassos if you are on Debian 11 you don’t need it. Simply configure samba to share the disks you will.

L.

thank you Lucio, I added Samba at the OS level.

Charlie

Hi,

I am having issues getting the “medialibrary” function to work. SSH on port 22222 is up and running and I can connect via Putty on my windows pc.

I get the following error. Any ideas?

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] automount.sh: executing... 
[18:36:54] INFO: Protection Mode is false
[18:36:54] INFO: MoreDisk option found!
[18:36:55] INFO: MediaLibrary option found!
Warning: Permanently added '[192.168.18.100]:22222' (ECDSA) to the list of known hosts.
Load key "/root/.ssh/id_rsa": invalid format
[email protected]: Permission denied (publickey).
[cont-init.d] automount.sh: exited 255.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] mqtt.sh: executing... 
[18:37:09] INFO: MQTT cleanup.
s6-maximumtime: warning: unable to wait for child process: Operation timed out
[cont-finish.d] mqtt.sh: exited 99.
[cont-finish.d] umount.sh: executing... 
[18:37:14] INFO: Done.
[cont-finish.d] umount.sh: exited 0.
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

Load key “/root/.ssh/id_rsa”: invalid format

You have provided a wrong private key in the config.

You must use your id_rsa not the id_rsa.pub.
Check if the key start with -----BEGIN RSA PRIVATE KEY-----

L.

Hello,
Just installed the addon and it woks great.
Only one thing is weird, I have 2 drives connected to usb ports, and in the log I see both get Mounted with success.
But When I browse to it through SMB, I only see one.
And even weirder I see the name of the first drive but in fact the content is from the second drive

[15:46:53] INFO: Protection Mode is false
[15:46:53] INFO: MoreDisk option found!
[15:46:53] INFO: MediaLibrary disabled in config. Disk are mounted only for this addon!
[15:46:53] INFO: More Disks mounting… My-Book
Drive-2
[15:46:53] INFO: Mount My-Book
FUSE exfat 1.3.0
[15:46:54] INFO: Success!
[15:46:54] INFO: Mount Drive-2
[15:46:55] INFO: Success!

Thanks

Fixed in 9.5.1-nas3. Please upgrade.

L.