New and repeat problem: Stuck on "LOADING DATA" screen frequently

I know I know, there is a kazillion of posts about this problem.

All have the same basic solution:

rm $HOMEASSISTANT/.storage/*

Which means that when this happens every 2-3 days, I have to go through the onboarding process again and modify all my other processes (eg iOS shortcuts and my cloud server that feeds data into HA) with new long-lived bearer tokens. Because: the old API password is going (or gone?).

Can’t we have a better “solution” than this?


Have you tried this:

Have you tried to work out why your refresh tokens are becoming invalid?

Mine seem to last indefinitely.

Have you tried to work out why your refresh tokens are becoming invalid?

Is that’s what is going on? And no. All I know is that it gets hung up on the loading data screen and the only “solution” is to delete .storage (only deleting auth* and onboarding fails to work).

But I will try your quoted ‘password lost’ next time it happens. Even though password is not lost.

So now I’ve had a sleep, my refresh tokens are not going invalid. My comment there was about the workaround to get away from being stuck on “loading data”.

So to clarify:

  1. Periodically the web UI gets stuck on the familiar “loading data” merry go round. There are no config changes. Reboots and restarts don’t fix it.
  2. Everything still works ‘under the bonnet’ / ‘under the hood’. I just have no UI.
  3. Statement (2) includes calls via the API using long-lived access tokens.
  4. The passwords are not becoming invalid. Both the long-lived access tokens are still working on the one hand and on the other, if I clear the cache of the browser and am prompted to log in, it asks for and accepts my userid and password, and asks if it should save it. So that’s all good.
  5. It simply gets stuck at the “LOADING DATA” screen.

So, I followed @tom_l’s advice and tried the password lost ‘fix’. All that did was allow me a new password to be set without the UI without affecting my long lived access tokens. It also took me through the authentication process on the UI (as expected). It also asked me to save the token locally. As expected. And it kept me in the LOADING DATA loop.

So once again the only way I am left with being able to restore access to the UI is to delete everything in .storage.

Which is a crap solution because not only does it force the entity database to be recreated but I have to go and recreate all my long-lived access tokens and put them in all my external processes that feed data into or process data from HASS.

I shouldn’t have migrated from the ‘deprecated’ Legacy API Password.

Meanwhile, any ideas?

I’m working long hours, shift work, and travel 4 hours a day all round the clock so I don’t have time to muck around with this every six hours.

@tdrev figure this one out? I started getting this issue recently and not sure what it’s connected to. I am running duckdns and nginx reverse proxy addons as well.

I’ve seen this occasionally, and all I do is hit refresh, and the page loads properly.

I’ve got this problem now too. (Refresh doesn’t help)

I have also started having this issue since yesterday, as far as i know i haven’t changed any configuration. I also have the duckdns add-on installed and ssl on. However this also happens when i try to connect via it’s local IP.

The api works well, even on the same phone.

It’s probably not a great deal of help to anyone else but mine automagically started working again today.
See HA stuck on 'Loading Data' for a full description if you are interested.

But I do think there might be some underlying issue somewhere…

Yeah mine stared working again, i think this was due to a bug in Browser Mod add-on which is now fixed.

FYI, I was having similar ‘Loading Data’ issue very frequently and it wound up being IP ban: Recurring Issue with an unresponsive frontend

1 Like

in my case i was stuck on the loading data screen when chrome was attempting to create a websocket with home assistant. Brave browser and phone app all worked fine.

i found the only data which mattered in /homeassistant/.storage folder was the “auth” file that contained all the refresh token references. Instead of editing the file directly from cli i just used the brave browser and navigated to /profile → refresh tokens. I trashed all the tokens in the list except for the one that was most recently used. Chrome browser worked after that.