New Aqara light switching itself on unexpectedly

Hi all - recently started adding some Zigbee devices at home (all Z-Wave until now) but having some issues with one device switching itself on randomly.

The specific device I’m having issues with is an Aqara T1M that is randomly switching itself on; sometime main light, sometimes the ring, sometimes both - multiple times everyday.

I did a bit of searching around and saw some threads about some devices clashing (?? :man_shrugging:) and just to make sure that that the devices’ setting for Start-up Behaviour was set to “PreviousValue” so they would revert to as they were before. I have that setting available on the Ikea bulb, but there’s nothing like that showing for the Aqara device:

Anyone have any ideas or suggestions how I might resolve this?

Thanks!

Additonal info on current setup

Connected Zigbee devices:

Other Info:

  • Devices are all on same floor, less than 20ft apart.
  • Using ZHA in HA.
  • Only current ‘automation’ for this device is one that switches on/off based on a (non-zigbee) switch. No current automation for switching it on/off automatically.
  • Nothing useful in the log - only that it’s now on (I’m assuming as reported by the light)

I have been experiencing the same issue with symptoms just as you describe on my Aqara t1m connected via a Conbee iii and using ZHA. I haven’t found any root cause and don’t really know what to try next. I wondered if there was a firmware upgrade but being ZigBee via ZHA I can’t tell.

cheers,
–philip

After going through the ‘Manage Zigbee Device’ option, I’ve found some settings that look like they are the bits that would usually manage the start-up behaviour:

Anyone know if it’s possible to set some value here to force a change to the start-up behaviour - or is this not likely to work because it’s not showing up in HA?

Hello, I have the same problem and have already tried to write start_up_on_off with a 0 and StartUpOnOff.Off, apparently without success because the field remains empty when reading out.

I was able to find that too:

I found a review on the Canadian Amazon site that suggests the light can ship with firmware that has this random turning on behaviour, and that an update is required. As I don’t have an Aqara hub I have no idea how to get an update. My current firmware is 0x00000017 but I don’t know what is current and/or may fix the issue.

The problem does not seem to have been resolved with the current firmware.

Also experiencing this issue. As soon as both lights turn off, they both turn right back on. Doesn’t matter if I turn the main light off, then the side ring light, or reverse the order, or group them and turn them off simultaneously. With one light on, the other will stay off, but with both lights off, it immediately resets to full on.

My firmware is also showing as 0x00000017 and “Up-to-date” in ZHA.

I am also experiencing this issue. Hoped it was the faulty unit I had first (which developed a coil whine), but the replaced unit is showing the exact same issue as described here. It turns on randomly multiple times a day.

Both the faulty and the replaced unit have firmware version 0x00000017.
Using ZHA with a Sonoff Dongle Plus E with Firmware: 7.4.2.0 build 0.

After numerous tweaks to my Zigbee setup I am running out of options to try. I have it wired to a Shelly 2PM to be able to supply it with constant power and be able to turn it on or off using a switch. I was thinking of directly wiring it to the mains to see if the Shelly somehow cuts the power for a millisecond and it’s goes into a default state. But looking at this topic it might just be the firmware.

Before you go changing anything - mine is wired directly to the mains with no other inline devices connected and still have this issue :face_with_diagonal_mouth:

Like everyone else, mine is on f/w: 0x00000017.

I thought I had implemented a temporary fix until a proper one comes along (an automation in HA that when light reports it is on, checks to see if any buttons [linked to light control scripts] have been pushed recently and if not, switch the lights back off)… however, it’s now evolved to bypass my fix and sometimes isn’t even reporting to HA that it’s on so can’t get turned off! :melting_face:

Indeed, mine is doing the same.

However, I’ve installed a second one in my office that doesn’t exhibit this issue, so not sure what’s the matter with the first. I have two others to install so I may replace the one in the master bedroom with one of those in case it’s just a bad unit.

Is there any difference between the one that does work and the one that doesn’t?
Software and/or hardware wise?

They were in the same Amazon order, so I don’t think anything is different hardware wise (and they’re on the ceiling now, so can’t easily check, but nothing stood out to me).
Firmware is the same between the one that wants to stay on:

and the one that respects my nocturnal wishes:

A development: The Adaptive Lighting integration may have been interfering somehow.

I found that the bedroom light does turn off and stay off when I have Adaptive Lighting Sleep Mode turned off.

I do have detect_non_ha_changes set to false as recommended if seeing unexpected turn-ons: GitHub - basnijholt/adaptive-lighting: Adaptive Lighting custom component for Home Assistant so this may be an issue similar to the SENGLED light issue: GitHub - basnijholt/adaptive-lighting: Adaptive Lighting custom component for Home Assistant