New backup to NAS How-To?

Yep, for me too, thanks !

hey there,

did you find a way to see this option? I also run Home Assistant in a self hosted docker, but can’t see the storage option

Your’re amazing. I had to use apk add cifs-util but after that I was finally able to add my Synology NAS as network storage via Tailscale to HA :partying_face:

Hi all,

Trying to add a network share to my Synology NAS for backups. It keeps failing with that unhelpful message:

Mounting Backup did not succeed. Check host logs for errors from mount or systemd unit mnt-data-supervisor-mounts-Backup.mount for details.

I tried everything that’s suggested in this thread, but nothing does help. Did someone figure out where the error message is referring to? I’d love to know where that “unit mnt-data-supervisor-mounts-Backup.mount” is, so I can look for details there.

As the message suggest, check the logs.

Go to Settings/System/Logs and at the top right select either Supervisor for the Supervisor logs or Host for the Host logs.

Otherwise, if you state what operating system or HA setup you are using then it helps other to guess bettet what is your problem.

“The logs” is not exactly clear. There are quite a lot of logs, and I honestly do not know which logs I should check this time.

Fair enough. I’m running Home Assistant OS on an Odroid N2+.

Look at the host logs just after you tried to mount it, as the message says. It is not rocket science…

The operation is executed by the supervisor through the host on HA OS.

The log would tell you more what is the issue.

Phew, I’m relieved. You see, I’m no rocket scientist… :wink:

That said. “the host logs” still doesn’t ring a bell. Can you point me to some documentation where is explained what “host logs” are and where I can find them?

I just did…

Hence the name, the host machine’s log…

Alright. I found the logs. Turned out to be an issue with the NAS: I created a new user for the backup. I needed to manually log in as that user to change the password for the first time, to enable the account. After that, the Samba share started working.

@GSzabados I have some feedback for you: First of all, thanks for taking the time to help me. Your answers were generally correct. However, I felt the tone was a bit condescending at times. Please be aware that not everyone is very sharp in knowledge about the OS architecture under Home Assistant. To me, it’s always a bit confusing. It might seem straightforward if you’re working with it every day, but if that’s not the case, it can be a bit less straightforward than you think.

1 Like

However, I felt that you have not read what I wrote and you have not even tried to follow the most basic instructions that I gave. Both the error message and my instructions clearly indicated where you should look at.

If you feel that something is not documented well, then please feel free to document it, and you can help others.

And just for reference:

Great, so I did not only perceive it as condescending, it was really meant to be condescending. Thanks for letting me know. I feel a lot better now.

1 Like

Dude, why are you still always getting in arguments with people? Please take your time reading someone’s post before assuming they are being malicious. Gábor has been nothing but helpful to everyone on the forums for a number of years now. Keep in mind, not everyone is a native English speaker.

1 Like

Hey, I was just pointing out how I felt, only after saying thanks for the help anyway. I can’t help that people still feel offended.

The only one offended is you… Next time, just flag a post instead of providing “feedback”. Thank you.

Thanks for the “feedback”.

No problem, happy to help. :wink:

I did all of this and got this error

Mounting NAS did not succeed. Check host logs for errors from mount or systemd unit mnt-data-supervisor-mounts-NAS.mount for details.

I have exactly that error too and I`ve tried every permutation

I was able to fix mine. So turns out since I have both ethernet ports connected I have 2 separate IP’s and I was using the wrong one.
image
I was using 192.168.0.5 and got the error, but then I tried the 192.168.2.139 and it connected. Hope this helps