New Google Home device tracker Component - Introduced in HA 0.83


#1

How are you tracking known_devices on Google Home? (Solved)

Current Questions:

  1. It seems like GH bluetooth tracking is adding random bluetooth MAC advertisements to the known_devices.yaml and marking them away when device creates new random advertisements. (even for known bluetooth devices). Any solution for this?

  2. iPhone and even android scanning only seems to be working only if device screen is on (iphone) or manually triggering a scan (android)

Updates from the thread:

  • Works with Google Home Mini as well - Thanks @masterkenobi

  • Might have to scan using bluetooth device once to get it to show in known_devices.yaml - Thanks @gregg098

  • Devices get added with mac address as: < google home IP >_< mac address >
    This could potentially be used for Room tracking somehow


Can Google Home be used as a Bluetooth presence detector?
0.83: Fibaro Home Center Hubs, locks via voice, Traccar
0.83: Fibaro Home Center Hubs, locks via voice, Traccar
#2

Each bluetooth devices detected by Google Home will appear as new device_tracker entity. Similar to any device_tracker entity, if it is detected, then the state will be home, otherwise it will become not_home.

So far, it has detected my Mi Band 3 and my Android phone.


#3

Sorry if this is not the right place to post this, but my iPhone is tracked using nmap tracker.
Should I just add iPhone bluetooth MAC address as another device in known_devices.yaml ?


#4

Are you using anything else to track via Bluetooth.
I’m wanting to keep tracking via rpi and use g mini for room detection.

Is this possible?


#5

I added one Google Home back in and everything loaded OK. It did detect my phone and bunch of other devices, but they all show up as < google home IP >< mac address >.

In known_devices.yaml, the mac shows up the same way. For example (I randomly changed some information so the mac addresses don’t match in my example, but the format is the same):

1921681010_419997b93391:
  hide_if_away: false
  icon:
  mac: 192.168.10.10_41:D4:99:B7:1A:3A
  name: 192.168.10.10 41:d4:09:b7:1A:3A
  picture:
  track: true

It would be nice to parse out the IP and just use the mac address. Otherwise I will have 7 new entries for 1 phone.


#6

I see a bunch of new devices with similar entries in known_devices.yaml, however none of them have my iPhone’s MAC address. Would really appreciate if you could help me with this?


#7

I have an Android and had to scan for new devices (didn’t actually add anything) from my phone for it to be detected. I turned BT off after that and it went to not_home fairly quickly, but after turning BT back on, it doesn’t seem to be picking it up again.


#8

Okay this worked for me on iPhone as well. Went to bluetooth settings, Google Home name showed up in my devices to connect. Didn’t need to pair.
Appeared on HA pretty quickly.
Thanks.


#9

If you get a chance, try turning BT off, wait for it to show as not_home, then turn BT back on. See if it picks it up without a manual scan again. Curious if its working differently for you.


#10

Just did that.
Took about 30 seconds for device to change to Away. Then another 15 to come back to Home.

You may want to look into android settings.

I remember with an iPhone, if I toggled bluetooth from Control center, it didn’t really turn off phone’s bluetooth, only stopped connecting to devices. When I switched it off using the settings app then only it completely turns off bluetooth.

YMMV


#11

I think the point of this is to know where the BT device was detected.
Eg. I have GH devices on 1st floor & 2nd floor so possibly can use this info to check what floor I am on.


#12

Good point.

For the showing Home again, no settings I can really change on my phone and it just stays as not_home unless I do another scan. Hopefully there is a work around.


#13

I just found out that my iPhone bluetooth tracking is only working if Screen is on. As soon as you turn off screen iPhone changes to Away & doesn’t come back to Home unless you open Bluetooth Settings

So I think this behavior is pretty similar to yours


#14

Great stuff! How about multiple Google Home Minis? Is it possible? Thanks!


#15

Can anyone advise how I would use google home tracking with zanzito and asuswrt all together to track devices as “one device”, rather than as separate wifi, bluetooth, and mqtt devices?


#16

You need to combine them in your known_devices.yaml


#17

Interested in this as well. Thanks.


#18

Also from the half-baked knowledge of bluetooth I have, it seems like Google Home bluetooth tracking is adding all the random advertisements/MAC produced by phones and then marking them away when they disappear.


#19

Thanks, is it possible to combine all these methods? :slight_smile:


#20

The below link has instructions on combining GPS/Wifi/BLE trackers in known_devices.