New Google Home device tracker Component - Introduced in HA 0.83


Fair point :slight_smile:

It doesn’t look like they can be detected when they are connected to your phone. But I turned my bluetooth off and had a look at the output of the ghome and found this:


so yes, you can.


TrackR works too when you turn phone bt off


You can use the BLE tracker with the tile as far as I’m aware. You just need to get the MAC address of the device


Joining the thread to see if any headway has been made. I’m still unable to get RSSI to show up but would love to get real room presence set up.


What device are you trying to track?


Moto G4 Play phone.

I have 5 home minis and room detection would allow me to shut off lights when no one is in the room because people have a tendency to walk out and ‘forget’ they were on.

I’ve tried and tried but it just won’t work unless bluetooth settings are open.


If your willing to run an app try -


this seems to be phone specific. I can set my oneplus5 to be discoverable, but I remember that my previous phone only allowed it when the Bluetooth settings were open.


I actually tried that but It wouldn’t work either. I also looked at the activity trackers I have and they won’t show up either once paired with a phone.


Yeah my miband2 would work until paired. Fitbits seem to work fine. I had some luck unplugging the Google home then powering up again to get it to detect and report rssi values. Do you have the Google home set to a static IP address also?


Everything in my house is set to static.


I have had some success with my op6t using that option. Although not as reliably as a Fitbit. Not sure why? I am thinking of getting a


Make sure you’re looking for your Bluetooth Mac address, not the wifi Mac address.


I’ve been attempting to recreate @botts’s setup using a single template sensor, and I’m close! Below is the template I created to contain the name of the Google Home device with the strongest signal for a given BT MAC. Unfortunately, although it works correctly, it never updates after the initial HA startup. Does anyone know how I might HA to periodically re-evaluate the result of the template and update the sensor?

platform: template
    value_template: >
      {% set ns = namespace() %}
      {% set ns.maxsignal = -100 %}
      {% set ns.trackername = "" %}
      {% for item in states.device_tracker
          if item.state == 'home'
          and item.attributes.scanner == 'GoogleHomeDeviceScanner'
          and item.attributes.btle_mac_address == '94:65:2d:6d:e8:83' %}
          {% if (item.attributes.rssi | int) > ns.maxsignal %}
            {% set ns.maxsignal = (item.attributes.rssi | int) %}
            {% set ns.trackername = item.attributes.ghname %}
          {% endif %}
      {% endfor %}
      {{ ns.trackername }}


I figured it out. I created an automation that calls the service homeassistant.update_entity every 15 seconds.


@JayWll I knew there would be a more elegant way of doing it! Nice work! Just need to learn how to write something that way! Also the update_entity has removed the issue of a Google home going “offline”


@JayWll could this be incorporated for the scanning? ?


I just did a quick test, and unfortunately not. At the top of that page it says that those options work with components that are based on the ‘entity’ class. I don’t fully grasp what that means, except that I guess the device_tracker components that get created when the Google Home identifies a new BT device are presumably not based on the entity class.


All in all, this turned out to be less useful than I’d hoped. I found a tile mate at the office we’d received a Christmas Gift from an old vendor so I took it home and attached it to my dog. He gets picked up by one of the Google Homes we have from time to time but generally he’s not found by any of them, even though he actually spends ~80% of his time very close to either the Home Mini we have in the bedroom, or the Home we have in the kitchen.


It’s a similar story for my phone, which is in the bedroom with me (orange) all through the night but mostly shows up as not being found (purple).


I’m definitely interested if anyone has any tips and tricks. For now I’m just glad that I stole the tile I’m using rather than paying for it :rofl:


Have you changed the rssi?