New images, based on HassOS

Hi. I had the same issue using Google chrome. I changed to Microsoft edge and the page showed up. Installed my addons and then openned with google chrome Then it showed up and back to normal.

Hi All,

I tried the new version but my sensor HTU21 does not work.
Has I2C been fixed?

“New” is not a version.

Since when has it been broken?
Did you log an issue anywhere?
Does the ‘new’ version mention it in the release notes?

I stand corrected. Have now installed hassio on ubuntu using docker. Sofar it worked flawless

1 Like

You are right, sorry.
“New” means “HassOS Release 1 build 9 (Stable)”, 32 bits.
Details of the error, based on HassOS Release 1 build 7 (Stable), can be found in my post:


I tried enabling i2c in config.txt adding
after this the “lsmod |grep i2c” command shows:
i2c_bcm2835 16384 0
and cat /proc/modules |grep i2c command shows
i2c_bcm2835 16384 0 - Live 0x7f085000

but at the end the error

FileNotFoundError: [Errno 2] No such file or directory: ‘/dev/i2c-1’
is still there.

Hardware is rpi3b+.
A similar issue has been reported here custom-component-i2c-setup-please-help.

Thanks for your help.

dmesg|grep i2c


ls -l /dev/i2c*

Please see also on github.
I’ll keep you posted if pvizeli’s advice works.


How do I edit netwerk settings?

I setup a rasp pi zero-w on my own wifi network, but it is going to run at my father in law

So educate the new and unenlightened…what is the difference between (which Im currently using) and Hassle in terms of features, abilities etc.

Basically…why would i want to soend the time to upgrade?

?? Hassbian???

Hassio is just a different way to install Home Assistant. Hassio has 2 different ‘flavours’ - the old ResinOS based one and the new HassOS based one. If you are on ResinOS, you should be aware that there won’t be anymore upgrades to the ResinOS Host so that is a good reason to upgrade to HassOS.

If you mean Hassbian it’s not an upgrade - just a different install method that some people prefer because they like to load their Pi up with all kinds of other stuff to break HA.

The actual version of Home Assistant would be the same regardless of the install method you choose.


ls: /dev/i2c*: No such file or directory

I updated the post on github:

Looks like a kernel module is missing, or not being detected.

Any success using USB instead of SD card? I have tried using etcher to get the HassOS image on my USB. Having a RPi3B+

Any solusion for USB boot without SD card?. I have 3b+

I would like to put dtparam=spi=on in the options.txt file, but it is not clear to me how this would work in HassOS. In the start post, it is mentioned that this should be done differently in HassOS but in the configuration documentation I don’t read anything about this.

Sorry, that should’ve said HassOS. OK, the two “flavours” makes sense.

How do I tell whether I’m on the ResinOS or the new HassOS?

Select on the left side, then go to the System tab. It will tell you there.

:+1: looks like I’m on HassOS 1.7 :slight_smile:

Should update to version 1.9 again from the system tab.

1 Like