New Hass.io images, based on HassOS


#266

Please see also on github.
I’ll keep you posted if pvizeli’s advice works.

Thanks


#267

How do I edit netwerk settings?

I setup a rasp pi zero-w on my own wifi network, but it is going to run at my father in law


#268

So educate the new and unenlightened…what is the difference between Hass.io (which Im currently using) and Hassle in terms of features, abilities etc.

Basically…why would i want to soend the time to upgrade?


#269

?? Hassbian???

Hassio is just a different way to install Home Assistant. Hassio has 2 different ‘flavours’ - the old ResinOS based one and the new HassOS based one. If you are on ResinOS, you should be aware that there won’t be anymore upgrades to the ResinOS Host so that is a good reason to upgrade to HassOS.

If you mean Hassbian it’s not an upgrade - just a different install method that some people prefer because they like to load their Pi up with all kinds of other stuff to break HA.

The actual version of Home Assistant would be the same regardless of the install method you choose.


#270

nil

ls: /dev/i2c*: No such file or directory

I updated the post on github: https://github.com/home-assistant/hassos/issues/142.
Thanks.


#271

Looks like a kernel module is missing, or not being detected.


#272

Any success using USB instead of SD card? I have tried using etcher to get the HassOS image on my USB. Having a RPi3B+


#273

Any solusion for USB boot without SD card?. I have 3b+


#274

I would like to put dtparam=spi=on in the options.txt file, but it is not clear to me how this would work in HassOS. In the start post, it is mentioned that this should be done differently in HassOS but in the configuration documentation I don’t read anything about this.


#275

Sorry, that should’ve said HassOS. OK, the two “flavours” makes sense.

How do I tell whether I’m on the ResinOS or the new HassOS?


#276

Select Hass.io on the left side, then go to the System tab. It will tell you there.


#277

:+1: looks like I’m on HassOS 1.7 :slight_smile:


#278

Should update to version 1.9 again from the system tab.


#279

thats what i did (or at least think i did, i clicked update, but 1.9 was not displayed as possible update…), but now Hassos wont reboot fully to the frontend because of the dreaded frontend error:

2018-08-12 22:02:01 ERROR (MainThread) [frontend.js.latest.201808040] :0:0 Script error.

, (is this the bug in language setting?). Since i cant reach the settings in the menu because of this, im stuck.

Can we set the language in the configuration file? (or go back to 1.7?)


#280

??? What is that?


#281

—edit—
luckily i managed to solve the frontend error

2018-08-12 22:02:01 ERROR (MainThread) [frontend.js.latest.201808040] :0:0 Script error.
through a workaround. Because i use default browser Safari on Mac, which gave below situation, I fired up Firefox, after disabling custom-ui i the config files. This loaded Hassio, and gave me the option of changing language.Enabled custom-ui again, restarted, and all is back well now.

So beware of language change until this is solved in hopefully the next update.

cheers,
Marius

---- end edit—

forever stuck with this:

because of this:

54


#282

I am having the same problem. After restoring my backup it just refuses to connect. Did you find a solution to this? I have DuckDNS running on the backup but refuses to connect to IP:8123 or the https: duckdns URL. Putty or Winscp also can not connect. I’ve run out of ideas.


#283

Damn, that sucks that it still happens!

Since I don’t have easy access to my landlord’s router, I ended up installing Raspbian Stretch and installing Home Assistant manually from there, so I could easily connect over WiFi through a GUI after booting up the RPi.


#284

Don’t know… First boot after flashing HassOS takes for ever. Don’t know whats going on. So I wasn’t even able to install my old snapshot. What is going on here?


#285

Any reboot or restart takes forever for me.