New Hass.io images, based on HassOS


#226

#227

excellent! Thanks very much


#228

Well I’ve just got every running on the new HASSos restarted and now I can’t get it to load.
I can access the files and the log yet the page is a no go.

Has one come across this?


#229

I did a snapshot on the old system, installed HassOS and then “select and restore” snapshot. Now the Pi has been unreachable for an hour. Is that normal or should I try to pull the plug and see what happens?


#230

Make sure you are only restoring files and add-ons. You can’t restore the old HA back…


#231

Okay, will try that. I did pull the plug and that certainly didn’t help so is installing af fresh version again. Then I will remove the check mark in the Home Assistant 0.74 box and only choose the rest, and see if that is working.


#232

What does this mean???
I always restore a full snapshot… it only contains configuration information.


#233

Have you tried checking the logs? Depending on how old the snapshot is you might see a bunch of database errors. Try deleting the database and use ssh to restart. Avoid pulling the plug at all costs.


#234

I think it’s quite obvious. Every snapshot has 3 parts: Home Assistant, Folders and Files.

If you restore your snapshot (in the image 0.73.0 - ResinOS based) and choose the Home Assistant part, you’ll be overwriting your current HA files that are HassOS based.


#235

The OS is independent of HA. ResinOS/HassOS no difference with HA.
In fact it’s probably advantageous to import HA as well and then upgrade to avoid conflicts of using old add-on settings with new HA… although it probably doesn’t make any difference.

The recommended manner of upgrading from ResinOS to HassOS is to backup and restore a snapshot without any caveats I have seen.


#236

@DavidFW1960 your answer makes total sense. But in my experience the only way i could get HA to work correctly was the one i mentioned (restore snapshot only for files and addons).


#237

I updated without setting the checkmark in HA itself and it restored, but when it was online it returned a lot of errors, so I tried once again to do a full restore and then just wait. It ended by booting up again and now everything is working as usual again, including bluetooth, so thats great :slight_smile:


#238

Normally if you get errors after restoring a snapshot, deleting the database will fix it in my experience.
I have also had odd results if I restore a snapshot to a working and already configured HA instance (with add-ons etc). However I have never had an issue with a clean install (after deleting the database).


#239

On from what David says, unless you know what you did wrong, deleting the database in any instance of HA not starting up is a good starting point, it’s surprisingly easy to corrupt.


#240

I did delete the database and that fixed the history and log being empty. So a full restore and deletion of database worked for me.


#241

Did you solve this already @frits1980 ?

Thank you.


#242

So, thinking of upgrading my Pi to HassOS. Will use a new SD card. Current will be kept as backup.

So etcher and hassio (HassOS) on new sd card.
Insert in pi 3b.
Boot.
Install samba addon.
Move full backup snapshot to pi.
Restore snapshot (folders and addons). Wipe and restore?
Delete db
Restart HA.
That’s it?

Best regards.


#243

That will do it yes


#244

So I’ve just flashed my Pi2 with a brand new image of HassOS, latest version. It boots (eventually) and loads the screen, but I cannot get to any of the “Hass.io” section. I click on the link and it just shows a blank white page. I have no way of getting onto the box at all; I can’t install the SSH, SCP, Samba or Terminal add-ons, because the page doesn’t exist. I also can’t load my old snapshot for the same reason. Anyone else have this problem or know how to fix it?


#245

I had a similar problem when I was running a Pi NAS using the 3v3 rail from a PC power supply that was also running the HDD. The 5v rail was rated at 15-amps, so I was totally unexpecting “undervoltage” warnings. The problem, it turned out, was the micro SD cable that I was powering the Raspberry from. In this case I solved it temporarily by using a 1A wall-wart supply. The permanent fix was to hard-wire the 5V from the PC supply into the Raspberry.

Sig