New Hass.io images, based on HassOS


#246

Known issue: Hass.io screen not loading (404 error)


#247

No, there are two other threads about Bluetooth problems with the new HassOS now, so I hope an answer will be out there soon.


#248

same problem here


#249

Is there an ova available now? I’ve read a couple conflicting things and don’t see it on the release page. But sounds like some were able to install a earlier version?


#250

My trust in HassOS is running a bit thin. It has been running okay since I updated from ResinOS, but today when I hit the update button in the Hassio panel to 0.75.1 (I think it was) then it has so far been unreachable for two hours. Before converting to HassOS my system was rock solid, but now it is beginning to be a little bit too exciting if the system will get up and running after a reboot.

Is it because upgrading just takes very long or does it go faster for others? Anyone else experiencing a rather unstable platform after HassOS or have I been struck by bad luck?


#251

It took just several minutes for me


#252

I have not tested yet but I hope it would be possible to save the two containers in HassOs and then run them on Ubuntu Docker. Or am I wrong. I will test as soon as my new Nuc arrive


#253

Just you I think, no less stable than resinOS, just takes longer to start up but that’s only particularly noticeable on very slow devices like Pis.


#254

Saving containers is not the docker way.

You just have your configs handy in a bind mount and docker will handle the download of the images necessary


#255

I have a fully working HassOs HA on RPI. I want to move away from all with sd cards to a nuc. For me the best way must be to just move and run the docker image to the new hardware. Not correct?


#256

Not correct.

You don’t move containers. Containers have no data in them. They are disposable. The hassio containers running on a pi are different than hassio containers running on x86 hardware (arm vs x86).

You simply move the config directory over and fire up the appropriate containers on your new platform.


#257

Hear, hear!!!

I’m getting to the point where I am wondering if I want to do something about this. Can anyone point me in the direction of some resources that clearly outline the benefits, dis-benefits and requirements of the various flavours of HA? Remember that I am one of those drawn into this by the promise* of hassio on a Pi, and for a long time thought that hassio was HA.

*A promise pretty well delivered if only it wasn’t such a pain to test any changes due to pedestrian restart speeds (using packages)!


#258

hassio on a Pi is the simplest to set up and get going because it’s the best supported and you can’t get much simpler than flash an sd card, plug it and power into a PI, hey presto, up and running.

You can run hassio on lots of other platforms just takes more work initially but they will be lightening quick in comparison to a Pi. Unsurprisingly there’s a trade off for Pis being so cheap and that’s performance BUT when it’s just doing it’s thing you won’t notice any difference unless you have a huge set up.

If you want to get your hands even dirtier you can go for a completely manual install of HA but there are only a very few cases where it’s an advantage and most users will never come across one of those cases. I did this originally and it’s a total ball ache to install anything that is just one click through hassio add-ons.


#259

Hi. I had the same issue using Google chrome. I changed to Microsoft edge and the hass.io page showed up. Installed my addons and then openned with google chrome Then it showed up and back to normal.


#260

Hi All,

I tried the new version but my sensor HTU21 does not work.
Has I2C been fixed?
Thanks.


#261

“New” is not a version.


#262

Since when has it been broken?
Did you log an issue anywhere?
Does the ‘new’ version mention it in the release notes?


#263

I stand corrected. Have now installed hassio on ubuntu using docker. Sofar it worked flawless


#264

You are right, sorry.
“New” means “HassOS Release 1 build 9 (Stable)”, 32 bits.
Details of the error, based on HassOS Release 1 build 7 (Stable), can be found in my post:

error-while-setting-up-platform-htu21d

I tried enabling i2c in config.txt adding
dtparam=i2c_arm=on
after this the “lsmod |grep i2c” command shows:
i2c_bcm2835 16384 0
and cat /proc/modules |grep i2c command shows
i2c_bcm2835 16384 0 - Live 0x7f085000

but at the end the error

FileNotFoundError: [Errno 2] No such file or directory: ‘/dev/i2c-1’
is still there.

Hardware is rpi3b+.
A similar issue has been reported here custom-component-i2c-setup-please-help.

Thanks for your help.


#265
dmesg|grep i2c

And

ls -l /dev/i2c*