New Hass.io images, based on HassOS


#124

I decided to update to the new HassOS following the instructions here so I can finally use my RP3B+. I made a snapshot before starting and made a copy of the 4 files available over samba share. I have downloaded the new image, flashed using etcher, installed smb add-on, and copied the snapshot back to the new build. The snapshot is about 440MB. When I click restore I get a message asking if I’m sure and I continue then it says it’s doing a partial restore after which point I can’t get back in. Any idea how long the restore should take? Should I see a progress bar or anything? Thanks for any help.


#125

I just restored a snapshot that was around 149MB, and it took a long time. Not hours, but probably at least 30 or 45 minutes, something like that. The green light kept flashing so I knew something was going on, just keep waiting.

Don’t forget to type https:// if you had a password set up previously.


#126

Sorry, that was for you, Mathoosala.


#127

I can’t figure out why it says its doing a partial restore. It is a full snapshot and all the boxes are selected. It’s not restoring my automation or customize yaml files, nest config, etc.


#128

Lol the name confusion.


#129

the mount command will reveal what drives are actually in use.

mount

Also the pathname of the kernel you are running should be found with

cat /proc/cmdline

#130

To do a full restore you have to choose the Wipe and Restore option in the snapshot window.


#132

Hi. Any progress with gpio error??


#133

I have tried that but it still doesn’t restore everything. In facet when I choose that option I can no longer get into HA. I can see the shares via SMB and I can get the login page but it won’t accept my password. If I try to ssh into it I get a message “Disconnected, no supported authentication methods available. (server sent: publickey, keyboard-interactive)”


#134

Is there any possibilities to define network configuration without external usb, after booting up with it and making changes to some file with SSH?

I’ve booted up without external USB stick and with cable network and I can see HA RPi.

Now, if I want to define a static ip or define a wireless connection what should I do?

I don’t find /etc/NetworkManager or /usr/share/system-connections folder

Thanks


#135

Hi

I’ve been trying for a week to get my home assistant back up and running and can’t even get an image to boot any more. The closest I’ve managed to get was it hung for a day on the initialising home assistant screen.

I’ve notice there are new image formats, since the last time I did a full install, so I tried the latest ResinOS 32bit build which is the one that hung.

Just so you understand my setup, I am using a pi 3B, booting from USB without an SD card.

I’ve since tried the 64bit image and I found the HASSOS image, again neither even seem to boot.

I’ve just gone through all the current download options for the pi, finally reverting back to the 32bit image, but I think I right in saying this is the HASSOS one now?

Any way, the config.txt and commandline.txt seem different to the instructions I’ve always followed and using the old instructions, I don’t seem to be able to make it boot.

Please could someone help me out?

Which image am I best using?

Do I need still need to resize the partition and if so which ones (they all have different names now)

Do I need to change the commandline or config txt files, and if so what needs altering to boot directly from usb without an SD?

Finally would it be possible to get the install page updated to include instructions on the above, I’m sure there are a number of people who would like to boot from usb too?

Thanks in advance, can’t wait to get everything back up and running, my Konnected alarm panel just arrived today too, so I’m really eager to get that connected.

Andy


#136

HassOS and ResinOS are not the same and the instructions for USB boot for ResinOS won’t work for HassOS unfortunately. I reimaged a USB stick 2 weeks ago from the latest resinOS image and it installed perfectly so if you are using resinOS you are doing something wrong. It sounds to me like you are using the new HassOS which does have different cmdline.txt and config.txt options in it.


#137

I got this up and running last night with minimum effort. The snapshot restored all my config. No issues so far. Thanks again guys.


#138

Hi, if you look above in my posts you would see that I was in the same situation as you.

What I did:

  • I had a SD-less HassIO working and booting from a USB-SSD only.
  • I flashed the hassos image to my 32GB USB-SSD and extended the data partition (using GParted in Linux)
  • I flashed the hassos image on a 4GB SD
  • I plugged both on my RPI3

For some reason, it boots properly and runs off the USB-SSD (logging in by SSH, running df -h shows that the mount points are coming from the 32GB SSD)

Hope this can help you


#139

So far as you have said, you still have not removed the SD card to see if it is booting from the USB.


#140

Thanks.

Everything (mount, df -h) show that the mounted partition is sda8, which I assume is the USB-SSD (32GB partition).

/proc/cmdline show this:
root=PARTUUID=8d3d53e3-6d49-4c38-8349-aff6859e82fd

but I have no mean to see which partition it relate to.


#141

Whoops, I did but didn’t comment back.

Without the SD card it simply doesn’t boot…


#142
sudo blkid

#143

thanks.

But it returns nothing (I’m logging in through the ssh addon, maybe I’m not in the proper subsystem)


#144

and with the sd-card but without the usb it works normally I presume which means it isn’t running off the usb.