New Hass.io images, based on HassOS


#145

There is a difference between what device is booted from (ie has a bootloader and a kernel present) and what device is mounted as the root filesystem.

I have never booted pi from USB, but it is possible, and some googling and hacking might sort it.


#146

That’s why I asked for the output of the

mount

command.


#147

I am running off a USB only (no sd-card installed) with Hassio on ResinOS but so far as I can see, and no dev has made a single comment about it, it’s not possible with HassOS. (in fact it seems a usb is only used to transfer information like authorized_keys etc)


#148

https://pastebin.com/qXXjGVpq


#149

see also here PSA: HassOS does not use the SD card for wifi settings or authorized_keys!


#150

Thanks, it’s sub-optimal but I can give it whirl :slightly_smiling_face: Would love a solution to mount and boot from USB though


#151

Anyone Experiencing High CPU Usage?
image


#152

well, no luck yet…

brand new RPi 3b+, new sd card, etched fresh download and power on.

lot of things happening, but the messages are (on the HDMI attached monitor)
first line is:
no ethernet found

then final lines:

IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
brcmfmac: power management disabled

no page available on http://hassio.local:8123

https://hassio.local:8123 is my regular Hassio instance

I can see the new hassio on my router, so seems rather odd it doesnt recognize the ethernet ?
what can i do?

tried to enable ipv6 (had that disabled since no use for it) but no change.

Half way the scrolling lines I can see a HAssos login prompt, but it quickly fills up after that…

if i click the enter key, I get the Hassio login prompt again… what to enter?


#153

Mines sitting at a virtually constant 5% but it’s only been going since this morning.


#154

Ok so I’ve got the latest 32bit HASSOS image of the installation pages, I’ve flashed to my usb HDD with etcher.

Do I need to resize any partitions and if so which?

Do I need to add anything to the config or commandline txt files and if so what?

This is what I get just by flashing the USB drive without touching the partitions or files

I have it working with the SD card in, I’d love to know if this can be avoided?


#155

I have the same issue…but I am running a regular Rp3. Says not Ethernet found. I see the LOGIN prompt…but after that it keeps repeating the same stuff…over and over.

Questions:

  1. do you have to have a UUID in the text file for the setup of the Ethernet or Wifi…? I did not have that setup under Resin.

  2. The TYPE I used for ResinOS was ethernet…and that worked for Resin…do I need to have the one stated in manual: “802-3-ethernet”…?

  3. Does the interface-name need to be something different than eth0…?


#156

If you’re using an Ethernet cable you don’t need to do anything other than burn the image and stick it into your pi.


#157

sure, thats what I thought too, but apparently not…

This is talking about a brand new install, not an update of an other Hassio setup.
Would that make any difference?


#158

I will try that when I get home…I just burned a new copy of 1.7 32 bit. So I will try without the USB key first. But The reason I am trying to do the Ethernet Setup is to assure a Fixed IP address.


#159

I have no usb, simply trying to use the default setup. Do have ethernet (and my router sees the hassio…) and have a usb dongle for keyboard and mouse (which is instantly recognized), and hdmi for the monitor obviously.
using this setup instruction https://www.home-assistant.io/getting-started/.

all goes well up to 7.
8 is never reached…

just had a brainwave… using the ip address it popup immediately …


#160

After many tries, I finally upgraded to HassOS. A couple of tips if they may help others:

  • When flashing the image with Etcher on a Windows PC, when it completes you may get some dialogues to format the SD card. DO NOT close/cancel any of these dialogues, just remove the SD card.

  • When I restored my previous ResinOS backup I had many Bluetooth errors (I use Bluetooth device tracker) which stopped the UI loading. Using SSH I commented out the Bluetooth device tracker platform and restarted the Pi3. The UI then loaded although it took some time. I then removed un-commented the Bluetooth device tracker platform to enable it and restarted Hass.io. Now the Bluetooth device tracker platform is working as expected.

Hope this may help others that come across these issues.


#161

Hassio is headless, you never need to connect anymore than a power supply to the pi, everything is then done in a browser on another device.


#162

Set the IP on your router like most people :slight_smile:


#163

Yep, exactly as I described.

Any install is a new one, you only restore a previous snapshot once it’s up and running.


#165

same here using 1.7 32bit on a pi3b